Glowforge offline, "Device Error" when attempting to connect to any WiFi network

We just moved across country, and I was able to get my GF up and running and was happily making things until last night, when it went offline and refused to come back.

There’s a WiFi extender literally 3 inches from the back right corner of the GF, which is what it had been connecting to. Our Internet connection is a bit spotty out here in the country, so it was an on again, off again thing, but more on than off, thankfully.

Since it went offline, I have tried:

  1. Turning off all competing devices (my daughter had just arrived to visit, and I initially thought her baby monitor was the problem) --> no change
  2. Restarting the router, extender, and GF, and refreshing my browser (all of this multiple times) --> no change
  3. Connecting to a different WiFi network --> device error
  4. Connecting to a cell phone hotspot --> device error

This is the error I get with #3 and #4:

Is there anything else I can check or try while I’m waiting for Support to get back from their Christmas holidays?

Not that I think I can provide much help, but when you run the setup, does the machine see wifi or hotspot just fine?

In addition to what @eflyguy (which, up until 37 seconds ago, I kept reading as elfyguy!) said, I saw Support respond to somebody just a little while ago, so they may be able to look at things sooner than you think!

1 Like

What do you see happening in your router management software regarding dhcp negotiation? Anything?

That really doesn’t come into play if she’s tried her phone as a hotspot.

They way I would look at it is that the router management doesn’t see anything. That’s another bit of evidence that the Glowforge seek is not getting out or reaching. Phone may confirm that sure.

I tend to make posts that say, “yes and” rather than “no, not that”.

Oh no, I’m sorry to hear about that! Could you please download the logs from your Glowforge so I can take a closer look at what’s causing the errors?

  1. Reboot your Glowforge once more and wait about 30 seconds
  2. Hold down the button on your Glowforge for ten seconds, until it glows with a teal color
  3. Your Glowforge is now broadcasting a temporary Wi-Fi access point. Connect your computer to “Glowforge XXX-XXX” (from your Wi-Fi Settings)
  4. Visit the following URL in your browser: http://192.168.192.1:3000/logs/zip
  5. A .zip file should download to your computer
  6. Reconnect to your usual Wi-Fi network and email the .zip file to support@glowforge.com (if you’d like to post these to the forum, that’s fine, but feel free to send them via email)

Please let me know if you run into any difficulty with these steps. Thanks!

Thanks for the quick response, @vee! Here’s the file:
Logs-QRQ-699-20191209-205103.zip (3.5 MB)

And I know you know this, but… 2.4GHz band selected?

Yep.

It was working on this network for two days before it died, so I don’t think it’s about the network settings. :slight_smile:

2 Likes

That’s the bit that concerns me. It’s not like this is your first day, so the fact that you’re in this situation sure makes it feel like a hardware issue.

But, I still think @eflyguy was onto a good line of investigation. For that matter, so was @marmak3261. When you, for example, tried to connect to your hot spot, did it connect all the way through? “Congratulations” and all? And in your hot spot, could you see that the Glowforge was connected to it? Not sure if all do, but mine shows something like “x devices connected” and I can see the names of the devices if I look.

Agreed.

… and the GF won’t even show 5GHz networks as an option to connect to during setup. The WiFi radio simply doesn’t have that frequency.

I looked thru the logs and it appears it’s been connecting briefly but then repeatedly timing out trying to reach various GF URLs, like the network was unstable. I assume you’re using the same router for your laptop? One thing you could do is connect to the 2.4GHz band using your laptop, then run Speedtest.

My 2.4GHz speed is abysmal, and it’s not a signal strength issue. I can connect to it reliably from anywhere on my property, it’s just super slow. As well as the GF, all my home automation and webcams use it without issue - except for the camera calibration.

That is EXACTLY what I was experiencing the other day when I posted here in P&S. It saw the access points just fine but flat out refused to connect to any of them.

1 Like

Maybe the baby monitor went somewhere it should not have? I would not trust even a baby one around your pups.

2 Likes

No, I just get the “device error” message.

I can’t find how to see that – will get one of my kids to help me figure it out when they’re finished eating apple pie. :stuck_out_tongue_winking_eye:

Nope, just said I had a device error and to contact support.

Definitely not the best connection I’ve ever seen. We’re 'way out in the boonies; the signal comes from a neighbor’s tower (a mile or two away) via some kind of thingy on the house antenna. It’s abysmally slow and blinks in and out now and then, but it works better than it did before the neighbor who works in the biz put up his tower and connected us to it. :stuck_out_tongue_winking_eye: My phone and laptop have been working okay with it, other than the occasional brief outages.

What does Speedtest on your phone or laptop say?

Ouch. I can’t speak for support, but based on what I saw in the logs and those numbers, I think that’s your problem. Sorry.

3 Likes

I always read it as elfyguy

2 Likes

Thinking out loud - based on how you’re getting internet, I wonder if an antenna alignment might help improve things.