Glowforge only showing last bed image. Stuck on centering

Guys, my Glowforge is stuck on “Centering” and is only showing the last bed image. Is there a quick fix for this? The machine is clean. I’ve cleaned all the lens, and my router has has been reset multiple times. Not sure what is going on.

You can try setting up your Glowforge to operate on your phone hotspot while waiting for a response from Glowforge support. This would also help diagnose whether or not your issue is your wifi connection.

1 Like

I tried that as well. Its connected to my hotspot, but wont refresh the ben image, only shows the last print job image. Still stuck on centering. :frowning:

How long does it usually take for Glowforge to reach out?

I have the same problem, except mine is stuck on focusing. The bed image does not change.

Did it just start today?

No, I am dealing with it for a few days now. Just received an email from GF support to let me know they are looking into this. So hopefully we will know the reason not too long now.

Try turning off the GF, positioning the laser head with the GF symbol directly under the lid camera and turning it back on. Sometimes that helps.

1 Like

I’m having the same issues as a lot of others this weekend. What were your results from Glowforge Support, as they have yet to respond to me. I understand its the weekend, but man. Its frustrating! My machine is a pro, and is only 1 month old. Its not refreshing the bed image, and the arm doesnt move to center up. Thanks!


I am currently having the same issue. I had to replace my black ribbon last week and my machine worked for 3 days and then it stopped AGAIN! I emailed support but it took 2 days for a response. I replied back yesterday with a picture they asked for regarding my pulley and I have not heard back yet. I don’t know what to do either. It’s frustrating especially during this time of the year.

1 Like

How long did it take for you to get a replacement wire?

2 days of emailing and 2 days to ship. But it’s already been 4 days since my initial support this second time around

Hopefully I will get a response soon! I need to be up and running this close to Christmas. Just my luck. lol.

1 Like

Mine is also a Pro and one month old. It really is frustrating. I’m beginning to wish I never bought one and kept my money in my bank account . I have been under considerable stress for a week because of my GF, and this is the last thing we need considering the year we have all had. :frowning:


Maybe our machines are twins!

1 Like

having the same issue with it being stuck on centering and if I refresh the page it switches to scanning… My Pro was also replaced with a new machine less than a month ago…

I am in the same boat, they sent me a new one less than a month ago. And am having the same issue. Started with a weird offline message when I was in between prints, but my internet was perfectly fine and machine hadn’t been moved. Then it takes forever to scan, and still cannot focus without getting an error message. Everytime something goes wrong it literally means risking business waiting for support.

Wow!!! I really hope this isn’t going to be a trend for me! Maybe this lid cable will get me back up and going! So sorry you are dealing with this too!


Hi Andy, did GF support reach out to as yet?

Hello @andyjohnson,

Thank you for reaching out to us. I sincerely apologize for the delay in getting a response to you.

I’ve extracted the logs from your Glowforge and looked at the scanning trouble you’ve been experiencing. The issues you’re seeing look to be caused by a poor connection with the cables on your lid. Please follow the steps below to check the lid connections:

  1. Turn off your unit.

  2. Open the lid.

  3. Using both hands, gently roll the laser arm to the front of the unit.

  4. There are 5 clips pictured below. Check each one to ensure it is closed. The clip should lie flat, and you shouldn’t be able to flip it in any direction.

  1. If any of the clips are open, please take a photo and attach it to your reply. Don’t try to adjust or reseat the cable until reaching back out to us.

The cable should look like this if properly connected:

If you are unsure about any of the connections, please post a photo and we can verify it for you. If everything is connected properly, please turn your Glowforge back on and let it run through its calibration process.

If is still stuck scanning then the black cable on the lid likely has a problem and needs to be replaced. If a new cable is needed, we’ll get one shipped out to you and send you installation instructions.

Please let us know what you find. Thank you!