Glowforge Stuck on Centering after setup - JUST came back from repair!

I JUST got my Glowforge back from repair after waiting 3 weeks. I unboxed it, removed all of the packing and orange parts, went through WiFi setup and it has remained on CENTERING since. The head moved once about a foot to the right and stopped after I turned it on for the first time, but hasn’t moved since. I have rebooted the WiFi router, rerun setup a couple of times, cleaned the lenses (they were already clean anyway from repair), etc.

PLEASE HELP!!! I JUST got it back and I didn’t even get a chance to run 1 job!!!

Often this is a WiFi-related issue.
Can you log into your router and see if your Glowforge is actively connected to it?
Can you try connecting to your phone’s hotspot instead to see if that changes things?


Thank you for your advice!!!

I logged into my router and I can see both machines (I have 2, the other 1 is working fine). I also redid the setup using my phones hotspot… still no movement from the laser head or arm… still stuck on centering. I even reconnected the ribbon cable to the laser head several times.

Any other ideas???

1 Like

Here you go:

1 Like


No. Hopefully @geek2nurse’s suggestion will get you there. Otherwise I think Support will need to advise.

1 Like

I usually go through the entire Forum looking for others who have had the same problem and try all those solutions before I ask for help, and I did find that one with all the troubleshooting tips. I went through all of the steps from that post but the laser head and arm still won’t move… just stuck on centering.

Just months ago I already replaced that lid cable because it was stuck on scanning. Replacing the cable solved the problem but then months later it was stopping in the middle of a file, shutting off the laser but the countdown would continue and the fans would stay on. Even after the job was done the laser wouldn’t go back to home until I turned it off and on and then it would do a different job just fine but then randomly stop later on a different job, no rhyme or reason. That’s why I originally sent it in for a repair.

I inspected it after I got it back but it looks like nothing was replaced it was just cleaned in the areas that you could see but under the panels you could see that everything was just as dirty as it was when it left and nothing looked new, but of course I’m not a Glowforge tech so what do I know?

I just need the machine to work because I’ve already been down 3 weeks and I have a lot of work backed up. Even though I have another basic machine, it’s been running practically nonstop and with Christmas coming up it’s going to get pretty crazy. I just hope it’s something that can be solved remotely.

I’m sorry to hear that you are running into trouble.

I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.