Having Trouble with engraving and cutting settings (after Mac OS update)

My Glowforge app will let me choose the Thickness of the Leather but when I try and click on the Engraving and Cutting out settings the windows for me to choose will not pop up. What am I doing wrong?

Welcome to the forum.

Can you share a photo of what you see when you click on an operation? Did you click “manual”?

1 Like

First screen I can select the leather but then when I click below nothing comes up

When you say “nothing comes up” what do you mean?
The red in this image is the cut line - and you can see on the left it says “Cut” - you are using the PG settings.
The blue in this image is (presumably) an engrave. Because it doesn’t say “Engrave” it means you selected manual settings to override the PG ones. If you want to go back to the PG settings click where it says 1000/99 and click the “Back” button and it’ll take you back to the PG settings (along the top it’ll say Engrave/Cut/Score/Ignore - pick the one you want (if it’s not a vector then Cut/Score will not be an option)

Does that help?


When you choose a Proofgrade material, the cut/score/engrave settings for that material are set automatically. If you want to change the settings, click back or manual.

I urge you to work through the Glowforge tutorials if you haven’t already done so.


That is the problem, there is NO window that pops up for the engraving and cutting just on the material.

Have you successfully completed the Gift of Good Measure or any other project?


What is that? I have another computer and it works fine on it and I can cut. Its just this computer

This is very interesting.

What OS and browser are you using? Are they different between the computer that works and the one that doesn’t?

1 Like

yes one is apple and one is HP

So one is Mac OS and the other is Windows?

The Mac is probably Safari. Do you know what browser you are using on the Windows machine?

(Also, which one is working? Sorry for all the questions; just trying to help!)

Looking at your screen shots above. I am guessing the Mac (Apple) is the one that is not working? (I see blue folders in the background. I think that is a Mac style.)

If you are using the Safari web browser, can you try a Chrome we browser (if it is available for you to use)?

I may need to step aside and let someone more experienced with Macs help you (if this is the case.)

1 Like

using Crome book it is fine and works great on my Mac

it is just when im using safari

Thanks @allabouthimgentlemen

That should help run this issue down. You might need to create a support ticket for Glowforge if this is a specific browser issue. (They don’t actively monitor this forum anymore.)

Does anyone else know if there are known issues with using the GFUI in Safari?

Everything looks fine to me on Safari from my Mac. I suspect an adblocker/popup blocker at the user level is causing the issue.

1 Like

I turned the popup to allow

Is it still problematic if you use Chrome instead of Safari on your Mac?

1 Like

no its fine, I just didn’t understand why its not working in Safari.

1 Like

I’m running into the same problem, did you ever get anything resolved? I have used my mac the entire time I have had my glow forge, just doing this today.

As @dklgood suggested just a bit ago - it’s likely there’s a pop-up blocker enabled. If it was working before did Safari update? @allabouthimgentlemen was able to turn the pop-up blocker off, but didn’t say whether that fixed it!

Both of you - let us know if it helped :slight_smile: