Head Calibration


#1

First off love my pro unit and it’s cutting and engraving great. Camera is crystal clear too. One small issue last night was that every single time I turned it off and back on, including the initial boot up, it would never calibrate properly. I did the turn it off and move the head under the camera trick and calibration worked with no issues. It’s not a huge issue but if there is a “fix” I’d like to implement it.


#2

The fix would be contacting support. They can look at why and implement a fix on their end.


#3

yes, although dan has stated recently that there’s no need to both send an email and post in this forum, so this counts as contacting support these days.


#4

Thanks. I thought I’d try this way to contact support before I go the email route.

@jrnelson - you’re too quick… :slight_smile:


#5

Since I’ve seen this come up so often, and mine does the same, I just move the head manually as standard operating procedure before powering up. Always works that way… unless they force a reboot/recalibration with an update.


#6

My guess is this is on the repair list, since multiples have been having this problem. Probably one of those near-invisible firmware updates will just make this vanish somewhere along the line. I’m sure support still wants to hear about it, as they want to hear about everything that goes wrong in any way, shape, or form.


#7

Thanks for posting this here. I’m looking into the calibration issue.

Glad to hear you love your Pro!


#8

I’ve been doing the same, it doesn’t happen often but it pains me to see that head with like 8 systems in it thumping itself against the edge. It might have happened a total of 7 times in the months I have used this PRU. First time it happened it freaked me out, it’s as fast as a woodpecker. As it paused between thumping I gently moved the head under the camera and it calibrated fine. I reported it and support told me to be sure to turn it off before manually positioning the head to avoid damaging the machine - so I just set it up there and then power up.


#9

this was very helpful! i just got my glowforge today and the print head just kept bumping against the left side. Turned it off, slid the head over to under the camera, powered back up, problem solved… i feel like it’s x-mas!!


#10

Outstanding!
Oh man, if you’re a newb to lasers and CNC like me, you are in for a real adventure into creativity.


#11

I’ll say this… I’ve had to manually position the head a couple of times. But definitely not every time. Not even often enough to give it much thought at all. Just maybe… I dunno… once every 2 weeks. So I’d say you have a little issue.

One thing is to make sure it’s getting a strong, solid internet connection. It won’t home well otherwise. Maybe sit your phone on the Glowforge and see how strong of a signal you get there. Otherwise, all up to Support.


#12

I’m on my 2nd unit. And this one did the same thing. I called it “headbanging.” I figured mine was just into Metallica. But yours is the 3rd such story I’ve heard doing the same thing. Not sure everybody’s talking about the same thing. I’d captured video of it: https://drive.google.com/open?id=0B0PsiEZx6V47VVYwTHVwRFhTdE0
Anyway, mine did that a couple of times and then never did it again.

Congrats on getting yours! ENJOY!


#13

Every time I boot up now I manually move it. It seems 90% that if I do t it moves up half way and repeatedly slams agains the left side grinding every 15 sec. I have reported the issue multiple times. They have got to know its a issue so we just wait and hope no permanent damage is done with the slamming and grinding


#14

Mine is doing that headbang thing when it doesn’t calibrate. I haven’t tried it tonight without moving it as there’s no way that can be good for anything on the unit and I was cringing every time. I’m about 10 feet from the router, one wall, but I’m sure the wireless is fine.


#15

I showed Support my video when it happened a few weeks ago. Their advice at the time was to turn it off immediately. (Which is common sense, of course, but I wanted to capture the video beforehand.)

Yeah, no kidding. They must have done something weird with the calibration process in the past month or something. Never heard of this happening before then. But, yeah, I’d certainly adopt the practice of manually homing the head before power-on if I were you.


#16

Ya I sent them a 15 sec video as well. But one of the times I got home from work fired it up and went into the other room to take care of business and when I can back 20min later it was still grinding the left side.


#17

Congratulations!!!


#18

It sounds like it is not reading the positioning information correctly. So it thinks it has more room to travel.

I have an X-Y ARM in my Cell sorter, and it can lock up once in a while if there is a power glitch and it suddenly goes stupid.


#19

I almost had that happen initially. I switched on, then went to take out the trash. As I was walking out the door with the trash I heard the sound, dropped the trash bag, ran in and switch off. Manually homed, and it never did it again.


#20

I have only used my glowforge a couple times so far, but both times that I turned on the unit it did the exact same “banging” on the left (x min) back (y max) side. I couldn’t quite tell if it was X min or Y max that is the culprit. If it’s Y max, then I have a feeling that it could cause the Y axis to “rack” slightly with the Glowforge’s 2 motor Y axis. All my test cuts seem to have nice 90 degrees corners though. Either way the problem is with the head reaching its limit and the stepper motor skipping steps, or the belt slipping on the pulley. To me it sounded more like the belt was slipping on the timing pulley, but with the lid down during the procedure, I cant really see which motor/pulley is the problem to check. It definitely had that louder more abrupt skipping sound of the belt slipping compared to that of a nema 17 just skipping steps. Unless both Y motors were skipping, or the x axis motor has a ton of current running through it.

I definitely hope they fix this soon, as it’s not good on the belts, or the linear motion system in general.