How to connect to Glowforge from wired computer on network?


#1

So I have successfully connected the glowforge (Sonny) to the network and I can access it from my laptop (wireless) but how to I get to the glowforge app from my workstation (wired) on the same network? Normally I have reserved IP addresses mapped to the mac address, but that does not appear to be an option in the setup. Workstation does not have wireless.


#2

I had to use Chrome to log into the app on the wired computer. I tried every other browser and that was the only one that worked. (It’s what I use exclusively to send jobs though…very stable once you have it connected.) :slightly_smiling_face:


#3

App.glowforge.com will get you there from any device. Am I understanding correctly?

You aren’t directly connecting to the Glowforge. Rather you are connecting to a web service that interacts with the Glowforge.


#4

No web service, just one big happy network. 192.168.2.xxx
This is a single network with several workstations, nas drives, 3d printers, inkjet printers, and assorted wireless devices that connect via wireless access point.

I WAS able to connect to the forge via my laptop, but not my wired workstation.
Curiously, in the time it took to read responses, the forge has mysteriously gone “offline”. The lights are on, fan is running but how do I get it back ONLINE?


#5

Chrome is the default browser on the ranch…


#6

I believe they floated an update through today. Try logging out of the app completely and then log back in. See if it picks it up again.


#7

Got it.

Just to make sure we’re on the same page…

Glowforge connects to your wireless network which allows it to connect to the cloud (on another note: you should probably be able to specify a reserved IP address in your router or wireless AP management console - the method will depend on brand/model).

You then connect to app.glowforge.com which is an externally hosted Glowforge site. That site allows you and the cloud to interface with the Glowforge.

However, the problem here doesn’t seem to be logging into/accessing the app.glowforge.com site, which is what I misunderstood your first message as.

The issue is that you’re having trouble accessing Sonny through the website on your hard-wired PC; it’s showing offline. Right? Sorry for the confusion!

Did you just get Sonny hooked up and running - no prints as of yet? As @jules mentioned, they floated an update to the machine today and while in transit, they probably floated a couple of other updates. I’m not sure of their method of updating (pulling you straight to the latest firmware, etc.) but it sounds like a good chance it is downloading the updated firmware and flashing it.

Try and give it a little bit of time to run through that process and see if you don’t get something going on with the Forge (some calibration movement, etc.). You can turn the power off on the forge while it’s updating the firmware without hurting it, per previous mentions by staff on this forum… If you don’t get a bit of movement after just a bit, it wouldn’t hurt to cut the power and let it start back up. And logging out and back into the app would be worthwhile as well.

If this is leading you down the wrong path, my apologies… but, it might be a little bit before you hear back from support given the time and Friday evening.


#8

Connecting from wireless should be identical to connecting from wired, I am not aware of any specific browser requirements for the app, but I always recommend and use chrome.

If you are not able to access from your wired network I would see if you can get to other websites, if you can’t get to any websites, you need to look at your network setup, or call your ISP if they set it up for you. If you can get to other sites but not glowforge, the website is likely temporarily down. If all that fails, restart your computer, modem, router, and your glowforge and try again.

Anything outside of that would require more information about your setup and what specific issue you’re having.


#9

It sounds like you’re familiar with networking, but I’m having trouble figuring out what is actually happening.

This…

… makes it sound like this network isn’t connected to the internet, that is to say it’s a network with an “air wall” separating it from the internet. If the Glowforge is connected to a network that isn’t connected to the internet, I don’t believe you’ll be able to use the Glowforge.

Is your 192.168.2.X network separated from the internet?


#10

Ah, but if I was having trouble with the network in general (ISP etc) I couldn’t be sharing my joy here!

Don’t know how to reply to more that one person at a time, but for all others helping on the network issues, a 192.x.x.x is connected to the internet, but is a translated address. Once the machine came back online, I was able to get to the app via the wired network. Thank you all for your input!


#11

You could technically be updating from your phone :smiley:

Glad you got it working.


#12

Don’t own a phone. Old school. (ironic isn’t it?)


#13

You don’t own a phone but know that 192 is a private address that requires NAT to connect to the internet? That’s a unique mix of new age and old school. hahah.


#14

Doesn’t seem that strange to me… I’ve known my way around IPv4 (including NAT and private address spaces) since the mid-90s but only got a cell phone in 2008. But I suppose in 2017 it’s a bit odd.


#15

You mean nearly a decade ago? hahahah. #timeiscruel


#16

Finished high school on a slide rule, punched cards in college and I just buried my HP41C.

I also miss grep and vi.


#17

Oh man VI is still around, it was covered in a linux class I took not that long ago.


#18

I use grep and vi (well, vim these days) every day at work. And sometimes at home. :smile:


#19

Depending on where your ranch is in CO (or any number of remote areas in the west), I could see why a cell phone would be pointless. :slight_smile:


#20

I’m glad you’re set! Please post a new topic if you have any more questions.

Thanks for the help @jbmanning5!