Huge Lag on Glowforge Server. Please Help!

I am getting incredibly long lag on a couple files, one of which I have a huge deadline on and need desperately to be able to cut more pieces. This is the second file this has happened on. When I upload it is fine. It works great for several days. I go back to the file to do a second run maybe a week or two later and suddenly the file takes forever to load, when it does load I have to wait minutes to on occasion a half hour or more for selected pieces to do the movement into place that I have already commanded. Sometimes using the the arrow keys to move things slightly takes forever and I have to leave the computer and come back to wait for it to finish (this arrow key lag happens on more than just the two files). At this point on the file I need most, I can’t even get the file to load most of the time. The file has lots of small pieces, but it works fine initially and then becomes unusable later.

I have restarted the browser, I have restarted the computer, I have updated the browser, I have tried a different browser, I have tried a completely different computer. I’ve even tried using a different Internet service provider (both Comcast and AT&T). It is all exactly the same. So I can only conclude it is on the server end. If I have to re-upload the file and start again I will lose a lot of work that was done in the glowforge app.

Please help!

I believe I saw that clearing the cache on your browser will straighten that out. If not, you might need to reboot router, computer and machine.

1 Like

Jules, like I said, I have done all of those things and more. I didn’t list that I have rebooted the machine, but I have and it has nothing to do with the machine. The machine can be off, its using the file on the app that is the problem.

It’s not on the server end. Try a different browser or a different file (re-upload).

You don’t even need an internet connection to use the UI, once you have a design loaded. Of course, you need it connected again to send the job for print.

1 Like

Like I said in my post: I have used a different browser, and a totally different computer even, it didn’t help at all. I have tried everything possible on my end. I am trying to avoid uploading again because I will loose a lot of work if I have to do that and I’m on a deadline. I’m working on the parts while I wait for an answer from the staff. The file was fine for the first week uploaded, it only started to lag about 2 weeks after and this is the second time that has happened…

1 Like

These two suggestions have nothing to do with each other but I have experienced the same problem.

  1. Keep the top of your GF completely covered until you hit the button to print. Sometimes I think the light coming into the GF causes problems.

The only time the glass is revealed is during the actual print. Glass is always covered when I turn on the machine. Also stays covered between prints even though the machine is on.

This is my routine: After the print is finished, I take the project out of the Glowforge, load more material, close GF and cover with cardboard sheet again. Cardboard sheet stays on until I hit print again.

  1. Make a copy of your file and use a copy

Did you try exporting a copy of the file to your desktop? (We can do that now for non-Catalog designs.) Look in the 3 dots.


I would definitely try making a copy to see if the problem remains and then the export like Jules said.

From your description, it sounds like this file is one that you use a lot, and have made a bunch of adjustments in the Glowforge interface. My theory is that over time, those adjustments add some kind of internal complexity or junk to the file that you can’t see, but is slowing it down. Like it might actually, under the hood, have layers and layers of alterations — draw this circle here, then move it, then resize it, then move it again, etc. If that’s the case, you need to get a cleaned up version somehow. Like the good old days when you could spend a Sunday afternoon defragmenting a hard drive. Now that we have export, that should not be impossible.


I’m sorry that you are having a long lag with some of your designs. Thank you for letting us know what steps you have taken so far.

To investigate more can you please tell us the names of the designs in your design library?

1 Like

RBG.svg is the one I am currently having the issue with.

Jules, that sounds like a good work around option if staff isn’t able to help me. Thank you for the suggestion.

I’m sorry for the ongoing trouble. I was able to locate the logs for the design, and when I tested it on our end it doesn’t appear to run into a performance issue in the app. May I have a screenshot showing your layout for the design in the app when you notice the slow responses? It’s possible that the way it opened on our end might not match how you currently have it set up and I’d like to ensure that what I saw matches.

Ivan, Can I email or direct message you screen shots?
I can also take a video of what happens if that helps.

Unfortunately the export of my file and upload again didn’t help me. The lag was gone when I did this, however every single piece in the in the file could only be selected all together. So I need to cut a bunch of 2 specific pieces but I can’t even select a single piece, everything is just one big block. It doesn’t work. I don’t think this is how it is supposed to work, so it might be an issue in the download. I don’t know.

Change the stroke color for the two pieces that you need to cut separately, move them outside of the closed shape, and resave the file under a new name. Anything enclosed inside another shape will always be treated as one unit, but if you have them set as a different color, you can turn the other shapes off by setting them to Ignore.

Or you can remove those interior shapes before resaving the file, then you can move them independently.

So none of my shapes are enclosed in any other shape. There are several different layers and yet after downloading, all of the layers, every single piece is treated as one connected item. I can not select a single item without it selecting all the other items at the same time. There is no way to even move a single piece like it is in the original.

Also, I can not make changes to the the file before downloading it because in the original lags so bad that even opening the file takes 5 minutes and moving even a single piece can actually take a half hour.

At this point I have started redoing the work with a new file because I can’t wait. I will continue to work with the staff to see if we can figure out the problem because this is not the first file that this has happened, and I suspect that even my new work will start failing in a week or so. This is not a good long term situation for me.

Are you not able to ungroup it at all? Are they set up as Compound Paths? (Without looking at the file, it’s hard to tell what’s going on with it. But if you want to keep it private just let support take a look at it for you.)

Correct, the file will not allow for ungrouping at all. Not a single piece or layer will ungroup from everything else in the download. I can try and select a single piece with just one click and it will still select every single piece in the file. Yes they are compound paths that I created in illustrator. I really appreciate the help, and I didn’t want to leave you with questions hanging, but at this point I’m hoping to go over it with staff as soon as they get back to me on their preferred contact to continue, which I assume won’t be till Monday. I have re-done the work I was trying to avoid and have the pieces I need for my deadline. I do appreciate the brainstorming. Hopefully staff can help me. Thank you.

I’m so sorry to hear that you’re continuing to run into trouble. I’d like to take a look at copy of the design file you are experiencing trouble with. Would it be possible to post the design to this thread?

If not, you can always reach out to us directly at support@glowforge, referencing your ticket number (#247068) and we can review the design file directly via email.

1 Like

@Jules missed one step in fixing GFUI browser issues: Clear your cache, and THEN restart your browser. That always fixes the lag for me.

1 Like