I can't seem to select the artwork or move it

I cannot drag any of the artwork and I cannot click on the artwork when it is pasted on the board. Please help/


I cant move art or images or anything around the browser either this is a glowforge end problem please fix asap i have work to do!


Same here! Ughhhhhh

** :roll_eyes:**

PLEASE fix it - so much work to do!!!


Same. Using Chrome on a Mac, worked no issue last night

Same here!!

Same here. What in the world is going on? I’ve restarted my pc 5 times in the last hour lol

It´s nighttime in Seatlle…but Europe is working…want to work

Same problem here. Worked perfectly yesterday with same file. Today, the artwork won’t select to be able to move. I wonder if it is related to the new feature they announced enabling group/ungroup, etc.?

I have sent an email to Glowforge describing the issue and that many are reporting this same problem. Hopefully they respond soon!

1 Like

me too.

Has anyone found a solution?

I’ve had this issue for the past few days. This is awful and unacceptable

Same here!! Has anyone figured this out yet ?

Me too! This is really frustrating. So much work to get done today!

Same issue over here!

1 Like

I was able to work around this by selecting the artwork via a selection box - but the selection box had to be significantly larger than the artwork in question (like 4x the size).

I am hypothesizing that this problem is being caused by the display of the glowforge work area not mapping correctly to the internet browser for some reason.

i have to exit and enter the project everytime i want to select something. it’s frustrating af. and it doesn’t always work.


I’m so sorry for the trouble. We’re seeing this, too, and the team is looking into it now. We’ll follow up as soon as we have more details.

Kind regards,

1 Like

fingers crossed y’all can fix it. i almost cried out of physical and emotional exhaustion trying to move ONE object for over 30 minutes last night. it broke me.