Illustrator Path Cutting Twice

I created a simple rectangle in Illustrator, and for some reason it cuts twice every single time. I just got a new computer (a PC) and installed Illustrator, and on my old computer (a Mac) I never had this problem. So I don’t know what setting I need to change to make it stop doing this. Can someone tell me where to go to fix the issue? Thanks.

Search is your friend:
https://community.glowforge.com/search?expanded=true&q=twice%20in%3Atitle%20order%3Alatest_topic

Whoops–sorry, original comments were for Inkscape. I don’t know about Illustrator…
but if it changed with the new install, try an Illustrator help forum, too.

I’ve never had it happen when using the rectangle creation tool–but always when you do a bitmap trace. (Though have to reread the link myself to see if there’s a trick to avoid it there, too).

Use the nodes setting to delete the nodes/sections for either the inner or outer shape (as described in the link @elfguy provided) if that’s faster for now to figuring out how not to get two copies of the rectangle in the file…

If you’re getting two cuts from Illustrator files its because you’ve got two lines. There is no other intelligence transmitted for number of cuts.

I’m guessing compound path. Release it, then check your lines, squares, etc. You’ll no doubt find the culprit.

Feel free to post your rectangle if you want somebody else to look at it. :slight_smile:

2 Likes

I searched. None of the existing posts address my problem. There is some default setting in illustrator that apparently is different from what I had on my other computer, which is strange, because I’m using the same version of Illustrator. On my Mac version I could draw a rectangle, set stroke to 1, save as svg and get one cut path. Now it cuts in one direction, then turns around and reverses to cut in the opposite direction. I have one path in illustrator.

Any chance you could share an example of a simple file that cuts twice as you describe?

Are you converting the rectangle object to a path?

Problem solved. In Illustrator under “stroke” there’s a setting for “Align Path to Center.” That must be selected. If you have path aligned to the outside or inside of the stroke, it will cut twice.

On another note, I know people should search before posting I question. I do every time. I know you meant well, but “Search is your friend” comes across as very condescending. My issue was not addressed elsewhere in this forum, although it may have appeared that way at first. Just something to think about for next time. Problems can be similar but not the same.

align%20stroke%20to%20center

2 Likes

It’s come up multiple times, including in the last month or two. But it can be hard to know the right search terms unless you already know the answer.

1 Like

I’m glad you got it resolved! I’m going to close this thread for now. If you run into any other trouble, please start a new topic or email us at support@glowforge.com. We’ll be happy to help!