In past week, my Adobe Illustrator svg files are not cutting properly on Glowforge

Please help! During the past few months, my svg files were cutting properly on the Glowforge Pro without issue but this week, the GF isn’t cutting the same files properly - even a simple circle isn’t cut as a round, closed circle. It’s cutting an irregular shape that doesn’t close.

I started troubleshooting by cutting a file from a GF design and the cut works - the circle in the file is perfectly cut. I then wondered if my Adobe Illustrator (AI) file was corrupt so I started a new design in AI and it doesn’t cut properly. It looks perfect in AI and perfect as I upload it to the GF app, but doesn’t cut as shown.

Has anyone else had this happen recently or ever? Any suggestions?!?

Irregular shapes are almost always caused by either belt tension issues, debris on the rails, or a broken guide wheel along one of the axis.


I suggest you print the Gift of Good Measure and closely inspect the result. If the engraves, scores and cuts are as expected, then your problems are with the AI files and not the machine. Try saving one of the AI files as a pdf and see if the problem with the Glowforge interface persists.


Adobe regularly updates their apps, and if a recent update added a feature or changed some setting, it could have affected something in your designs. Have you re-tried an older design that you made in AI and printed successfully in the past? Thinking perhaps default resolution? aspect ratio? pixel shape?(I know, that’s photoshop, not illustrator, but…)

As fas as WHICH change is causing your problems, I’m afraid that comes down to detective work. After a recent photoshop update my default palette layout changed and I STILL haven’t got it back to where I liked it…


Just use the PDF format, it’s more stable.

1 Like

Thank you everyone for your quick responses! I’ll be trying these suggestions today.

Well, we’ve tried everything suggested and more! I have ruled out AI as the issue - it is definitely a Glowforge issue.

Our Glowforge couldn’t be any more clean, the belts are as tight as possible and all the parts look to be in good shape. I honestly haven’t used the GF very much and have only had it 8 months. This morning, I recalibrated the camera following GF instructions. The print turned out horribly and the odd thing was the printer head kept hitting the dropdown lid during the measurement process on the left side only. That can’t be right but we let it go and got the success message at the end of the process.

Then, I performed the precision preview test pattern score. I placed the pattern in all 4 corners of the draftboard and in the center. The top left pattern scored the design very well and then the remaining 4 designs went downhill with each score.

Then we noticed that the laser arm seems to be slightly misaligned, so we performed the Perfect Squares suggestion to square the laser arm. When we turned the machine back on, when the GF pulled the laser arm to the back of the machine after the warming cycle, the right side of the arm slightly coming off the rail. So, we turned it off, performed the perfect squares again, turned it back on and the same thing happened. Now the GF is worse than it was previously.

There is definitely something wrong on the right side and my husband suspects the stepper motor. I’ve seen a post (Laser arm made loud noise and mis-aligned on right side) but haven’t tried it yet. I’ve asked GF support to tell me how to confirm if the stepper motor has an issue but haven’t heard back.

I’ve reached out to GF support via email and phone, attached numerous screenshots, photos, times I ran the files, etc. So far, I’ve been advised to use Set Focus and recalibrate the camera and I’ve done both. I didn’t have the major misalignment of the arm issue until this morning so haven’t heard from GF support on that yet.

We did notice that there seems to be some give in the wheels on the right side of the unit and the left side doesn’t have any “give”. Not sure if that is normal or not.

Anyone have any recommendations? Thank you in advance!

BTW - here are earlier screenshots of when I ran the Gift of Good Measure over the weekend, i n case this gives anyone a clue:

With the machine off, remove the honeycomb tray. With the front door open, look under the laser arm as you glide the carriage arm forward and back. Can you see any impediment or feel any resistance that might be causing it to jump the rail? Gently slide the printhead left and right also feeling for any resistance. Closely inspect the wheels and belts for cracks and debris. Inspect the rails for debris. When you clean the machine do you loosen the belt or simply slide it off and back on?

1 Like

Thanks for the quick reply!

We have already done as you suggested and didn’t see any impediments or feel any restrictions in the movement of the laser arm or the printhead. We also see no cracks or debris in the wheels or belts and have wiped the rails many times. Someone noted the red wire restricting the movement for theirs, but that’s not the case for my machine.

When we have cleaned the machine, we haven’t completely removed the belt but we did loosen the left belt to tighten it after we had cleaned most of the machine. That left belt seems a tiny bit less tight than the right belt, but we can’t get it any tighter.

I purchased new belts that arrived today but haven’t done anything with them yet. Honestly, the machine has 30-40 hours of use and wasn’t very dirty. It looks almost brand new.

If the belt tension is wrong, you get wavy circles and Glowforge logos that are wonky as yours are in the camera calibration print. I doubt that you need a new belt. Many of us have had our machines many years and haven’t needed belts unless there was a fire.✓&query=belt+tension

1 Like

Thank you. It makes sense that the belt tension would be the issue but it seems fine on all 3 belts. You can slightly press one side and the other side doesn’t move. It looks just like the video and photos from the GF troubleshooting steps. I could keep adjusting the tension but it seems roughly the same on all 3 belts.

This morning, I adjusted the tension on the right belt even though it didn’t seem to need it but the issue is clearly on the right side of the machine. Afterward, the laser arm didn’t come off the track after warm up but we could see it slightly adjust the right side once it got to the back.

I proceeded with the camera recalibration again. The logo prints well on the left but gets progressively worse on the right side for the entire page.

During the measurement process, the GF laser arm came off the rail again. There is nothing stopping the laser arm - no material, no wires, there is nothing in its way to stop it. The laser arm and the printer head move smoothly when the machine is off.

There is clearly an issue on the right side of the Glowforge. The tension in the right belt is appropriate and matches the tension on all other belts. The belts are not dirty and do not need to be replaced. We have spent hours checking and rechecking EVERYTHING for debris, cracks, etc - I have followed every instruction I could possibly find in the GF troubleshooting guides, multiple times now. I have sent multiple photos to GF and information so they could review several files.
This barely used machine should not have any issues, yet it does and the likely culprit is the motor on the right side but GF doesn’t seem to have a way to test that theory. As I read other posts with identical issues, it sounds like they’re likely to replace it.

I truly appreciate those we have responded to this post! If anyone else has any recommendations, please let me know.

The only thing I can think of, that would confirm whether there was an issue with the right stepper motor, is to swap the left and right motors to see if the issue you’re having switches sides as well. If it does, then that would confirm the issue is related to the motor, but if the issue continues to affect the right side more than the left, that would indicate the issue is related to motion control components (wheels and or bearings) on that side.

Appreciate the response!

Glowforge Support has been in touch with me to do a little more troubleshooting and it was determined my machine can’t be repaired remotely & must be swapped with a refurbished unit.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.