Interlocking puzzle design help


#1

I’m trying to cut an interlocking puzzle out of PG draft board but none of my dimensions seem to be correct. The draft board is .125 in thick and my puzzle pieces have .125 in slots cut in them. However the pieces I retrieved from the glowforge are NOT the right size. What am i doing wrong? I was under the impression that PG materials would take kerf into account but that doesn’t seem to be the case.

i’ve attached the design file i’ve used.

I would attach images of the cuts but i’m away from home at the moment. But if any of this sounds familiar and you’ve had the same trouble or know of a solution i’d love to hear it. Kinda frustrating on my first project on the forge.

i guess it sparks another question in my mind, how do i KNOW that the image i’m uploading is being respected with regard to dimensions when it gets into the bed view? how do i know that that gap right there is .125 inches wide? since you can resize designs that you load i would hope there would be a way to confirm the expected dimensions or something.


#2

The GF automatic kerf adjustment feature has not been implemented in the software yet. You’ll need to manually adjust for the kerf in your design. You’ll want to measure a cut to see how much it is in your machine for your material. Mine tends to be about .007".


#3

The key to making sure dimensions stay consistent is to place your design in a 20" x 12" artboard. The Matrix in the Glowforge Tips and Tricks category has tutorials for achieveing this in Illustrator, Inkscape, Corel Draw, & Affinity Designer (plus heaps of other priceless tips).


#4

well that’s bummer.

anyone have any suggestions on what i should do with this file to adjust? i suppose if i had two identical shapes each with a slot cut into it to accept the other’s depth, then each slot would need to be ".007 wider in both the x and y directions.

i really wish i had some of my test cut pieces to take pictures of and upload. i made a T shaped object and the width of the t was about HALF the depth of the material when it should have been the same. that sounds like more than .007"


#5

No, there is no kerf adjustment built into the system for Proofgrade. It is possible to adjust for it in a program like Illustrator. (It’s a bit more work in something like Inkscape, but it can be done.)

But the main problem might not be the kerf in your design - the actual measured thickness of the draftboard is probably not exactly 0.125 inches. (The draftboard I have here is measuring from 0.129" to 0.131" thick, so your slots might be designed just a hair too small for the puzzle.)

And for something interlocking like that, you probably wouldn’t want to kerf adjust anyway - you might need a little leeway during assembly.

You can use a caliper to take measurements on the actual thickness of the draftboard that you have, and make your slot size match that…it will probably work a bit better. :slightly_smiling_face:


#6

good idea. gotta find my calipers.


#7

yeah I’ve been thru a great deal of those documents already. i’m trying to get a handle on fusion 360 now as inkscape runs very poorly on my mac for some reason. i have other graphics apps i can use (autodesk graphic) but it doesn’t seem geared for this type of work.


#8

That’s not likely kerf. What design software are you using? There are sizing issues with some export settings depending on the how you save/export to SVG.


#9

my T shape is in this file. the idea was cut square with square hole and t shape should fit into the hole. but the T shape instead of being .125" was about half that wide across the face. made this in Autodesk Graphic.


#10

Make sure you don’t have “responsive” checked on your SVG export. Also, try a PDF export and see if you get the same error

Good luck


#11

Check @hansepe’s suggestion. I don’t use Autodesk so I can’t chase the problem down from that end. But I’ve found that all resizing errors so far have been due to problems with the design software’s output file. A setting prevented it from sending the right SVG. The only known issue with GF’s SVG import is their lack of support for both of the supported SVG winding path methods.


#12

I took your ACAD generated file above into AI and saved it back out as another SVG. It’s dead nuts on (tech term) in the GFUI.


#13

Cool. Thanks everyone for looking at this. I’ll try out the new file tomorrow when I get home.


#14

If you’re comfortable with text editors, you could take a look at the SVG itself. Yours looks like this at the top:

<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0" y="0" width="1440" height="864" viewBox="0, 0, 1440, 864">

That tells me right off you’re going to have trouble because of this part: width=“1440” height=“864”. The width and height need to be specified in physical units or the Glowforge can’t know how big it’s supposed to be and your dimensions stand a very good chance of not being respected. What you want to see is something like this:

<svg id="Layer_1" data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" width="5.53in" height="3.95in" viewBox="0 0 398.06 284.65">

That is a from a file I exported from Illustrator, ensuring the “Responsive” option was unchecked. Note that the width and hight are given in inches, not just numbers with no units. This file will always load into the Glowforge UI at the correct size.

I don’t have Inkscape installed so I don’t know what the correct incantation is to ensure it outputs units, but I understand there to be one. Affinity Designer is another vector editing program but is known to have a defective SVG output that can’t get this right, so you have to open up the file and edit it after exporting.

People on the forum will tell you that making your artboard 20" x 12" is necessary to get things to come out the right size, but this is a popular misconception that certain regulars refuse to stop repeating.


#15

Not required to come out the right size. Required to come out in the right place.

The 20x12 artboard insures that if you put it two inches in and 5 inches up then it’s going to show up there in the GFUI too. And every time you load that project it’s going to load there too.


#16

This is absolutely correct. It’s not, however, what this popular tip says.


#17

Guess that would be me, eh? (Since this is the third or fourth time you’ve referenced it since I put up the Saving SVG reference sheet.)

What I’ve been told, and read here in the forum, is that it impacts sizing of raster image export (as well as placement) in Affinity Designer if the SetView Box is checked on export.

“If the page size is 20x12, AND “Set viewBox” option is checked (AD has it checked by default), the GFUI loads at the proper size regardless of the resolution set in the document (72,96, 300, etc)”

Granted, I don’t have Affinity Designer, so I’m having to base that on what the other people who use it have said.

You seem to be the only one it bothers, but if it’s that bad for you, I’ll reword it.


#18

I have just done some experimenting to get a bit more insight into what’s happening here. I will follow up on the “Correctly save a file as an SVG” thread.


#19

I saw it. Thanks for sharing your results with the group.


#20

That is exactly the way I’ve been using it.