Jagged Edges - Suspected Mechanical Problem

I’ve made 5 attempts now at this engrave. All 5 tries have had slightly different results, but always bad. They all started out fine, but about 5-10 minutes into the print, these jagged, stair-step edges start. And the whole thing design is leaning left. One time, I thought everything would be fine then it looks to have skipped to the left slightly. I tried cleaning the machine, no help. I thought maybe my file was corrupted so today, I recreated the whole thing from scratch. Same exact problem. Using PG maple ply. Any ideas what the problem might be? Oh, for what it’s worth, my machine doesn’t seem to recognize PG materials anymore. Help!

i am no expert but my guess is either your laser head is not seated properly or the belts or guides that drive it left and right are not properly tightened/ aligned . I had something similar and one of the wheels that helps guide the laser left and right along the cross arm had jumped out of the track.


Check your belts and tracks to make sure there’s no debris anywhere that could be throwing off alignment. With the machine off, try moving the head as far as it can go to the right and left, and see if you feel any resistance anywhere.

If none of that yields any useful results, Support will probably want you to print a Gift of Good Measure on PG draftboard, as far to the right as possible, and then post a photo of the results.


I was so hopeful. I cleaned it again, paying close attention to the belts and tracks. Ran the Gift of Good Measure on PG draftboard and everything was perfect. Tried my file again, scaled down, on PG draft. Absolutely perfect! And then, I scaled it back to original size and tried again. Same exact issue! Why? Why would it be okay when scaled down, but not original size?

Is it an artifact in the file? It looks like jaggies from upscaling a BMP file. If you upload the file I’d bet someone would have you fixed in minutes :slightly_smiling_face:

Here’s the file. Trying to scale to around 18" wide.

Well okay, that seems to be a photo. I’ve never uploaded an svg here. Lemme see how to do that.

Zip it first.

1 Like

Mandy sign take 2.zip (4.1 KB)

Okay, I only saw one thing in it that was questionable…it appears that the kudzu vector had shifted slightly relative to the black score lines, and that had them overlaying just a little. Overlapping vectors have caused trouble before…I’m not sure if that was causing the stairstepping as the program tried to move from one vector to another, but it might have.

I moved them back off of the top of each other in this file:
Mandy sign take 3.zip (5.7 KB)

And just rasterized the Kudzu in this one: Mandy sign take 4.zip (112.3 KB)

One or both of those should work, they are already set at 18 inches, so you should not have to scale them. (And let me know if either or both works…I’m curious now.) :wink:


Was it in a different place on the bed when it was scaled down? And then, when scaled up, on a different place on the bed? (I’m guessing so).

What that would tell me is you don’t have a problem with the file - you have something going on at the particular place in the bed. Something causing it to hang and lose steps over that small little area.


It looks worse scaled up for the same reason a photo looks worse scaled up. We “think” in an analog world, things move smoothly from one point to the next. But in computer controlled devices, that analog world has to be approximated. And approximation means quantization error. When you scale something with quantization error down, the errors average out and it looks better… when you scale it back up the errors become visible again.

All 3 pictures are of the same region.

The first one just has a small shift.

The second and third pictures show it skewing over a period of y-movements.

I meant with regard to why the print looked better when you scaled it down. You’re reducing the quantization error that is visible on the full scale print.

That, or given you’ve inspected everything else, there’s probably something wrong with one of the steppers in your GF.

1 Like

I might agree if not for the fact that the trouble seems to start at different times in the operation. And that twice now, it’s been just a single blip instead of stair stepping. Still working on the files that Jules sent to see if those will work.

Since I was using a vector file, that shouldn’t be the case.

Hi, Jules! I was excited to see that rasterizing kudzu cut 20 minutes off the print time. But, alas, neither one worked. In the photos, you’ll see the rasterized (sign 4) had a single skip. The vectored one (sign 3) has the stair stepping. While sign 3 was running, I watched the entire thing to look for some obvious bump or something. But each line printed as smooth as the one before it. I also included images of my screen to show alignment after the print was cancelled. I don’t know if that’s normal.vector%201 vector%202

rastor%201 rastor%202

Okay, that’s good…we’re eliminating issues with the file itself. That single bump on the last file is indicative of a belt slip or bump…and it’s probably either on the horizontal belt that runs underneath the laser arm, or the white ribbon cable might be getting hung up on something.

Try turning the machine off, drop the front door, grab a strong flashlight and a mirror, get down at eye level and slowly move the head postion out to right over where that K starts to deviate. Check the belt under the laser arm with the mirror and flashlight right there…see if there is anything it is hitting on, any debris, any worn teeth…etc. Move the head left and right and see if it hangs up on anything. Check the white cable too as it unwinds…see if it is hanging up on a screw in the channel.

You might see something that you miss while the machine is running.

1 Like

Nothing jumps out at me. The white ribbon is definitely losing smoothly. So I removed the head to get a better view. I attached a few videos. The first one to see if this sounds normal, the other 2 to show the belts guides on each side.