Large-ish (1.2mb) file errors out


#1

I have converted the text to outlines, but this map of Africa with names keeps erroring out.

When I open the app and try uploading this file I get this error.

“We’re sorry and unexpected error has occurred”.

This error is so frustrating because it does not give you any information to work with. I find this error happens much more often than I would like.

Here is the file


#2

Couple of things with that file…

It’s not loading up correctly in Illustrator, it has a tremendous amount of data in it from an engraving size standpoint, and it has 141,062 nodes in it.

This is what it looks like under the black blocking layers (never seen those before), and after removing the fills:

Any one of these things can cause a load error…all three pretty much guarantees it. :anguished:

All I can think of to do with that is to use a Screenshot program to just capture the image from your desktop. It will capture at a low enough resolution that it might load correctly. Windows has a Snipping Tool that works very well.

Then if you want to print it at full bed size, as that original file shows, take that image into the splitting program and split it into fourths.

https://imagesplitter.net/

Take the four splits into a drawing program and align them, then apply your outline rectangle cut (if you want one) and save that as an SVG.

Once the file has been opened in the GFUI, do just one part of the engrave at a time, setting all the other parts to Ignore. Change your LPI in each of the engraves to about 195 LPI before you process that part. And between parts, don’t move the material on the bed, or shift any images on the screen, even if it looks like it doesn’t line up any more.

That’s going to be a very tough file to process if you try to make it large sized. (If you’re doing a wallet sized one - it might not need to be split first.)

Sorry, that one is going to be a pill to process, I think. Maybe one of the other guys has an idea…which drawing program are you going to be using?


#3

@Jules, thanks so much for taking the time to look at this. That you took the time to unload the layers and screenshot it means a lot.

I know that the items, and process, you listed are a great practical solution to this problem and will help me print now. But it brings up a lot of disappointment for me.

Why should a large file cause these problems? Why should we accept the need to split images into four?

Why do we have such non-descriptive error messages?

I have never heard of issues like that with Epilog (the only other type i’ve ever used) or other type lasers. Because we are required to offload our files to the cloud, these kinds of hangups happen. I know that the argument is that by using the cloud they can give us great future features. But so far, in addition to file won’t upload errors, i’ve had real issues lining up successive cuts using the camera alone. I know there are workarounds, but I don’t want workarounds, I won’t it to work.

The detail this machine produces are amazing. The low cost and the beauty of the machine are amazing. But I’m having many issues producing projects that I didn’t have when I used an Epilog for three months.

Again, I know you don’t really have answers to these questions, and I do really appreciate all the time you spent looking at my image, I just think that there are open items in the software that should have been fixed by now.


#4

You are like the guardian angel around here girl. That might make you squirm a bit, but I think how much the community would lose without you around. :purple_heart:
Thank you Jules, for all you do.

@dpmarkman, the software is still beta.


#5

Well they’re working on them, but they’re also working on getting some of the Wifi issues and calibration issues squared away, so no telling where the resizing on the buffer falls in the plan.

It’s a hassle for now, but they’ll get to it.

(And yeah, it’s disappointing to a lot of folks. All I can say is it will get better, and it’s only been a couple of months…it only feels like it’s been longer than that. It’s not unusual to run across things that weren’t expected. They wouldn’t have known how many people wanted to do full bed engraves until quite recently.)


#6

It makes me squirm a lot! :wink::flushed:


#7

“It is known.”


#8

The intent has always been for large files to process and if they are too big to fit in the buffer to cut and then the rest of the file is downloaded. Don’t know if that will be a continuous stream or if the unit would have to pause and load the rest of the design. But clearly that is not yet working. No reason to believe it won’t.

Lining up things precisely will require the head camera, not the lid camera. Again not yet implemented.

And not talking about you here… Some say this should all be easy. Maybe it is, maybe it isn’t. I give those people the same amount of respect I give the group of retired old men in McDonald’s who think they understand geopolitics.


#9

What? Don’t you think everybody would expect a laser to be able to engrave a full bed of objects? I don’t think any other CNC machine has limits on job size smaller than its bed. I don’t know how GF could think a 3 hour limit would be enough. They must have known even moderate sized engraves would exceed that.


#10

@rpegg & @PrintToLaser,

Just like @Jules, thanks for responding to the topic. I think that saying “The software is in beta” is a little too dismissive and flippant. It is a comment that does not help push the discussion forward.

Design is hard enough, and having errors that are not explained, makes it even harder. In my complaint I am trying to differentiate between “It sucks that this error occurred” and “an error occurred and I have no idea why”. The first sentence can be explained by the software still being under development. The second is harder for me to understand. We are all guessing that the reason my file had issues was the size of the file. I exported the svg to pdf and loaded that. It worked fine. So maybe the file size is less of an issue. I can’t learn from the mistake and create a better file in the future if the software does not give feedback on the issue.

Thank you again for trying to help.


#11

Agreed.
Sorry, didn’t mean to offend.


#12

This is interesting…I don’t know that anyone has tried that.

Might be a way to deal with them if we just suggest it up front.


#13

Wasn’t disagreeing. Just letting you know that two of the things you had a problem with are something that is expected to be operational at some point. Didn’t want to leave it with the impression that this is all that you will get. Also have no doubt that there will be improved error messages. We are all waiting. I would rather have my unit now and receive upgrades than defer until I could get everything I paid for.


#14

Sorry…but some of us have not clue one. I have no idea whatsoever… what to expect of a laser. I’ve never seen one, operated one, nor owned one…until now.


#15

If it’s already in Illustrator, why wouldn’t you just rasterize it there or export as a 1-bit PNG?


#16

The one I looked at was corrupted. (Might have been the recent Discourse thing.)


#17

Yes, the file in the original post of this thread has been mangled by Discourse stripping out its style sheet, which causes all of the paths in it to default to fill: black, stroke: none. It’s also apparent from the header that it has been saved “responsive”, so the size has been lost. But the OP presumably has the pre-mangled file and can do something like support suggests in this topic, although depending on the size they may get away with just a single bitmap engrave at a lower LPI.


#18

@Jules and @chris1

I tried to modify my files based on the information in this thread, but now I’m really confused.

I’m trying to work through my files to understand what works and what does not. Having the files as .ai does not help me because you can’t load them into the GFUI, and when I save them as SVG’s, the country boarder lines no longer line up. This lead me to saving as PDF’s which can be loaded into the GFUI.

So I made a new .ai file that has two layers, the country names and the country boarders. When I turn one layer off and save the file to PDF, the file loads (even though it is 3.1 mb, takes forever). Each layer individually loads in the GFUI. However, when I save the PDF file with both layers on, it will not load.

PDF with just country names (works)
WRLD-AF-02-0001-For-Glowforge-bigEdits_Just_Names.pdf (3.1 MB)

PDF with just county boarders (Works)
WRLD-AF-02-0001-For-Glowforge-bigEdits_Just_Lines.pdf (3.1 MB)

PDF with both layers turned on (does not work)
WRLD-AF-02-0001-For-Glowforge-bigEdits_Names_Land.pdf (3.1 MB)

Illustrator file (cannot be loaded into GFUI):
WRLD-AF-02-0001-For-Glowforge-bigEdits_Names_Land.ai (9.1 MB)


#19

Okay, got your AI file working just fine…but I had to do a few things to it:

  1. Removed the clipping mask

  2. Simplified the number of nodes from over 69000 to 3775

  3. Combined the double overlapping outlines of the states into one engravable image. (Pathfinder - unite)

  4. Converted the Text to fills, and removed the separate treatments of strokes on them. Expanded and combined the strokes with the fills. (Might have been used to thicken the fonts.)

  5. When the file opens up in the GFUI - used the Manual settings to change the engraves from 450 LPI to 270 LPI.

And it still takes several minutes to process, so give it some time.

39 minutes to print at that size. (But I left the option in it to treat the text as a separate engrave.)
(All of this reduces the 9.1 MB AI file size to 211 KB, which the interface has no trouble accepting.)

WRLD-AF-02-0001-For-Glowforge-bigEdits_Names_Land3.zip (211.2 KB)


#20

So kind of you to do all that work! :clap::clap::clap: You are a :star2:!