LPI Buffer Size Limit?


I’m trying to engrave a rather small/detailed image (2.65"x3" at 600dpi). I can engrave fine at 675 LPI, but when I try to shoot it up to 1355 LPI, I get a failure to load error when preparing my artwork.

I’m assuming this is exceeding some kind of buffer, but is there a way to know what that limit is? This is a relatively small image. The SVG is all of 1MB or less with an embedded bitmap image and a vector path for the cut. Is there anything I can do to overcome this problem or method to increase the buffer size?

Print job failures

It’s a known bug when engraving large stuff. It’s my #1 complaint to be fixed as of now, so they are very aware of it. If you try resubmitting it sometimes works, the other thing you can do is print your design in chunks.

If its possible, ignore some parts of the design, print the rest, don’t move anything, ignore the first bits and then print the rest.


As the motion plan is sent to the GF as waveforms there is a total time limit of about 3 hours. If you work out the total distance i.e. length * width * LPI and divide by the speed in inches per minute (not the obfuscated speed) you can estimate the time.

You may be able to get 1355 to work if you double the speed but I don’t think it will get better results because the beam is a lot wider than that.


Hmmm interesting. This is a relatively small image and I’m maxed out on speed (1000).


We may be interpreting Dan’s comment about 3 hours too literally. In any case, it does seem very likely that the problem is what you think it is. The size of the output of your job, in whatever low-level machine control format Glowforge has come up with, is limited. So it’s quite easy to take even a small engraving, crank up the settings, and get a failure to chooch. I would assume there’s another limit at play here as well, taking some guesses at the kind of architecture I’d build for this. Presumably when you press that print button, your job is queued up for processing, and at some point a free worker comes along and grabs it and turns it into GF-Code. That process itself may time out before finishing, even if it was on its way to generate something that could fit in the Glowforge’s memory. That might explain why resubmitting sometimes works.

I’ll give them a free user story that should be in the backlog if it isn’t already:

As a Glowforge owner, I want the entire job pipeline to support the maximum possible size file, at the maximum possible quality level, so that I can design projects without having to worry about being unable to print them.


How long does it say it will take at 675 LPI? If it is more than 1.5 hours that total time is probably the cause.

@chris1, yes GF have hinted there are several failure modes due to bugs in the cloud as well. Not good system design if they have not got enough resources in the cloud to process a small 2D image in 2017.


At 675 LPI it’s at 28 minutes. It’s a small engrave… but there are small details, so I want highest possible LPI to help with the outcome.


Not that it fixes your problem, but I’ve found (as well as others) you can hit a point of diminishing returns if working with an organic material, like wood. The increased LPI actually causes loss of detail due to overburn.


Yep. If nothing else, you have to back off on the power. Somewhere between 125 and 250 is the “natural” lpi where the dot size is the same as the raster spacing. If you do it smaller you get smoother edges but at the cost of multiply-zapped non-edge regions.


Great advice and ideas here! To add one more to the list, you can divide your image into pieces and print them one at a time:

Split your image into pieces

  • Save your design as a PNG file
  • Go to imagesplitter.net and upload your file
  • Click on the “SPLIT IMAGE” tab and enter the number of rows and columns you want to split your image into
  • Choose PNG
  • Click the blue “SPLIT IMAGE” button. The software will split your image into the number of rows and columns you specify and automatically download a zipped file of the pieces.

Create a single file with all the pieces
Locate the file on your computer (where your downloads go) and unzip it

  • Mac: Double click on the file to open it
  • Windows: Double click on the file to open it, then click “Extract All”
  • Open a new file in Inkscape (used for this example, although other software will work too)
  • Choose File > Import and select all the images from the zip file
  • Line up the images up so they are seamless. In Inkscape, when you drag the images near each other, they will snap together. (If they don’t, go to View > Show/Hide > Snap Controls Bar and adjust the settings.)
  • Select File > Save As and save the file as an Inkscape SVG file

Upload and Print

  • Sign in to app.glowforge.com, click “Upload” and choose the file you savedEach piece of artwork will import as a step in the app. Click on a step and choose “Ignore.” Ignore all the steps but one, and then press “Print.”
  • When that print finishes, leave your material in place
  • Set the step you printed to “Ignore” and print another step
  • Continue ignoring and printing until you’ve finished

Would you let us know how it turns out?


What type of engrave is it? I can imagine the map grey scale to power uses more memory than the dithered options.


Yeah, I noticed that when I did some tests a while back. But I found 1000/80/340 LPI gave a good result… so I Engrave at 1000/40/675 LPI and the result stays more or less consistent. So I was trying to engrave at 1000/20/1355, but it still seems to be overloading the buffer.

All this is just standard dots.