Print job failures

I’d like to re-open the discussion around engraving large files. In particular, I would like to have the ability for the machine to automatically split and print my file in pieces.

I’m trying to engrave a design with lots of fine detail that can’t be simplified further. Here’s a screenshot of a section of the engraving I’m trying to do:


The problem I keep having is that the file will randomly fail without explanation. From my research on the forums, it sounds like my file is too complex, resulting in a final instruction set that won’t fit in the machine’s buffer.

It was mentioned on this thread that a solution is to split the image into multiple parts, and print that way.

The entire image is very small, about 7" square. I understand that such small line work will run into issues where the width of the laser will be wider than the line it’s trying to engrave, but this is not a concern for my particular application.

My thinking is that the end-user shouldn’t need to think through this, and at the very least, we should get more info on what’s happening when it fails. Ideally, I should upload a design of any complexity, and it would just give me a warning saying that I’ve uploaded a very complex file, and that it will run in parts. Then, the cloud side of the application should automatically split the job into parts, upload a part to the machine, engrave the part, then continue on the next part until it’s complete. The parts should be automatically split horizontally, so that any slight misregistration between the sections is less noticeable, and the machine can continuously engrave without the end-user even knowing where it is in the process.

Too complex generally means it exceeds the buffer size/max time limit - not necessarily that the image is too complex.

What settings are you trying to use - speed and LPI?

I’m running it at 340lpi, “1000” speed, and about “40” power.

Did you ever get an error saying that it was too complex?

That’s a pretty dependable error message as far as getting error notifications.

1000 speed is 335 inches per minute. Not considering deceleration time etc, I believe you should be under the limit.

I suspect something else may be causing it to error out.

As for the complex thing, it’s kind of a bad error message. It really means it’s going to take too long for the buffer. The actual fine detail and complexity doesn’t really matter since every step is defined in the plan. In other words a very complex 7x7” image has the same size motion plan as a 7x7” square.

Try knocking it back to 225 LPI.

I was assuming that it was because of the file size, but perhaps something else is going on. Here’s the error I’m seeing:

Try knocking it back to 225 LPI.
If that doesn’t work, you can zip the file and upload it here for someone to take a look at it.

Vector or raster?

I’d try it rasterized at a nice high DPI and see if it works out.

@Jules I’m not able to actually get to the preview screen, since this error happens while rendering the design.

@evansd2 I’ve tried both. The raster version uploads ok, but when I go to print, it just says that it’s preparing the design for a long time, then closes the screen and returns to the preview window. (No error message.)

Ahhhh…okay, might be something in the file. I’ll take a lookie.

Oh yikes…that has about a billion paths in it. Let me try rasterizing it and getting it opened. What program was it created in?

I drew it in Illustrator, and I figured that something like this may have been the issue. Is there a suggested way to flatten the drawing?

Yeah, hang on…let me see if it works first before giving you the go-ahead.

Okay, yeah that worked…

I think any time you get something that has that many paths in it (awesome creation by the way) you’re going to want to rasterize it. The commands necessary to create thousands of little hairs are just too much for the buffer to handle.

This is the result of rasterizing the dog vectors at 300 ppi and transparent background…great results that had no trouble opening and it will take about 25 minutes to render the dog:


Thanks for testing this out! Did you confirm that this would indeed start printing? I’ve gotten to this point before, and had it randomly cut out when I tried to print.

It processed, but I didn’t start the print. (There’s a big storm starting up here and I’m about to turn off the machine. I got the blinky white light though.) :grinning:

Interesting! Ok, thanks I’ll see what I can do with this - good to know that you made it that far!

If you want to try this one you can…

1 Like

Oooh - thanks for uploading. Now I understand what you did. I was thinking you exported it as a PNG, at 300dpi. I was going to say that I’d tried that and it didn’t work, but I guess for some reason it seems to be ok when it’s embedded in an SVG.



Thanks for the answer @Jules. I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic.