Motion Path Failure

Annoying failure just now. I was cutting some 1/4" acrylic from inventables, and cut lines that should not have overlapped… did. Motion-plan preview looked fine, file looks fine to me. Went back to the GFUI, rotated the image 180° and tried it again. Worked fine the second time.

But… why did it fail the first time? It didn’t get bumped. The air assist did not move the acrylic. I wasted a 3"x9" section of 1/4" red acrylic (would have been more, but I can salvage part of it).

What can I do to ensure that this does not happen again to the next $24 sheet of material?

OSX 10.11.6 / Chrome 62.0.3202.94 / approx 3:10 PM (PST)


Is there something on the rail that is hampering movement?

1 Like

There does not appear to be anything on the rails. I guess there could have been something in a belt-tooth that fell out between the operation and my inspection.

Just now I turned off the machine, slowly moved first the gantry all the way forward and back, then the head all the way to the right and back to the left. I didn’t feel any extra forces or stutter through those movements. I cleaned the rails with zeiss wipes anyway.


I would have guessed something in the belt. Did you try another one (in that position) on something like cardboard to see if it’s still happening? That looks like the far right edge in the front?

1 Like

Just tried same file, same placement, on cardboard: no issues.

1 Like

(I wrote this post and prepared this image before seeing the remade cardboard image above.

There’s definitely something wonky happening here too.

The top line looks OK, the middle one looks like it was truncated on the right, and the bottom one looks like it was truncated by twice as much on the left.
Was this piece of material on the left side of the bed? Were there any objects to the left of this? It looks like it cut the top line and the outsides of the letters, then started cutting the middle line and somehow lost some X movement, then lost some more when cutting the bottom line.
The funny thing is, both the middle and bottom lines seem to be cut basically correctly, they are just shorter. If it lost X motion because of running into something or because of being jostled or something, the middle and bottom lines would either be the same length but in the wrong position, the angled lines would be messed up, or either the top or bottom cut wouldn’t meet up correctly.


I had something similar happen with my GF - unfortunately the fix was for them to replace it. I hope you have better luck!


Looks like the tail of the “r” is cut off. That’s clearly a place where the X motion stopped working correctly. Probably collided with a physical limit.

Also, it looks like the “r” is farther to the right on the acrylic than it is on the cardboard. Thing is, the centers of the letters are even further right. I suspect the head (hardware) was physically further to the right than the software thought when this cut was started.

It looks like the insides of the letters were cut first. They cut correctly, albeit too far to the right. Then when it tried to cut the outsides of the letters it collided with the physical limit on the right. Since they are steppers and there’s no limit switch the machine was none-the-wiser.

It looks like the outsides of the letters started being cut near the tip of the tail of the “r”, which makes the location of the error difficult to spot.

What would make the head hardware be farther to the right than the software thinks?
The head getting knocked.
Bad homing (root cause: no limit switches).
Running into a physical limit on the left with no way of knowing (root cause: no limit switches, usually).
Maybe some kind of belt slippage.
Pulses not being transmitted successfully to the motor drivers. (doubtful)
Bad motion planning. (also doubtful, IMO)


Might have been a one off thing. We saw them with the belts on the 3D printers - every once in a while the print got knocked out of alignment (usually from contacting warping PLA) but once in a while if something got in the belt it might do something like that too.

If you have a magnifying mirror, you can reach under the belt and check a lot closer than you can just by eyeballing it.

But since you got a good cut afterwards, I would take a chance running it again. (Of course it’s not my $25 sheet of material, so if you wanted to break up the file into different colors and take them one at a time just to make sure, it might be cheaper.) :wink:

1 Like

I hadn’t noticed that…I’ll check it out when I go back in the morning, but looking close at the pics I think you are right. I was too distracted by the overlaps to notice the truncated tail. Nice catch!

Pretty much, yeah. Cut order was: upper line; lower line; counters (the insides of the letters); “L”; “ower”; middle line.

So yeah, the head must have lingered, for whatever reason, and the motion path from then on is shifted.

Just before this, I had cut the first part of the design. It was also 1/4" inventables acrylic, and it cut perfectly.

FWIW I was using the ‘proofgrade thick clear acrylic’ settings.


Thanks for letting me know about this. I’m so sorry about your material. I’m taking a look at what happened.

1 Like

Good call; I brought in an illuminated inspection mirror this morning and peeked around under the rail. I didn’t see any obstructions or blockage/damage to the belts.

1 Like

There’s like, a gazillion lines of code running, so why the focus on the hardware?

Okay, so maybe not a gazillion, but still a lot of code. The letters look properly formed, which implies the gantry is doing ok - just following orders.

It never occurred to me to document it when it happened, but I’ve observed some wonkiness in the preview window just before starting a print. Was there any hint in the preview window of this error?

Given the error was in the lower-right corner, maybe this posting is related?

There are no limit switches, and it appears the motion code will plow ahead even if it hits a minor obstruction. I recall seeing a video showing how the system will halt if you leave a coffee mug in the chamber, so there might be a way for that failsafe to be more sensitive.

1 Like

Thanks for your patience. Unfortunately, I believe it would be best to replace this unit. I will reach out to you via email to sort out the details. I’m sorry for the bad news!

1 Like