My .svg files will no longer upload into the glowforge app

First I have followed all the instructions that I have found to try and troubleshoot this issue myself. I use CorelDraw and up until this past Saturday have never had any issues. When I create a new .SVG file and try to upload it onto Glowforge I get an error saying it cannot complete the upload at this time. I have cleared my browser, I have tried a different browser, I have changed the name on my .SVG, I have even saved a circle (curve) in .SVG format and tried to upload that and it does not work. I have reset my CorelDRAW settings and that has not fixed the problem. I do not know what else I could do to fix this, but I would really like to get back to cutting if anyone can help.

I don’t use Corel Draw so I can’t help on that front - but can you upload your .svg here so someone else can see if it uploads on their machine?

A couple of hours have passed, but if you still need help and will share your file here, someone will take a look at it.

i am trying to get my file to upload into this chat and it is not working either. So I will keep trying hopefully it works shortly

When you upload it defaults to being tiny - like 10x12 pixels, but you can click on the line that says ![image|10x12] and make it bigger by typing ![image|498x319] or whatever.

You can upload by clicking the icon, or dragging the image into the box - but if it’s an .svg with a raster image imbedded into it, the raster will disappear. You can zip that type of file.

After spending a good portion of my day uninstalling programs, then reinstalling my programs, and essentially making sure everything on my computer is working as it should. I still have not been able to get my .svg files created using Coreldraw to work in glowforge including the formwhy . I know they are fine since even when I create an .svg like a circle I can pull it up with no problem using other applications. In the attempt to find something that would work I downloaded inkscape. I can upload the .svg file no problem into inkscape. I then save it in inkscape making absolutely no changes and somehow miraculously the file works. I do not know why this would work, but it does. So for now I have a workaround. Hopefully I will not have to do this permanently though. I have attached the .svg after saving it in inkscape so you can see how basic a file it was that hasn’t been workingwhy

I tested your attached file, and yup, simple, no problem.

But it sounds like that one works fine for you too? Can you upload one of your examples that doesn’t work fine for you? We may be able to help more.

If you can’t even get that file to upload here… maybe it’s very big some how? Seems unlikely… but trying to guess :slight_smile:

Hi @StewartLittle. I’m sorry to hear that you’re running into some trouble uploading your design files to the Glowforge app recently. I see that you’ve been getting some great advice from fellow owners, and I also saw your opened email ticket. I’ll be happy to help with any troubleshooting for this as well.

Our software has trouble processing certain design elements, and it looks like that’s what’s happening here. I was able to upload the files by opening them in Inkscape and saving them in the “Plain SVG” format (as opposed to Inkscape SVG), which removes most program-specific SVG code.

It sounds like you were able to test this yourself as well with using Inkscape. Unfortunately, this looks like it may specifically be due to recent incompatibility with CorelDraw if the designs are able to upload using Inkscape.

If you’d like, feel free to post a SVG file that has failed to upload for you, and we can take a deeper look at any other potential causes. Thank you!

Unfortunately, every time I try to upload an .SVG onto the form I get this warning: “Sorry, but we couldn’t determine the size of the image. Maybe your image is corrupted?”. As we have been able to determine the file is not corrupted. It is a compatibility issue currently going on. I have not changed or upgraded CorelDraw so I can only guess the issue has arisen from a recent Glowforge update. I am obviously willing to do the workaround for now so I can keep creating and making. I just hope that an actual fix could be created so that I don’t have to use Inkscape just to save my files again as it creates an extra step in my process that really should be unnecessary. I do appreciate all the help everyone has been trying to give the support of those on the form has been awesome.

Which version are you using?

If you will take a screen shot of your file info as you are saving the svg, I will look at your settings to see if I can spot a problem for you. I use CorelDraw daily with no issues.

Also, did you save the file you uploaded with Inkscape or CorelDraw?

The forum software is completely unrelated to the Glowforge software. (The forum is run on Discourse.) So no changes Glowforge made to the app would be affecting the forum.

Can you compress your SVG into a ZIP archive and try uploading that to the forum? That way Discourse won’t try (and fail) to determine the size of the image.


Thank you for the additional information. As a next step, would you try uploading one of your SVGs that isn’t working that you created in CorelDRAW to the forum by first adding it to a ZIP file as @tim1724 suggested? If you’re still unable to attach it to your forum post, you could also try emailing it to my attention at If I have your original SVG file from Corel, I’ll be able to take a look at some of the settings it contains and check to see if there might be something leading to the error you’re experiencing.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email