Need a Solution for a bad lid cable now , While I wait for a new Cable

I have had my glowforge for 22 months and have used it every day 10 or 20 times a day so it has gotten use .

So what about the cable made it go bad, I opened up 1 time a little far when a friend opened it up , but it worked a little bit after that , than stopped , than worked than stopped completely.

Here is what I have done , I have pressed on all the connector and ribons, that worked 1 time than it quit.

Anyone have any ideas at all how to get it to run just a few more runs till I get the new cable.

WOW after spending some time researching the Black Cable Replacement it appears that APRIL was the month for a lot of black cables needing replaced.

Is it possible that an Update caused this or was everyone at the 22 month mark on using there machine as i was.

Interesting , is there a way I can pay to have Over Night Shipping or at least faster shipping, where does this ship from ?

Would anyone have any instructions on how to do this install ?

The thing is about my cable it looks perfect , however when I did push on the connector I got it to go a few times, than it just stopped, so very confusing .

That cable has fine wires inside of it that will flex back and forth when you open the lid, and if people open the lid all the way upright, you will note that it is possible for that cable to get pulled tight against a sharp edge on the lid. (Some machines had them placed with not enough slack to account for that.)

That eventually stresses the wires to the point of breaking inside. When that happens, they might slightly touch, allowing it to work intermittently, but if they get separated, it needs to be replaced.

You’re at the replacement point.

Here’s what I did to keep mine from ever being a problem…small square of Gorilla tape. (Yep, still on the original.)


Also not necessary to open the lid all the way…they built something into it that holds it open.


It may just need to be re-seated. The tab on top of the connector is a tab. Light pressure on the edge closest to the cable should release it. Then you can slide the cable out and back in and close the tab.

Don’t use too much pressure opening the connector - you don’t want to break it and create more problems. :wink:


Shoot tried the gorilla tape just to see if I could get it to get past centering, no luck
Thought maybe the pressure might work ugh. Thanks jules for the tip.

Unseated all the clips , they look fine, Now were stuck on calibrating.

That spot on the Black Cable was glued down, I cannot imagine that it got yanked , this seems so strange to me that cable issue. Just out of curiosity when was the last update anyone know ?

So when I disconnected the cable the Internal lights do not go on. Reinserted cable and got the light back went to focusing and centering does not move the laser into any position it wont move.

This same thing that started me on this quest, It wont move to center.

I checked all the gold tabs they are perfect , nothing seems bent or scratched, ugh loosing hope for 1 more run. Dnaglhdwfauydofuyas it lol

Don’t try to unplug the cables while power is on. Probably not going to do anything but don’t risk it.


Oh, could it be network issues? I’m noticing some big problems today with Facebook today. If you are stuck on calibrating that sounds similar to the Google outage last month.

I already did , this to me is looking more like some kind of update that went tru which would explain all of Aprils Black Cable problems.

No im not stuck the Printer Head wont move at all, not a network issue, Something much more sinister is at work, this ruined my 4th, just needed one more run, , if i just new it was an update than i could stop trying .

I was just going off the original post where you said the machine is out of warranty and pressing the cable worked once.

Those little connectors are a pain. I got a replacement machine a month or so ago and the lights on the right side didn’t work and it reported the door was open. This was right out of the box after delivery. The right side cable closest to the hinge was misaligned. It took me five or six tries but I finally got it to seat correctly. And I did have the same symptom where the lights came on a couple of times when I pressed the cable.


I never had any of those issues, it was flawless for 22 months, I swear to god this has got to be an update that took place . Did you see how many Cables were replaced these last couple months. WOW !

Mine was flawless too, until it wasn’t. Luckily for me I had about two weeks left on the warranty.

1 Like

Im going to STOP now. My research shows that there was an update in april 25 th that really left a lot of people where I am , Stuck on Scanning and Centering with No Printer head movement.

We all have the exact same story so somehow the Update pushed through to me and I am in the same boat waiting on the new cable.

I think the tell is that the : Printer head is not moving.
The camera picture is the same as the last run
That all of our cables were like brand new
Everyone went thu all the hoop 100 times with no joy.

This is all you need to know: Stuck on Scanning and Centering

is there a way to extract the logs on the glowforge to investigate further ?
I remember seeing that once in post. >

Correlation is not causation. If your cable is bad it’s simply bad because it ran out of cycles.

ribbons have cycles ? This I was not aware of Thank you.

Yes in this case it is cycled every time you open the door.

1 Like