Negative space is being engraved, help

i cannot for the life of me figure this out. This is apart of a design I drew out. Everything is great besides this. It just engraves the entire inside of the bubble instead of the little quotes inside. It’s a curve, fill only, transparent… I used shapes to make this with the subtract tools. It looks fine on here but when putting it into the glow forge the entire thing is highlighted. I followed the same steps as all the other icons I made. It’s just this one that I don’t know what happened.

This is what I’m trying to engrave.

This is what it looks like on the interface

And what it looks like finished

Not sure what program you’re using, but this usually happens when there is white present. The gf see the white like any color and wants to engrave it. Double check your design construction and how it is being saved to make it truly is transparent and not white.

Ja. Your center shape is filled, so the GF fills it, as it should. It doesn’t care about color. White fill is still a fill.

Subtract it and all will be as you would expect:

1 Like

You’re running into the Glowforge bug where it fails to support the even-odd fill rule in SVG files. Export your file as PDF instead; the Glowforge correctly supports both fill rules in PDF files.

I wish Glowforge would fix this but after three years of living with this bug I’m not getting my hopes up for a fix anytime soon. But saving as PDF is a good workaround for now.

1 Like

There is no fill. I triple checked. Even remade it twice to make sure. Still no good :frowning:

I posted it here in hopes it’d help and they’d see it. Like you said, not holding my breath for it. I usually do save as a PDF, but with everything else in the design that needs to be cut and scored, when I save as a PDF I can only engrave the entire thing. So that doesn’t work for me. I rasterized it and sadly it’s not as clear as the rest of the design, but gets the job done.

I swear I have checked many times and remade. It still shows up as if there’s a fill :confused:

That’s odd. When you export to PDF you should still to be able to choose what to engrave and what to score and what to cut. It sounds like it’s all getting rasterized when you’re saving to PDF. How are you saving as PDF? Use the Export command in Affinity Designer.

On my end, it doesn’t let me do it… I just redid it and the rasterize drop down I changed to “nothing”. I went to upload the file in the interface and it says “We can’t process masks”, but I didn’t add any masks that I can see on it. It said that as well as not being able to process gradient fills. So I fixed the gradient fill part. But now that I didn’t rasterize it, it says the can’t process masks… and 2 objects that I did rasterize separately are all janky now. lol fml

Here’s the version I uploaded to the UI after just subtracting the inner shape from the outer - (2.8 KB)

(I use Inkscape…)

I exported your file as a PDF in Affinity Designer and it shows up fine in the Glowforge interface when I upload the PDF:

bubble.pdf (6.5 KB)

1 Like

yes when I do it as a PDF it’s fine, but like I said when it’s with the entire design, i’m not able to cut, score, and engrave all in one.

Is it that it won’t let you cut/score anything? (That would point to it being rasterized.)

Or is it that it isn’t breaking things into steps where you can set different options? (In that case make sure you’re using a different color for each operation.)

1 Like

Just tried using yours and it works with yours. Seriously not sure what’s going on with mine. I use affinity designer. Would’ve replied sooner but they wouldn’t let me lol

I’m sorry about the ongoing trouble. May we have a copy of the PDF you exported with Affinity? I’d be happy to take a look at it alongside the PDF @tim1724 created and look into this further.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email