New wifi, can't connect

update: I switched from Microsoft to Firefox and it connected.

I have a new modem/router. I cannot get my GF connected to wifi.

All electronics in the room are off, the router is 2ft from my GF, my laptop is right next to my GF.

I can see the GF wifi, and it is at 2.4hz. when I connect it says “open, no internet”. I did get it to stay open once, but the setup screen wouldn’t connect. I have spent about 8 hours on this and am getting frustrated. Any suggestions?

1 Like

This helped me last week after I got a new modem.

Turn on your GF. Wait about 1 minutes and press the button until it turns teal.

1 Like

I forgot something very important. Contact your ISP and tell them you have a new modem.

1 Like

Only contact your ISP if you can’t get internet at all. If other devices are connecting to the new router just fine then it’s a Glowforge thing.


i have tried that about 30 times, not working.

1 Like

I got the new router/modem from my ISP.

Can you share a screenshot showing the 2.4gHz channel? Some ISP routers (Spectrum) don’t broadcast anything but 5g.


I have a new Xfinity router and it automatically detects which channel to use and it has worked correctly for every other device that has been connected. I am not near my computer, but I verified that the screen shows it is 2.4hz.

I have to admire your tenacity, evansd2 suggestion would be the first question in troubleshooting.

Edit- I see you have connected other devices. That’s odd.

1 Like

Can you share a screenshot of when the setup app fails to connect? Which is the furthest step of you can get to?

“Open, no internet” is normal when you’re connected to the Glowforge during the setup process.


the furthest I get is the screen that says the Glowforge is waiting for my to connect.

Here is a video. 2:30 in the video is very important

I have done that about 40 times. It doesn’t ever get to the screen that says it is connected.

I can’t get past this screen, waited 30 minutes the last time I tried.

Is the Glowforge wifi name showing in your list?

1 Like


Is the teal light solid or blinking?


So you are on the app setup page on your computer and refreshing the available network list shows you the Glowforge wifi name which you select and then nothing happens after that?

1 Like