No Artwork (because the SVG was HUGE)


#1

This isn’t so much a problem, but maybe there would be a more elegant solution for it. I have no idea how this happened, but I took a picture with a ruler in the frame to match the scale for the 4.5in width I was looking for. In Inkscape, I matched the ruler up to the guides, and then traced the shape I was interested in. I saved it, uploaded the the 'forge, and… No Artwork as a message, or on the screen. Long story short (after several power cycles, opening and re-saving the image, I noticed that the scale had changed. Instead of 4.5 inches, it was over 16 inches wide. I reduced it, then things were good to go. Out of curiosity, I loaded the first image, and used the zoom out function in the GFUI, and sure enough, there was the file, conveniently outside of nearly every print line. It was also significantly offset from the print bed. Inkscape had pushed it over to the left by 20 inches.
The suggest comes in now: Would it make sense if the first path that could print is oriented so the resizing box would have it’s top left corner at the top left of the printable area? Had that been the case, I would have immediately seen the shenanigans of Inkscape, and resized the gigantic file. Now that I know this could be an issue, I shall keep an eye out for it, but are there any scenarios where behavior like this pose an issue? For reference, I’ve attached the .svg that was re-sized in Inkscape. outerplate


#2

Think they recommend making a bed-size rectangle canvas in your software … creating your design within it … then ignore the bed-size rectangle when processing in your Glowforge.

Actually … @Jules loaded this last night!


#3

Yes, setting the Document Properties in Inkscape is very helpful. In the beginning I kept having designs not appear or be in a weird place on the bed. After setting the artboard size I can see exactly where my design will be on the GF design layout once imported. I no longer lose the design if it is off the edges.

Edit: See the next post on how to permanently save the template.


#4

To save having to set document properties to inches and 20 X 12 every time, create a new Inkscape file, set all the variables you wish across the different tabs, and save as;

%appdata%\inkscape\templates\default.svg

  • and click save. That’s it. The next time you open Inkscape, it’s all there and you’re good to go. :sunglasses:

#5

Yes, I did that many months ago. Forgot that it doesn’t automatically set it.


#6

I need to put that in the SVG file saving writeup…will be very handy for Inkscape users. :grinning::+1:


#7

This is awesome. I’m trying to track down the equivalent in a Mac install, but it’s not quite as easy to find as I’d have thought. I’ll post when I discover it, which will almost definitely be after someone else does :wink:


#8

Found it!

On MacOS, you have to go to Applications, then Right Click on the Inkscape.app, and Show Package Contents. You can then browse to Contents>Resources>Share>Inkscape>Templates.

In my install, I just replaced default.svg, and that worked. In some of my other reading, you might need your language extension in the file name as well, i.e. default.fr.svg for French (You’ll see all of the existing files there).

Thanks to everyone for the help!


#9

I tried to do this before and I got an error message saying that I couldn’t save this file. I’ll have to check again when I get home to see if I’m still getting this error message.

So right now I just have to go into Document Properties every time and redo my “default settings”


#10

Often this has to do with permissions, if I understand your issue correctly. Any way you might already know this, but the info is sparse documentation on this forum about all the ins and outs of doing this. On a Windows and Linux install, and I would assume Mac OS, you can put the default template in two places, each of which might require different permissions for the directory. You can put the default template in the program file location or you can put a default template in the user space configuration directories. Putting it in the program files has its advantages but sometimes folks aren’t use to accessing the permissions to do that. If in the user space, it might be a little harder to find the configuration folders to place them in, especially if you haven’t done Linux .config directories in the user’s home directory. If you use the Userspace config directories, your default template will most likely survive a program remove/upgrade/reinstall. If you put it in the program files directory, you might lose all the special tweaks you’ve made, especially all the extensions you might have placed there for Inkscape.


#11

I got so tired of that setup dance! @rhenley gave me a link where I found this string…
%appdata%\inkscape\templates\default.svg

So I made a new file the way I wanted it and pasted that string in the ‘save as’ dialog and hit save. I looked for it in my ’ Glowforge designs, where by default I save all files and it wasn’t there…
So I closed Inkscape and opened it again - presto!
Didn’t have to put the file anywhere, it knew where it belonged. :sunglasses:


#12

I will have to try this tonight!!! I really hope this works for me too


#13

Man, I was so happy when that 12x20 in inches popped up!


#14

The tutorials in this issue that you can Google are old, in various states of utility and are linked to specific OSs. Using the string search is pretty good and efficient, just doesn’t quite let you know where it might end up.

As an added bonus to understanding file locations, you can make several Glowforge specific templates and then when you make a new document, if you do New from Template, you have several documents to choose from. I have a metric version template for the Glowforge art board. Some times I design in metric and sometimes in Imperial, so I have different grids set up and different display units but also have the document size default in inches. You can still do this by saving with the string variable, but being able to edit in place the documents is helpful for management.

Again, this is my work flow. Whatever works for you is best.


#15

Thanks for that tip!
(note to self) … New from template…


#16

after all this time…I have set that doc properties a couple hundred times now.
this is life changing, Thanks for posting!
Having that pop up with the right settings after reopening made me squee a little


#17

I squeed too.

At least!


#18

Thanks everyone for the helpful suggestions.

I’ll pass on your feedback about the design placement when you first open the design.

Happy printing!


#19