No new SVG files will load anymore

Hello, I keep getting and error message anytime I try to upload any newly created SVG files. I use AI. I can upload files I previously made months ago even if I haven’t cut them before. If I save them as PDF it will load. Can someone help me and figure out what the issue is! I have always saved as a svg but now they wont load!!! I have restarted my macbook, restarted my machine, restarted AI. This has been happening for 3 days now!


Have you tried clearing your internet browser cache? Also, which browser are you using?

I use chrome. I have cleared cache, cookies, everything. I have restarted and started my computer, AI and glowforge for 3 days. If I save as a pdf it will load.

So save as PDF. I like them better than SVG anyway, because they preserve the size of the design. :slight_smile:

1 Like

will I be able to ungroup or choose different settings for different parts if saved as pdf? I thought that was why they suggest svg? Im new to the whole designing part so still trying to understand the differences. thanks for the help!

They’ll work exactly the same in the GF app.

1 Like

As for the SVG issue, I’m guessing it’s an export problem, but I don’t use AI so I can’t help you with that part. :slight_smile:

it just started 3 days ago, i have been able to export svg files fine before then! thinking there is a bug in the software some where.

An update to AI, maybe? It’s happened before.

Not on the Glowforge side.

There are probably thousands of owners using AI. If there was a problem, it would have been reported by more than one user - especially on a weekend.

1 Like

Don’t think it’s an AI update issue. Svg exports working fine for me yesterday. Could be a settings issue or issue with particular file/objects in that file?

It’s any file I make and save as an svg. It has been working fine for months, then all of a sudden 3 days ago I started getting the error message with any “newly” made svg. If I save it as a pdf it’ll work.

Post a screenshot of your svg export settings form.

So if you upload a SVG you made months ago it works but not one made today? What if you load an old file and just save it?
It sounds more like a setting that was changed. Is there two ways to save as SVG?

Btw- you don’t need to save svgs since you’re using Illustrator. You can copy/paste with the keyboard directly from AI to the library page.


If load an old file and edit it and save it again it wont work. I haven’t changed any of my settings to save my files ( I dont even know how) unless it accidentally got changed some how.

I don’t see anything obvious here, other than I always embed images, rather than linking them. I don’t know if that would cause the problem. If you’d like to post a file, I’ll try opening it on my end & see what happens.

I just did a “Save as Copy” using Ai 24.2 (64-bit) to save an svg. I then loaded it into the GFUI without problems. The SVG settings I used were:

I then changed my settings to match yours and repeated the process. It also worked correctly – no errors inthe GFUI.

Beats me. I’d be happy to take an AI file that fails for you and run it though my system to see if it works for me.

If you want to save an example of a simple design in AI, saved as SVG, that doesn’t open for you, one of us could easily see if it opens for us.