No option to enable Compact Filter in the UI

So I have happily received my Compact Filter, read the ENTIRE manual, and gotten everything properly hooked up, but there is no option in the GFUI (under trace) to enable the Compact Filter. I’m assuming there is a software switch that needs to be flipped, that has not yet been flipped.

I have powered down (and back up) my Glowforge, logged out and logged back in, but still no option to enable the Compact Filter.

(If it matters, my unit is a Basic model)

Could you please let me know if there is something else I need to be doing? Hopefully this is a quick fix, as I have disassembled my existing venting, but still have a couple of prints to get done today. (And I was hoping to use them as a test for the filter).

Thank you very much for 1) getting the filter to me quickly, and 2) looking at this.

Best regards,


When I looked under the GEAR the other day I saw the switch there.

(and it’s still hiding there today)

I enabled it under trace when I got the filter, but I was one of the first so it could have changed.

1 Like

Manual said to go into trace, then the gear, and I did, but don’t have that available.

I edited my response, but just in case.

When I set mine up it worked just like the manual says, using trace.

Not working for me either. At the moment I have not unboxed the filter nor is my Glowforge turned on, so I don’t know if that’s a factor. If I had to guess, I’d say they have to manually enable the function for each user’s machine, and they haven’t gotten around to it yet.

1 Like

Cynd11, is yours a basic, plus, or pro?

Just curious, as mine is a basic.


Ok. So it’s not model specific. Good to know.

I believe they currently have to manually set a flag on the machines, they haven’t rolled it out to everyone yet. ( So I’d probably mention it also in the Air Filter-Latest thread to make sure the correct team sees it, and maybe tag Dan since we don’t know who else is working on the filters yet.)

Thanks Jules (and done!)

I’m so sorry for the wait. You should now see the option to enable the Compact Filter for your Glowforge. Would you give it a try and let me know ?


I’m out running a few errands, but will confirm later this afternoon. Thank you.

Also, if you (Glowforge) would like video of the Fedex driver not waiting for a signature, let me know. I’ve spoken with them, and shared the video, and have requested that they refund Glowforge for whatever the signature fee is.

It’s working now for me.

1 Like

Yes, the option is there and I have successfully turn the option on. Thank you.

I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!