Open lid, close lid, then scan forever? [Resolved]

Hi All,

Just got my GF+ and enjoying having the new tool (toy?). There’s a weird bug though that maybe someone will have an idea for…

Symptom: Turn the machine on, wait for calibration to complete, and all looks well. Open the lid, and the app registers lid as open. Close the lid and the app registers the lid as closed. So far, so good. Well, now things go wrong because after the lid closes, the app goes into scanning mode indefinitely.

Current work around: While GF is off, pre-load material and position it somewhere “nice.” Turn GF on, wait for calibration and initial scan to complete (note – scan occurs without lid opening), then go ahead and cut my project into pre-loaded material. Once I open the lid to remove my cut, I end up back in the eternal scanning stage and have to power cycle to reload material and move onto the next cut.

Note: this problem happened straight out of the box – so there’s nothing that’s “changed” to cause the problem.

What have I tried? Well, first I poked around the GF help section and tried a few things there. Then searched the forums, and found a half-dozen or so posts with similar problem descriptions and tried suggestions from there. Specifically, I have:

  1. wiped all laser lenses and lid camera lens
  2. reset the ribbon cable
  3. reset the breadcrumb tray
  4. turned on/off my computer
  5. switched to Chrome browser (from FF)
  6. used PG and non-PG materials
  7. sampled bright, medium, and low lighting levels (daytime, night time, etc)
  8. tried reconnecting to the wifi
  9. tried connecting to internet via my phone’s hotspot
  10. rebooted the router
  11. checked router’s DNS settings to confirm nothing custom or unusual there
  12. reproduced the problem from another computer
  13. reproduced the problem from another browser tab

A few more (possibly helpful or maybe not) notes:
-The web app definitely knows what the GF is up to – it senses when the lid is opened or closed, calibrating, etc.
-The web app shows pictures of whatever is in the bed when it turns on (recall, I have to power cycle to actually cut something).
-When I open the lid after a cut, sometimes LED strips brighten up and stay turned on, while other times the LEDs go dark while the lid is open. The ribbons connecting the lid LEDs are tightly socketed as far as I can tell, but there may be a loose connection I missed somewhere.
-And, ready for the kicker? If I power cycle the GF, then open the lid just an inch or two, the app will recognize the lid has been opened. (so far so good). Now, I can close the lid and the app will SUCCESSFULLY COMPLETE the scanning step and report ready for printing! To be clear, I’m opening up the lid a small way, and finding the operation is NORMAL. If I open the lid more than a few inches, then I end up in the eternal “scanning” loop of death.

If I had to guess, based on the troubleshooting I’ve done so far (which BTW, thanks everyone for working together as a community and providing so many suggestions when others reported similar problems!) and from my own observations, there’s got to be a bad connection somewhere associated with the lid’s hardware. Maybe a camera ribbon? LED? Power? If opening and closing the lid were to exert a bit of torque or tension in the wrong way, I can see how a sensor would bug out and a power cycle with the lid CLOSED would return the system to normal operation.

Has anyone had similar experiences or have suggestions for what to try?


I do think that you narrowed down the problem very well but what I did not see was extra attention to sitting on a flat level surface. That it works at all means that you are close but these machines are very finicky about what is flat.

1 Like

Can I ask you something? Are you waiting for the cooldown period to end, the little tick-tick-tick-tick…ticktickticktick…tick-tick-tick and then the button to flash before you open the lid after a cut? (Takes about half a minute.)

I never have trouble with post print lockups, but i read about so many of them, and I was wondering if opening the lid before it finishes the cooldown and sends the picture to Glowforge isn’t causing a signal stream to be interrupted and things to hang up.

Just curious.


Just checked and here’s what the bubble level has to say about the two X- and Y-directions.

My workspace is a large desk, and as far as I would guess, seems reasonably level based on these images.

In general, I wait for the app to complete it’s dialog box and come back to the stage where it’s ready to print again.

That said, I can turn the GF on, open the lid without doing any cutting whatsoever, close the lid again, and send the app into the “scanning” loop of death. Based on this “minimal” reproduction of the bug, I’m inclined to guess the issue is unrelated to waiting for the cooldown to finish.

Well opening the lid while it’s in the middle of the Startup Calibration might also cause it to lock up.

Best thing to do is turn it on and leave it alone for a few minutes to let it load and install any updates, then complete the Startup Calibration, before you send it any commands at all from the app, or do anything else.

That can take up to ten minutes, so i just usually turn it on and go get a cup of coffee or something. By the time I’m back, it’s done and ready to go.

1 Like

It certainly makes sense that interrupting the startup sequence would cause problems. In general, if the app completes “calibration” and reports “ready” would you trust it to run, even if it’s been less than 10 minutes?

Yeah, as soon as the head returns to the home position, it should be ready to go. i would think.

1 Like

Then I don’t think the issue is related to interrupting the startup sequence since I definitely wait for the head to return to it’s home position and for the app to report “ready.” It’s possible an update is being installed and not reported through the app’s UI, but I would be very surprised if the software was allowed to run while updates were installing. That’s a recipe for total disaster.

Yeah, unfortunately it can also be caused by something like sketchy Wifi,or some problem with the machine, but we can’t check for that…they can sometimes see something by checking the metrics for the machine.

So anyway, we ask about the common ones that we can eliminate up front. :slightly_smiling_face:

1 Like

Yeah, that’s why it’s good to browse the forums first to see if any of the community-suggested ideas work. Sadly, there hasn’t been a straight forward fix based on what I’ve read and tried so far.

I emailed support a couple days back and am waiting to see what they come up with. My hope is exactly what you pointed out – because it’s a cloud platform, they should have access to substantial technical details to help diagnose the issue.

That said, I’m still stuck on the operational difference between opening the lid a few inches (which causes no problems), and opening the lid 6 to 10+ inches (which causes infinite scanning). Combined with the LEDs sometimes turning off when the lid is fully opened and sometimes staying on when the lid is fully opened just screams a loose wire somewhere. I tried a few more times and can reliably reproduce both the LED on/off effect as well as the spinning “scanning” of death.

Nope…doesn’t sound good. :neutral_face:

Did you take a look at the pins on the ribbon cable? Made sure they’re all straight, none bent or broken?

1 Like

The ribbon cable for the laser head is fine – that was easy to verify, especially since it’s all brand new. The ribbon cable connections at the base of the lid, however, are another story. For the instances when I open the lid and the LEDs turn off completely, I can gently poke the ribbon cable connectors near the lid hinge and sometimes get the LEDs to turn back on. The ribbon connector is on tight and nothing appears broken.

Out of curiosity, what happens when you open your lid? Do the LEDs turn on? Off? Get brighter? Dimmer? I find the LED behavior on my end is generally inconsistent and it would be helpful to know what “normal” is in this case.

When you open the lid they stay on but they get a little dimmer. (They used to really blind us.)

1 Like

Interesting & thanks for the input… In my case, they’re sometimes much BRIGHTER when I open the lid. Other times, totally OFF. I was really hoping this would be a software issue or operator error, but it’s looking increasingly less likely… Dang.

1 Like

Well, we don’t know for sure…they’ll be able to tell. Good luck. :four_leaf_clover:

1 Like

You have a really good bit of trouble shooting done. I think is has been diagnosed down to that ribbon and something loose or broken. I was hoping that a bit of a low spot under one of the machine’s legs might be the problem as that would be an easy fix.

I think they will probably want it back at the shop and I would make sure all the shipping stuff is handy to put it back for sending.

In the meantime a kluge that might work is to see how much movement that ribbon makes when lifting the lid and as it is designed to allow the lid to be all the way up. If you could lift the lid a bit more without the ribbon moving you could manage a bit easier.

Assuming you know which end is causing the problem a bit of tape holding that end steady while the rest moved would allow a more usual operation until you have to send it off.

So, if I solve the problem without shipping the GF+ back, what do I win?

tldr Solution: ribbon cable connecting the lid to the main case was loose on the case’s end (as opposed to lid’s end). Here’s some pics of the problematic connection – it’s where the ribbon connects to the white PCB:

Slightly longer explanation: Was thinking more about the symptoms and how the LED lights were acting irregularly and how the lid opening distance was affecting whether I ended up in scanning spiral of doom. My sense was it had to be a cable or connection related to the lid’s hinge. Last night, I was poking around the end of the ribbon where it connects to the lid, but it was definitely a tight connection. For whatever reason, it didn’t occur to me to check the other end where it’s mounted to the back case. Today, I was walking by and on a whim, decided to open the lid and have another look in the daylight. The ribbon connector looked perfectly fine, but when I gently touched it, it was clear the connection wasn’t snapped shut. (I have some passing familiarity with these types of connections – when replacing the battery in my Nexus phone, I had to disconnected/reconnect several of these hinged mechanisms to finish the job.) Anyway, I snapped the ribbon hinge closed, booted the machine, pulled up the app, and checked to see if the problem had been resolved. It had. Hoo-ray!


You get props man! :sunglasses::+1:


I’ll take it! :smiley:

And thanks for going back-and-forth with me. It helped get the brain juices flowing.