OpenSCAD units do not come out right on Glowforge


#1

I use openSCAD, do a projection, export to SVG and upload to Glowforge. If I make a rectangle 25.4 x 50.8 I expect to get something that is 1 x 2 inches when cut, but it is WAY smaller. In order to get things to come out right I have to use 95.62 units in OpenSCAD to get an inch in Glowforge. (this was determined by printing out rulers and measuring the distance between ticks)

I took the SVG file and opened it in inkscape and got exactly the dimensions as shown in OpenSCAD, but when cut with the Glowforge, they are almost 4 times smaller.

Is there some really strange conversion factor being applied to an SVG from OpenSCAD?

I’m using Glowforge to make engineering devices and I need them to fit to fairly close tolerances, this bizarre conversion just doesn’t seem right.

Other people seem to get OpenSCAD to cut properly so it must be something I’m doing wrong, but I don’t know what it is.

Thanks,
John S.


#2

I have no idea about OpenSCAD, but I did find that when using InkScape (on Windows 10), saving as an inkscape SVG file caused some shrinkage when importing into the GFUI. When I save as a “PLAIN” SVG in inkscape, the import works at the intended size.

I don’t know if there is something similar that happens with OpenSCAD, but I would suggest looking for an alternative (plain) SVG format.

Hope this is at least a bit helpful.

-Todd


#3

It’s likely that your SVG does not contain specified units, so it (the UI) defaults to pixels when it sees a size parameter in the SVG code.

Your problem is basically the same as this:


#4

OpenSCAD version 2015.03 doesn’t include units in the svg export at all. If you grab the latest development snapshot at the bottom of the downloads page version 2018.0X it will export with sizing in mm. In which case the scaling should be correct… maybe.


#5

Have you tried opening the SVG in an editor and changing the art board to 20x12 inches, then saving and uploading to the GFUI?


#6

There is no art board in an OpenSCAD SVG file. Recent versions set the width and height in mm and they come out correct in the GFUI.


#7

Every time I have had a scaling problem with SVG-GFUI import, it was because the document size was not set for 20x12 (Colonial units).


#8

I think the 20x12 is a work around for files that don’t specify the units. People have suggested any 5:3 ratio will work and gets scaled up to 20x12. If mm or inches are specified the GFUI will get the right size and it doesn’t need to be 20x12.

Having it 20x12 though does cause its position in the GFUI to be fixed.


#9

Yah, the ratio is the trick, not the units.


#10

Yep, I was just doing this earlier today. Much smaller when uploaded directly. When I imported to inkscape, I saw that my 140-mm object was now 140 pixels across, i.e about 37mm. I guess I’ll have to go get another development version. Easy enough to fix, but annoying.


#11

Yes the last release was two years ago so you pretty much need the development version for any of the recent features and bug fixes.


#12

That was it! I switched to 2018.04.06 and things come out perfect now.

Thanks so much, now I can really go to town and start making things.

John S.


#13

Whee! I hid my copy of the release version and fired up openscad-nightly (the not nightly at all automatic development build snapshot) and everything was fine. Now if only they let you pick colors for the SVG…


#14

Somebody did a pull request that propagated colours to the SVG but it did not get merged.


#15

Thanks everyone for all of your help!

I’m glad you resolved it! I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic.


#16