Passthrough Seems to focus incorrectly

So I’ve been using the Passthrough, but have an issue with focusing. It seems that when it focuses it uses auto focus and seems to either be focusing incorrectly, or more likely on the wrong area. I can’t see any visual UI that shows where it focuses, so I can’t confirm where it focused, but if the board already has engraving on it, it would not cut through.

When it failed, I tested it with various settings cutting a “normal” circle. I could cut successfully when focused on the area (either auto, or using set focus). But if the focused point is set manually to be off it doesn’t cut through (which I know can happen when not focused - which is what I was trying to test).

The passthrough though seems to all be automatic, so I don’t see a way to fix the focus to a specific area to measure (like the set focus option).

When I measure the object with a digital Caliper and set the manual focus to that, it does not cut either - so I assume the set focus measurement must be off from the actual height of the material.

Is there a way to “set focus” while doing a passthrough… or I assume setting the manual focus for the cut may work, but if so I don’t know how to get the real measurement - am I doing something wrong, or is there a way to get the value of the focus when using auto focus or set focus?


1 Like

Passthrough has been the one area I have absolutely just trusted the GF on. The SW actually does really well, it just doesn’t communicate it perfectly. Today I was working on these long fabric eagle design that are getting sewn into a make of mine. Each wing took 4 segments on the passthrough. The second segment never showed correctly and the 3rd and 4th segment never showed anything. But the machine nailed them all perfectly. Now THAT is why using servers has a lot of perks :slight_smile:

But in summary, for now I at least just trust it. I trust the company SW will improve and is on the edge some some cool stuff.

1 Like

I’m sorry but the software is failing me. Your post may be good for others but it really doesn’t help me or relate to answering my question.

My question is how to get it to properly focus. When I have control I can focus no issue. But when the pass through worked for this material it didn’t. Other attempts worked but didn’t have already engraved areas. I’m trying to cut through it and without proper focus it won’t cut through all the way.

1 Like

Do you happen to have a screen shot of what the pass through is stating on the app? There are many points in the pass through process and so narrowing down where you believe things went wrong, of your last beliefs they did, would be helpful

I use Set Focus occasionally several times to make sure it is right. To get it to work properly you have to first run the calibration so the machine can calculate the location in the fisheye lens with actual places. What you see has an upper limit of sharpness due to that conversion but you should get sub-millimeter accuracy when you do.


You use Set Focus during the passthrough? Do you just use that each time you shift the material? I didn’t try to see if that worked - that may be one solution. (I’ve already run calibration recently, and the machine seems still in calibration – I don’t think that is my particular issue – it really seems to be a focus issue as it cut one set but not another in the same material with same settings). I’ll try to see if it lets you Set Focus in the middle of the passthrough wizard.

1 Like

So to clarify, is this not focusing on the second stage of the print or on the first? Setting focus manually on the second means that you are choosing manual and not letting the GF auto run the passthrough after the first print. I have not had issue with it auto running. Its only when trying to use manual alignment.

Do you have photos of what you use to define the failure? Or at what stage?

So this test was not with a passthrough cut?

It is not reallyyyyy. You can set it with auto or manual but after you finish the first segment then it will realign and show you where it will print and give you the option to manual adjust (this is where in my experience, choosing manual at this point had not worked out well). The photos I posed are all using manual setting because…GF does not do fabric like that yet. It was also without a crumb tray because I have a different tray I use.

Yes, at all stages. If you have already started your passthrough then you can alway manual adjust when it finishes a segment and gives the option. If you are setting up your passthrough, you can set up with manual settings.

You can test it. Also, are you using a proofgrade material?

1 Like

I ran the passthrough on material for engraving and another cut … that all worked – then I put the material back in (to cut some more due to design issues), and then it no longer could cut. So its the initial cut. Based on testing that material more with manual cut to validate it wasn’t the settings nor material, they worked just fine with setting focus. However the passthrough just could not cut - and I tried a few times – it of course attempted just didn’t go all the way through. Based on my testing I really think its a focus issue with it focusing incorrectly due to something about it being previously cut – ie, perhaps focusing on one of the areas already cut in error.

So to clarify, when you start a passthrough print, you are using auto settings and you never click to manually align when it asks to shift up material?

Ok, I’m sorry but you are over thinking this… I just was asking questions about focusing…

  1. It cut incorrectly on the “initial” cut — I had previously cut and engraved the material - that worked - but when I came back and tried to re-cut it due to issues with the design - it didn’t work - I suspect it didn’t focus correctly
  2. It failed by not cutting through – not an error or anything within the software - it just didn’t cut through, when those settings (if normally focused) worked just fine on that same material - even with a test on an area right near that cut
  3. I used set focus for my first attempt - when it failed I reloaded the design and allowed it to auto focus
  4. There is obviously some automatic areas of the passthrough – I was referencing the fact that the focusing seemed to not focus on its expected areas or those set, and seemed to automatically focus to some other value - my assumption is an area already cut or engraved by mistake
  5. I’ll try “re-setting” the focus after the passthrough is turned on – I didn’t try that in my initial testing - perhaps starting that process reset the “set focus” - not sure
  6. of course I’m not using proof grade materials – they don’t even offer almost anything that extends past the normal bed - so this is MDF from another vendor, but one that cuts just fine normally and has for many projects
1 Like

No - I am not using the manual align options – I let it align – I don’t have issues with the alignments - those match up just fine.

So this is what I (politely) am confused on with your question. If you are at all trying to set focus after you start a passthrough then you are choosing to manually realign. When you do a passthrough, the GF will print the segment, ask you to move it forward, show you what it calculated to do next and ask if you want to adjust it. At this specific point, are you see the calculation and it is showing it wrong and so you are choosing to realign manually?

So no - you don’t seem to be able to use the Set Focus option in the middle of the passthrough. So I assume it will use the focus already set – my issue is I’m not 100% sure where its getting that focus from … ie, a) from my Set Focus prior to starting the passthrough wizard, or if you don’t use that the auto focused area the software initial shows or b) some re-evaluated “auto” focus - of which I’m not sure what that would be…

I don’t think there is, but is there any way to see what the focus value is when printing (passthrough or just normal prints)?

Oh, then you might want to check out beyond the manual. I can move the thread over there where non proofgrade settings can be discussed :slight_smile:

Welcome to the forums!

1 Like

Manually setting the height does set the focus of the laser and overrides the the distance that Set Focus measures. What Set Focus does aside from measuring the actual surface height is align the image in the screen to where it will land. I always align the work on the right side of the crumb tray and have the design broken up to different colors so the cut off point is as much as possible on places where everything is vertical, and does not cross where there is engraving.

Then by only using the vertical arrows to bring on the next cutting area, I can know that at least on the left-right axis it will be aligned the same. Likewise, if all is aligned vis-a-vis the crumb tray at least that is one thing that will be easily correct and if only vertical lines are there then a millimeter error is not an issue. :slightly_smiling_face:

1 Like

No, I don’t currently touch the manual alignment at all – I can if that is the solution (but not sure it is)… Its the initial focus that seems to be getting off somehow and I’m just trying to see what happened… I would have thought it was a fluke or some mishap, but it consistently would not cut that piece.

1 Like

Ok, no offense – but this really isn’t beyond the manual … this has nothing to do with the material, and glowforge doesn’t offer material in the sizes for almost everything that would be large enough to go into a passthrough…

1 Like

No offense taken :slight_smile:

Yeah, I get everything you are saying – its just not my issue – I’m not manually setting the height (although I tried while trying to troubleshoot to see if that would help – but normal cutting at the height I measured didn’t work normally – so that’s a different issue/topic). I used the set focus one attempt and just let it auto focus the other.

So what settings are you using? I recently did 1/8 MDF with 150 speed and full power on a passthrough and it did just fine.