Passthrough Seems to focus incorrectly

Interesting – I wonder how it works – but if that’s the case, then that’s probably not my issue :frowning:

The lens must move up and down to change the distance between the material and the lens which has a 1/2" focus range. Other lasers have the bed move up or down to accommodate the focus range. The clicking you hear after a job completes is the lens returning to its original position and focusing.


I’m working with support – there does seem to be an issue with this - working with them and will update when we get to the final issue

1 Like

seems to be a potential software issue with at least my saved settings – they are looking into it to see why – if someone else has something similar – try to always use manual settings (just set to the same settings you have saved) – that seems to be a workaround until they investigate why its happening (not sure yet if its just me or something that can affect others).

1 Like

There has been a few threads on the setting overriding. Manual is certainly a great option. The glowforge community has a lot of great threads to look through on problem and support. Anytime I have an issue, I check there first so see if other have had it.

There was a really good recent on over that same problem and they did a good write up on it.

1 Like

This one was just 2 days prior to your post and so I’m sure it’s relevant:

This is something slightly different but possibly related in the backend. On this the pass through (at least) seems to be “forgetting” the focus that the Set Focus option finds. But only when it seems you use a saved profile in the settings. Even if that setting has the “Auto” toggle on. Instead of using a savaged setting, if you manually set all the settings (power, speed, and passes) but leave it as auto. It seems to work as expected and remember the height threat the “Set Focus” found. (At no time did I ever enter a manual height for the material - as that wasn’t what seemed to be the issue I was seeing). I know it’s confusing because so much is called “manual”, but my intention was to mean hitting the “Manual” option after you select the object in the sidebar. This manual being the area to manually enter the speed, power, etc but leaving the height to auto.
Definitely interesting what this person has found as well and definitely could be related. The reason I didn’t find it was simply I originally search through things relate to pass through. Could very well be something more severe affecting other types as well.

It looks like this question is not specific to which material or settings are being used, so I’m going to move it (back?) to problems & support. And since the team doesn’t get notified when that happens, I’ll ask someone to take a look.

1 Like

Oh no, I’m sorry to hear about the trouble @stephen1.

First, I’d like to clear up a few workflow questions. There are two ways to have the printer measure the distance between the printer head and the material. You can use Set Focus to choose where the red dot lands, otherwise the autofocuser will choose a location based on where your design is placed.

When you use the Set Focus feature, that only selects the location of the measurement but has no impact on the actual measurement itself. The printer will use this measurement to set the focal height of the lens, unless the measurement is over-ridden by selecting a manual focus height at the bottom of the print step menu.

With that being said, you can absolutely run Set Focus between slice attempts, but only when the manual align option is selected. Otherwise, your Autofocuser height will be the default measurement.

Next, while reviewing the logs from your printer, I looked closely at the images being captured by your lid camera. I noticed in some of the recent Pro Passthrough prints included a section of material held down by strong magnets. Sometimes, if the magnet is too strong, it can interfere with the lens in the printer head. Could you please let me know if you notice the print slices not cutting through are the selections with the magnets?

It is very important during a Pro Passthrough print to keep the material as flat and level as possible. It may help to use alternative options to hold the material during the print such as bracing it from underneath outside of the Pro slot. It may help to use alternative options, such as hold-down pins.

To help us investigate further, could you run a standardized print for us? The design we use has some known dimensions built into it and it will help me extract logs afterward to take a closer look.

Here are the steps for the test:

  1. Load a sheet of material into the Pro Passthrough slot and ensure that the portion sticking out of the printer is supported so the material lies flat on the crumb tray inside the printer.

  2. Double-check that the material is completely flat against the crumb tray. A quick way to do this is to press gently on the material where it rests on the tray and feel if it moves. If not, you’re good.

  3. It can help to use pins to hold the material flat against the tray.

  4. Open the Smooth Curves Stencil from your design library.

  5. Turn on the Pro Passthrough feature in the menu bar.

  6. Select the entire design, and arrange it so that the dotted line at the top of the work area is at the tips of the arrows in the design

  7. Click Print and run the first section of the design.

  8. After the first section completes, move your material through the Pro Passthrough slot so the printed area is more than 3 inches (7.62 cm) away from the front of the Glowforge.

  9. Follow the prompts and run the 2nd portion of the test print.

After the test print completes, please send us the following:
  • Photos of the front and back of the finished print.

  • The date and time you ran the test along with your time zone.

  • A photo of the bottom of your print head showing the lens and both windows.

Thank you for sending us this information. We’ll retrieve the data from this test print, review everything and follow up with the next steps.

So as I mentioned. I actually worked with support yesterday and with his assistance we were able to see that there was a problem based on his words not mine with the backend. The logs showed him that set focus’s measurement was somehow getting lost in between passes but only when you used a saved setting (even though that setting was set to auto). I’ve been able to cut successfully after we realized that by simply using a “manual” set of settings (not to be confused with manual focus height - that was still auto). By using manual settings but set to the same values as one of the saved cut through perfectly. Even with the same magnets. (I can understand the magnet argument but it doesn’t seem to be affecting my issue as we tested without magnets and he saw the issue- but I’ll keep that in mind when using higher material).
There should be some service ticket in your backend to review the backend issue as to why saved settings are behaving differently than when you manually enter. They said they would email once they look into it and I’ll update this when they respond.

Right now I have a workaround and it’s been working great so far. The workaround is to not used saved settings and instead just type in my values manually for the pass through run. Minor inconvenience but easy enough to do.

1 Like

P.S. if you need the extra run through you mentioned even after my support chat yesterday just let me know. I’m assuming you just didn’t realize I had done tests with chat support already.
Again right now my problem seems fixed as long as I use manual settings. Even with magnets and my other process. I will try the pins again but didn’t have good luck with them before but that was a long time ago. But yes we mainly used the magnets to hold the last cut flat as the outside props weren’t 100% level with the bed. But the prints prior to using the magnets (ie steps 1 and 2 out of 3, wouldn’t cut through and step 3 is where we used the magnets mostly).

I had that issue caused by the magnets before quitting using them. The most noticeable is that if you can detect the field with a lightly held screwdriver at the height of the printhead, then every time the printhead is near, the head fan behind the gantry can no longer work. The primary result is a candle-like flame that has soot all over and will not cut near as deep. If you see soot-marks that are not pointing sharply to the front of the machine then that is diagnostic. You may also get a yellow lite and the machine stop and will not restart as long as the field is there.

As mentioned in the most recent Latest Improvements post we recently made some changes that should help with this.

I’d love if you could help me test.

Since you have manual settings that are working as you expect, I’d like you to try to re-save those as new saved settings, with a new name. That way we can isolate the older saved settings.

Please let me know what you find out, and thanks for your help!

Awesome. Do you know what date that fix was applied?
I’m away at the moment but will try later this week and update.

Rita’s post linking to it was posted Oct 14.

The latest improvements includes the notice: "Changes may take 24 hours to appear."

Awesome! Let me know what you find out.

Unfortunately it does not seem to be fixed. I tried just a few minutes ago (on Oct 19, 21 around 1:00 pm to 1:50). I tried 3 passthrough cuts - a small oval but placed high to allow passthrough. Each totally separate cuts. The first was the manual settings (127/Full/1pass/Auto), the second with my previous saved settings (called “MDF - 1/4 - GS2”), and the third I made manual settings from 127/Full/1pass/Auto, and saved them as “MDF - 1/4 - BUGFIXED”. For each I made sure to toggle a different setting first, then back to the setting I wanted (just to make sure nothing was cached), used the “Set Focus” on the area of the oval, and did the automatic pass through alignment wizard. All were set to material of Thick Draftboard (but I wasn’t using any passthrough settings, so I don’t think it matters in this case). This was a piece of the exact material that I had issue with previously, the material was completely flat, and no magnets or any other elements were used that could have affected it.
The first cut through just fine, the second and third both failed to cut. All of them should be on the same settings theoretically but are still not cutting through when using saved settings.
Below are the images of the front and back:

is the material really flat? could there be something jammed into your crumb tray that is moving the material up somehow?

Yes the material is absolutely flat. No elements are pushing it up. The issue is proven to be software not only with my results but based on backend data the support rep was able to see. It’s something with saved settings. They are still looking into it but the latest fixes don’t seem to have made a difference for this specific issue (the issue they list sounds totally different as well).

well crap. just a thought. hope it get resolved quickly

Thank you so much for running those tests.

I’ll update the investigation and let you know when I have more.