Set Focus Override Problem

I am experiencing a “set focus” override glitch on a Pro machine (that is, I believe, days away from one year old and being out of warranty). Please review the two photos.


Note the most obvious difference can be seen on the “Member Since and date” elements. The outline around the “EvolveKY” logo is also much sharper on one than the other. Both of these badges were printed with the exact same speed and power settings, on the same material. (1/8” birch, from HomeDepot I think. But I am confident the material is not a factor.) The difference between the two burns is that the ‘blurry’ version relied upon auto focus, and the crisp clean one used manually input focus height on each step.

I have a score preset with that is purposely out of focus (set at .5") to give a wider line burn. On those badges, 2 elements use that setting (the name and the circle 1). The other elements I had set for “auto,” which are supposed to use the measurement from the automated “set focus.” It appears the “out of focus” manual preset is overriding ALL of the steps focus settings. When I tested individual elements(without the out of focus preset, but still using auto focus during the tests), everything looked great, but then looked horrible as soon as I tried a complete badge that included the preset.

I discovered a solution to this by trying to set ALL of the steps to ‘manual’ and inputting the proper material thickness for the focus, as well as still using the preset for the one score step at .5. This produced the expected result of a cleaner thin score for the Member Since Date and outline of the logo. So it seems, that even one step with a manual input focus setting will override autofocus on other steps. At least all similar steps (all the score steps in my case). (I can’t imagine that I’d be cutting through even 1/8” ply focused at .5”.)


I have not yet tested to try and replicate the issue on my much older Basic machine. Nor have I experimented with whether or not the override happens only to elements that are essentially “grouped” within the GFUI. (I cannot select the name separately and move it around. It is my understanding this is because there is an element, the outer cutline, that completely surrounds the name and other elements, which prevents them from being selected separately. This doesn’t bother me. But I will experiment with bringing other elements in the UI with a badge, and see if the “outside” element settings are overridden when using the out of focus preset and ‘set focus’ feature.


So, the work around to the problem is quite simple. Just input the material thickness manually. Not really a big deal. I wanted to bring this into view of the GF community, because I suspect this may be what has been happening with others, and they simply haven’t recognized a correlation of presets/manual setting vs. autofocus.

I am submitting this as a problem because if this is a machine specific issue, I need to get it addressed right away, as I said, my Pro machine is days away from going out of warranty. But perhaps it is a firmware or coding collision that happened with an update along the way? Or maybe it’s always been there, and I’ve just never had a job where it was so obvious, so I didn’t even notice.

Thank you. I appreciate your efforts in solving this for me and the community. Still absolutely LOVE my Glowforges!

Edited to add: I am NOT experiencing any offset or calibration/position issues with this. (Though I probably shouldn’t ‘say’ that outloud.)

3 Likes

I love posts like yours because they make me realize that I might not be crazy :slight_smile:

I have been having a little funky stuff like what you explained. Your write up really helps :slight_smile:

2 Likes

You still might be crazy, but not about focus issues. :smiley:

I’m also suspecting this has been the reason I’ve had some materials not cut all the way through, immediately after determining the ideal settings using my personal “new material test” file.

2 Likes

Yes, I believe you are correct, its not focus, its something with its setting it is using. I spent a while playing around with it the other week.

1 Like

Hi @n_dawson I’m sorry to hear that you’ve been running into some trouble with recent engrave prints. I understand any concern with the focusing potentially causing this, and will be happy to help you with any troubleshooting. To get the most accurate gauge of the current print performance of your Glowforge, can you run our Gift of Good Measure test print using the steps provided in the link below?

https://support.glowforge.com/hc/en-us/articles/360033633374-1-Gift-of-Good-Measure

Feel free to post photos of the results to help me review that for any next best steps. I’ll look forward to your response. Thank you!

The Gift of Good Measure printed great.

I am a bit perplexed with further testing. Using GF presets seems to negate my theory of manual/ autofocus overrides. Seen here… Matching settings of speed and power, with one of my saved settings set to .5 focus vs. GF preset ‘draft’ with autofocus. (The resulting print is as expected.)

However, with 2 of my saved settings, matching speed and power, one set to auto and the other at .5, they look exactly the same. Which goes along with my theory. The result is the same as with the badges. The “focus” preset is definitely NOT in focus.

I am relatively confident I can continue burning files with good results by inputting the material height manually, so if anything on MY presets is indeed overriding anything else, it will be with the proper measurement.

I’m very interested in your teams examination and diagnosis. Let me know if you need more from me.

I realized I forgot to compare preset “auto” with a preset “manually input” focused measurement. This seems to go along with the (amended) theory that “CUSTOM SETTINGS are overriding, or ignoring(?), autofocus, if/when a custom setting has a saved manual focus height, rather than ‘auto’.”


I then tested the amended theory by removing use of the out of focus custom preset… With a surprising result…



The top two sets should again match, but they still do not. All 3 sets should just about match, as the only difference SHOULD be power. I understand higher power WILL give a slightly thicker score, but it shouldn’t be as much as displayed here at the top. (The bottom two are actually expected results.)

So… I believe the question is: What is making “custom saved settings (at least for SCORE) that are set with ‘auto’” apparently ignore, or miscalculate, the autofocus input? PLEASE do not hesitate to correct me if you are seeing or thinking something else is the issue/problem to be solved here.

There have been problems reported with preset settings not working correctly. Are any of these examples where you input the speed/power manually that you have saved as presets?

3 Likes

Yes. All of them. :slight_smile: I noted where I used GF PG presets. But all the other settings were either my presets as saved, or my preset, then changed (not saved) to match a GF PG preset.

Startin’ to feel a little bit forgotten… :frowning:

Hi @n_dawson - thanks for the awesome writeup and data for this issue you’re seeing, I’m sorry for the trouble, and our delay in responding!

While this is something we’re still looking into I wanted to reach out just to let you know we’ve seen this and are looking into everything you’ve shared here. We’ll follow up once we’ve had a good chance to look this all over.

Thanks so much again for this level of detail, it really helps!

Thanks for the update. No problem working around the issue, just wanted to be sure it was indeed not forgotten.

1 Like

Hi @n_dawson, we’ve made a change to the system that may have had an impact on this issue for you. Can you try some tests?
If the first test has the same problem, try starting over and re-saving a new saved setting. That way we can test by isolating that specific saved setting.

1 Like

Will do. Unfortunately, it may be a couple of days before I can test. I’ll attempt to do the same type of tests, showing very specific settings, all input and saved (or not) differently, but the actual settings being the same.

Hi @n_dawson, thank you so much for your help and thorough testing. I look forward to the results. The more information you can provide, the better we can identify the issue and get it resolved to get this working as intended.

To test, I created a new blank file and inserted .5” squares and circles all within the GFUI. 4 sets, scored on Proofgrade Medium Draftboard, using the following settings:

1 = PG preset ’draft’ score (300/41/autofocus)
2 = PG preset ‘draft’ score (300/41/manually set focus (.131 measured with digital caliper))
3 = SAVED preset score (300/41/autofocus)
4 = Same SAVED setting as #3 (300/41/manually set focus (.131 measured with digital caliper))

The results are EXCELLENT. All four of these scores should be the same, and they are indeed virtually identical. I can see a slight difference between the autofocus and the manually input focus, however, that difference appears to be the autofocus measurement being ever so slightly different(more accurate I suspect) than my caliper measurement. I say that because both the PG autofocus, and the SAVED autofocus scores ARE identical (1 & 3). And the manually input focus height scores are also identical (2 & 4). Which shows there is no difference between a PG setting and a SAVED setting.

I will certainly post up if I experience any future issues with focus, but it appears that settings in ‘saved’ presets are no longer ignoring the autofocus input.

THANK YOU!

2 Likes