PDF madness continues – looking for PDF-Pros


#1

… again I’m struggling with simple pdf-files :roll_eyes:

attached two files, maybe someone can help me:

file “D” is an 1.4 pdf – GF says “Sorry, bitmaps can only be engraved”
birdtest4D.pdf (768.1 KB)

file “E” is an 1.3 pdf – GF cuts every path twice
birdtest4E.pdf (778.1 KB)

also tried 1.5 (usually working setting) – got the same bitmap error

both are made by illustrator

perhaps you can just load the files and tell me about the GF response

thanks


#2

Looked only at the E file - all shapes are doubled…

you can see in the pic i dragged some nodes from one of the outlines . Its drawing twice because there are two of each .

You need to break the baths on each object then delete one of the 2


#3

For what it’s worth, I think the vast majority of Glowforge users, certainly on this forum, use SVG format to get their files to the Glowforge. That doesn’t mean PDF shouldn’t work, just that SVG is likely to be paid more attention, better tested, and better understood.

It’s all a moot point if the issue is in the design, but still something to consider that may avoid introducing more variables.


#4

:thinking: very interesting, when i open the file in illustrator there is just one path, also in acrobat pro i can only see/edit one … no groups or masks … but i think before going that deep into pdf-code i’ll switch to svg.

thx for testing :slight_smile:


#5

If the paths are directly on top of each other, no zoom level will reveal them. Try moving things around like @PlGHEADED did.


#6

(Oh man, I had written this late last night, but somehow didn’t post it. You’ve gotten good advice, but might as well post it anyway :-))

The GF is cutting it twice becasue it’s reading the two lines that make up the outline of your objects. You can see it in the picture below. (My Corel program is in “wire” view so you can see it better. It gives a view of the file similar to an x-ray with the colors etc. stripped away.)

Your objects are made up of “compound paths”. Here’s an example of what you’re seeing. I placed the two rectangles on top of each other and “combined” them together to make a compound object. (Other program calls “combine” something different.) The GUI reads the red outlined box as two boxes on top of each other and is cutting both box out . It’s not reading the outlined box as just one single-stroke line. (Clear as mud yet :-P) The links below should help fix it.

I agree with Chris about using PDFs and I stick with SVGs for the most part. PDFs give me a headache lol.


#7

Weird. Opening both in Illustrator, I don’t have any duplicate paths. Each document has 14 closed, vector paths. Loading it into the UI, I was also getting the engrave issue.

You know what fixed it, @mrkz? I noticed looking at the document info that the paths matched the number that should be there, they were all closed, there were no embedded or linked images… but, there were 14 objects listed with transparency.

All 14 objects had a multiply transparency effect applied to them.

If you change that to “Normal”, it will load into the UI as a cut just fine.

The transparency effect must be handled differently when it’s loaded into another program like Inkscape (and @PlGHEADED saw) or Corel (like @kittski saw), and also like what the UI saw.


#8

That is weird. Wonder why the difference?
The only weirdness I saw was in the “D” file with the single stroke lines. There was a “lens” effect listed in my Corel object manager under each separate object. I never could figure out what it was and I saw no difference when I ungrouped each object and deleted it. I wonder if that was the transparency I saw being listed as a lens effect?


#9

yes, you found my workflow-error :tada: :trophy: thanks!
of course transparency can cause problems … just forgot to look at :confounded: also assumed pdf 1.3 gets rid of all transparencies … but that apparently works only for bitmaps.

i’ve no idea why other software (incl. GF) doubles the shapes … so the pdf-path-enigma keeps unsolved :ghost:


#10

Thanks for the help everyone!

@mrkz I’m glad you got it figured out! I’m going to close this thread, but please let us know if you have any more questions.


#11