Problems uploading bmp for photo engrave

Hi there.
I keep getting an error message everything I go to upload a bitmap for photo engrave. Is this happening to anyone else? Has something changed?

I don’t think it takes BMP files. You can upload JPG and PNG, though.

1 Like

Welcome to the forum.
I think you can embed a bitmap in an SVG file (created in Inkscape, for example) but you cannot just upload a bitmap.

1 Like

You can, actually. :slight_smile:


Tell us how! Enquiring minds want to know!

How to use a .bmp file? There’s no special trick.

Create–>Upload from file
You’ll note by default the “Custom Files” filter includes ~20 different filetypes; one of which is *.bmp.
Select your file.

Maybe I’m misunderstanding something here.

1 Like

I just drag and drop onto the dashboard. :woman_shrugging:

1 Like

I ALWAYS forget that’s a thing. I remember when they announced it. And I tried it and went “Okay. Cool.” And I never did it again for some reason. It’s been a couple years. And I just never do it!

It took them before the upgrade. That is why I don’t understand why its not working.

What’s the error?

Try clearing your browser cache?

1 Like

Dang! I remember seeing that! Slapping my forehead

1 Like

Thanks. That’s another totally useless error. :slight_smile:

Couldn’t tell… What browser are you using? If you’re not, I’d recommend a Chromium-based browser like Google’s Chrome or Microsoft’s Edge.

Can you try a different browser anyway? Or, try an Incognito window in Chrome / InPrivate window in Edge.

Can you try from another computer? If you don’t have access to one, it’s a little more trouble but, you could log in from Chrome on your mobile device. You’ll also have to get a bitmap file onto your mobile device to test your particular issue.

Since the error’s useless, perhaps it’s the size of your bitmap? How big is it? Have you tried something very small just as a test?

Okay… That’s all I’ve got for now. :slight_smile:

Oh no, I’m sorry you’ve hit a snag.

To investigate further, could you share a copy of the file with us? If you don’t feel comfortable posting it on the forum, you can email it to us at

Additionally, we’ll need a bit more information to investigate. Please do the following:

  1. Go to
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

1 Like

Did that too. :confused:

I’m using Google chrome. I’ve tried resizing the bitmap. I’ve tried to even do pics that I’ve already used to engrave and it wouldn’t use those again either. I’m not sure what us up with that. Had no problem with it before. But thank you everyone for the help. I really appreciate it.

It won’t let me upload the bitmap. But this is the photo that I turned to bitmap. Maybe I’m missing something but like I said it won’t even let me do an engraving of other bitmaps I have already used in the GF program.

Do you get the same error if you try to upload as a jpg instead?

1 Like

It uploaded without issue for me.

1 Like