Problems with photo engraving settings

I had posted this issue in the Beyond the Manual section hoping for some help, but the problem still persists. You can read the issue here

In short, my issue is that my custom saved settings are no longer working correctly. I have a saved setting that I use for Photo Engraves that used to work well. Now it doesn’t. Putting the same settings manually each time, the photo turns out how it should. Here are some images that show what is happening

Here is my custom saved setting

Here is the same settings entered manually

The saved setting was set to run first, then the manual run second. The order hasn’t mattered for how each one will turn out. I have done this test many times on many photos and it always turns out the same.

Here is the final output after the engrave, custom preset on left, manual settings on right

I find it amazing how different the two prints are, seeing as they have the same settings.

My current work around is to manually enter my desired settings EVERY TIME I need to run a photo engrave. It works, but it is frustrating to say the least. Presets are supposed to help my process, not hinder it.

I ran this job this morning 08/18/21 @ 8:05am eastern time. It is the only job I have run so far today.

I loaded the svg file which had both images into the user interface. I can’t attach the file here since it is too large at 10.8mb.

Can someone please take a look at what is happening? My other presets for cuts, scores and vector engraving seem to be working normally.

If you need any other information, please let me know.


I should also note that I cleaned all cameras, lenses and mirrors before running this print this morning.

I have an idea.

Try saving the manually entered setting as a NEW “saved” setting, then repeat the exercise (smaller pics to save time/material…)

I am wondering if the way they are saved as actual settings is determined at the time they are created. i.e. the numbers you see aren’t actually what’s “behind the scenes”…

Of course this isn’t a solution. I just like to experiment.

That is a good suggestion, and one that I had already done.

Before running my tests this morning, I deleted my saved preset, created a new one, even naming it differently than my old one just to be sure it was new to the system.

Thanks for the idea!

Then hopefully they can look at the logs from today’s print using two identical settings and figure out why they were actually different!

/Following. I’d love to learn what the explanation is for this.


Well…now I have another problem.

The saved settings for my Baltic Birch is no longer working. It was fine for cutting 5 sheets this morning. I noticed that there were just a couple of spots that weren’t burning all the way through, so I changed my speed setting from 170 to 165 for just a little more burn time, and re-saved the preset.

The following sheet did not cut through at all and the cut line is super wide compared to the normal cut.

I changed the preset back to 170 speed and resaved. tested a cut square, it didn’t cut through at all. I manually entered my 170/full/1 pass settings and the next square cut out perfect.

So I have another preset I can no longer use.

This needs to be addressed. Someone from GF needs to look into this and figure out what is happening. If I can’t use presets, it will really affect workflow.

The squares were being tested around 830am.

Doing some more testing throughout the day, I believe there is a focus issue when the preset is saved.

My workaround for still using the preset is this…

When selecting the task to cut, I go into the settings for my saved preset. Then I toggle the focus from auto to manual, then back to auto. Re-save as the same name. Then all additional cut tasks can just be selected as the preset and they all cut as they should.

When I load a new job to print, I have to do the same scenario as above for the first cut task…

I hope someone here can help with this…but since I haven’t had any response in close to a week…I am guessing I will get no answers here.

I didn’t toggle it to manual.

If it mis-measured…it only mis-measured on the tests where I tried using just the preset, not manual settings, so that seems unlikely to me.

I will look into using the flashlight, I hadn’t come across that trick before.

It just isn’t how the settings are saved that is the issue. I cannot create a new saved setting or change any of my currently saved settings without making them unusable. It may seem like a low severity problem to some, but it really slowed down my workflow today, that’s not a low severity problem to me.

Thank you for your help!

1 Like

Maybe. Maybe not.

Looking at the example engraves above you have both a loss of definition and a darker engrave in the problem engrave. Both can be symptoms of out of focus. It’s just much more obvious when it’s a cut vs an engrave.


Ha. Not at all. @dstosik did all the troubleshooting. If we were speculating, some variable either didn’t get renamed, reassigned, or something along those lines when the manual/auto focus toggle button came into play.

Honestly, I never trusted auto focus a whole lot and preferred to always set my own focus value just a touch into the material. But my original GF had some auto focus issues… The key back in the day at least, was making sure that the focus height was a different value than the material height box so that it would respect the manual focus entry.


I’m so sorry for our delayed response @dstosik. We aim to provide prompt and helpful support. We failed to do that here, I apologize.

Thank you to @eflyguy, @dan84, and @jbmanning5 for helping troubleshoot the issue further.

I’ve taken a look at the “settings test” print from the 18th and can confirm both steps had different focal heights. In this case, the one with the Autofocused result turned out as expected, whereas the step with the manual focus did not.

To get to the bottom of why this happened with identical settings, I’ll need some more time to review additional prints with additional manual settings and reproduce the behavior myself.

You mentioned you performed some additional troubleshooting steps yesterday. Could you provide me with the name of the file and the approximate time you performed these?

This will allow me to gather additional data and take a deeper look. I look forward to hearing back from you!

1 Like

Thank you for your response!

If the “settings test” print from the 18th that you are looking at, is the same one that I posted the images here, I find it funny that you mention one print being autofocus and on print being manual focus. Both are/were set to be autofocus. I only ever use manual focus when engraving 4 coasters at one time since they usually have different thicknesses.

You can tell from my screenshots that both images were set to autofocus.

I did some testing yesterday morning around the 8:30 - 9:30 am timeframe. I was having issues with cut lines after modifying one of my presets. I just started cutting a bunch of squares around that time. If you want me to do other tests and record when I perform them and what file name I am uploading, please let me know. During this testing I believe I also starting setting the material height and focus height (unless I did those tests this morning, I have tested so many things I have a hard time remembering anymore)


I have run another test for you to review. It is the filename of “cut and engrave test” performed on 08/30/21, run at 5:50pm eastern time.

I have three examples for you to look at.

1 - cut lines of squares
2 - photo engrave
3 - standard engrave by fill color

I created the file in inkscape with all 6 jobs in the file. So only one file was loaded to the GFUI to do the test.

For each of the 3 scenarios, I used a custom preset of my own making and the exact same manually entered settings.

Once the settings were entered, I performed a manual “set focus” from the drop down. Once focused, I clicked print on screen. Once the blue light flashed, I pressed the button on the GF itself.

I watched the print happen through the entire 12 minutes of the print. One thing I did notice was that there was a pause between every step…I assume that is the print head setting a new focus value. Just as all my previous tests have proven, the custom preset used did not turn out correct, and the manually entered settings were exactly as expected.

1 - Cut squares - settings used 170/Full
Preset used “BB Cut” on left
Manually entered on right

Very wide line for preset, not cut through. normal cut for manual, cut through

2 - Photo engrave - settings used 1000/90/Dots/0-100/MaxQuality/270lpi
Preset used “Dave HD Photo” on left
Manually entered on right

out of focus on preset, expected result on manual

3 - Standard Engrave with fill color - settings used 1000/20/270lpi
Preset used “1000/20/270” on left
Manually entered on right

much softer edge lines on preset (which I actually like, so I’d like to know the focus value on this if possible so I can duplicate the soft focus in the future)
crisp lines on the manual edges

Please let me know if you need anything else tested or if you can figure out why the focus values of my custom presets are not working properly.


Thank you so much for your continued patience @dstosik, and I’m sorry for our delayed response.

I can confirm we’re able to reproduce this issue on our end, and we’re currently looking into a fix.

I want to be transparent, I don’t have a specific timeline to resolution.

The best path for consistent prints at this point in time would be to manually double-check/enter the settings each time. I’m sorry for the frustrations this has caused, it’s not the experience we wish you to have.

To ensure your Glowforge is operating as expected, could you run a standardized test for us?

  • When the print finishes, leave the lid closed and wait until the fans stop and the picture updates.

Let us know how it goes, and if you have any additional questions or concerns.

I’m glad you are able to reproduce the issue. It means I wasn’t doing anything wrong :slightly_smiling_face:

Here is the GOGM print. It was printed at 9:05am on PG with PG settings.

Let me know if you need me to do anything else.


1 Like

Thank you for running that test for me @dstosik. The Gift of Good Measure looks amazing! This allows me to confidently say your Glowforge is operating as expected.

With that being said, I would recommend manually double-checking/entering the settings each time for future prints.

While our team investigates the circumstances around this trouble further, I’m going to close out this forum post.

Should any additional questions concerns arise, please start a new post, or reach out to us at

1 Like