Purple button during print

buttons
error

#1

Doing a small test print of some curves on non-:proofgrade: 4mm plywood. During the first task (engrave) the head stopped and the button turned solid purple. No indication of anything on the UI. In fact, the UI continued as if it was still printing and eventually said it was done and I should wait until the fan turns off before opening.

Here is what everything looks like:
(Head is stopped, fan is blowing. The black things in the corners are magnets, could that cause weirdness?)

(A truer representation of the purple)


#2

Maybe.
I don’t think we’re supposed to get purple buttons any more, just yellow, white or teal.

I’d wait for support on this one, cause we don’t have all the current color codes and they tend to shift over time.

What time did it happen? (roughly and the time zone?)


#3

Around 6:30 PM CST.

It was doing an engrave which I had set at 1000 Zooms, 25 Precision Pews, 225 LPI and 1 pass.


#4

Okay, that’s cool. They can pull the data if they know what time it happened and see what’s going on from their end. :slightly_smiling_face:


#5

Turned the machine off and on again, re-loaded the print and gave it a go. Got just a little bit further but same result. This is a design I drew up in Inkscape:

CurveCut01


#6

Hmmm, not sure how to link an svg


#7

Okay, hold off on doing anything else until support gets back to you. They’ll ask for more tests if they need it. (Might be obscuring things.)


#8

The SVG is there; it’s just tiny. Discourse does strange things with SVGs and in this case it just made it 20px by 12px. (I think it tried to interpret the 20"x12" size of the file as pixels instead of as inches. Hey @discourse you guys should fix your SVG size-sensing code to know about non-pixel units. :smile:)


#10

Does this recovery mode ever actually…recover? I let it sit there for about 30 minutes of nothingness then power cycled.

Define “frequently”. I just had it happen twice in a row.


#11

No, I don’t think it does anything useful at this point.


#13

I think that probably qualifies.


#14

Thanks so much for letting us know. I’m looking into it now, and I’ll update this thread once I have more information.


#16

While investigating, I noticed that your Glowforge recently connected successfully. Could you please try to print the “Gift of Good Measure” on a piece of draftboard and let me know how it goes?

We’re continuing to look into what caused the purple button you encountered, but I want to make sure you’re able to print in the meantime.


#17

Yes, I turned it on and let it sit for a long time in case it was updating anything (it’s been several days since I used it last). Tried to print my test svg and it completed successfully. Would you still like the ruler printed as well?


#18

That’s my take too. I had it happen last week. Said a bad thing because it was the first time and I was trying to make an anniversary present. Turned it off for 30 seconds and then back on (old electronics reset method :slight_smile:). Everything was fine after that.

Wonder if something is going on that’s kicking these out now - or if it’s just because there are more people running GFs so what was unheard of before now occurs simply because the population of usres is finally large enough to trigger some of these bad code pathways.


#19

Based upon the available data, I am convinced that the planet is experiencing a high muon flux.


#20

Seems legit.


#21

I too experienced the “purple” button. Then after a few minutes went yellow. But the machine was frozen. It would not respond to anything. I power cycled the forge and everything is running as if nothing ever happened.


#22

Thanks for your patience. I’m glad to hear that you’re printing successfully! There’s no need to complete any more troubleshooting for this issue, but thank you for asking. Since you’re good to go, I’m going to close this thread. If you run into this problem again, please open a new thread.


#23