Recent change to bitmap in SVG vs PNG/JPGs?

This is a new issue I came across in the last project which was cut after the recent update. Although I can work around it, it prevents me from being able to use SVGs with bitmaps in them and that’s a big issue. Anyone else see it?

There is a very noticeable degradation of the bitmap only when saved as part of an SVG file. I am using the same process of converting and saving files that I have effectively used for a year so nothing has changed on my end. The vector elements of the file were converted to bitmaps at 600 dpi. The only difference between the two versions seen in the pic below is one was saved as PNG and one was saved as SVG.

Left is the nice PNG version and the right is the degraded SVG version.

This is what it looks like cut. (Vary power / 340 or maybe 270 lpi.) I had cut a few things prior that came out horribly and I thought I had just screwed up the DPI when converting them to bitmap. Double checked and it’s definitely happening on the GF end. It was a costly mistake and used up some precious wood :frowning:

1 Like

Do you remember when rotating a bitmap within an SVG file caused the quality to degrade? It looks like that same issue.

Maybe do the rotating in design software first then use the “Rasterize” tool to make it a bitmap again after all the work is done, so there is no translation being done.


I only rotated these to get them closer together for the pic. It happens when I bring them into the GUI without any manipulation at all. The vectors engraved and processed fine.

I would think it was maybe from my end/program, but I can’t figure out what it is. I’ve tested it a dozen times by converting a vector to a bitmap in Corel. I then save the same bitmap as an SVG and PNG exactly like I’ve done fa few hundred times before. They are now coming in at very different qualities.

Same bitmap saved as SVG and PNG

In Corel are you leaving the bitmap in the file and then doing a Save A and SVG and in the pop-up telling it to embed the picture (vs. linking)?

Yes, the same as I’ve been doing all along. I can’t figure out what could have changed on my end to cause it to do this. FWIW, I also tried exporting it as SVG and a few other setting just to see if there was a difference, but couldn’t see any. I’ve also opened old SVGs containing bitmaps that worked fine before and they are degraded now too.

Can you share a file that is effected? Or even just create a new one with a random image, so your designs aren’t out in the wild, that shows the same symptoms.

Thanks for taking a look. It’s definitely on on my end when saving as SVG. I’m sure it’s as simple as me hitting a weird checkbox or something and not seeing it. It seems to save fine, but when I go back and reopen the file , it’s very low DPI and pixelated. Coincidentally or not, my computer seems to be in a slow meltdown as well and acting very glitchy so maybe that has something to do with it, I dunno. I’m going to do some maintenance and reboot just in case. Don’t think it’s related, but have to do it away. :slight_smile: .

Here’s the vector SVG. Can you convert the vector file to bitmap SVG and send it back to me so I can see how it come in?

Here’s the vector SVG

This is what the bitmap looks like when converted on my end

!This is what the SVG bitmap version and the PNG come into my GUI as

Here is your SVG that’s rasterized (at 600ppi). It looks just fine in the UI. (51.5 KB)

Can you upload a copy of that file but after you’ve rasterized it (the one that’s looking bad in the app).

I’m so sorry about the trouble! Thanks for including those screenshots.

Using the file you shared in your most recent comment, I made a bitmap copy of the artwork in Inkscape and saved that as a new Plain SVG file. This file matched the quality of the vector version when uploaded to the Glowforge app.

Could you please do the following for me?

  1. If possible, share one of the converted .svg files that reflect degraded quality when uploaded to the app. If you’d rather not post it in the forum, you can email it to us at

  2. Try the steps below to make a bitmap copy of your file using Inkscape, and let me know if you see the same results:

    • Open the design in Inkscape.
    • Using the Select tool, choose the object you want to rasterize.
    • With the object selected, choose Edit > Make a Bitmap Copy.
    • A copy of the object will appear as a new bitmap layer.
    • You can choose to either delete the original vector layer, or ignore it in the Glowforge app before printing (To delete the vector layer, choose Layer > Switch to Layer Below, and press the delete key).
    • Save the file as a new Plain SVG

Let me know how it goes.

Hey @vee, you can close this. The issue is on my end with Corel. Haven’t figured out what it is, but it’s not the GUI. Thanks for the help.

Thanks @vee . I will get to it as soon as I have more computer time in a day or so. I honestly think it may be on my end, but I guess we should make sure as I haven’t figured it out yet. Just didn’t want you to think I was ignoring you.

Thanks for the update @kittski.

I’m going to close this thread - but if you need anymore help, please don’t hesitate to post a new topic.

1 Like