Scaling issue when exporting from Aspire/Inkscape and importing into Glowforge app

I have been trying to make parts for a wooden clock but they either come out too big or too small.
I have tried using DXF, SVG and even PDF with no luck. I have tried making identical parts in Aspire and Inkscape and always the size is off. I have used the measuring tool to verify the size of the parts before exporting but the problem is the same. I will attach some files. One is one of the clock parts and the other is a test rectangle drawn in both programs. I even set the work space to 12 X 20 in the programs. Any help would be awesome.
Zentira test aspire.dxf (15.1 KB)

19x11.dxf (6.6 KB)

Try making a bounding box of known size around all your parts in a different color.

Then when you upload to GFUI select all and check the size of your box-o-parts with the measure tool. If it’s off you can resize to the correct size there and set the box to “ignore”.
If it comes in the correct size and the parts cut differently that’s a very different issue to suss out.


Nothing imports into Inkscape from these DXF files and the Glowforge app gives a warning that there is no size information in the DXF file.

The originating CAD file/program has to have units defined in order for DXF files to have scaling info available for other programs to import properly.


I will try ekla’s bounding box idea in the morning, it’s 2am right now, but you are right nothing imports into Inkscape. Get a couple errors and then nothing. I don’t understand why. As for the units I see that as well but again don’t know why. The rectangle I drew but I don’t know what it’s looking for to define the dimensions. Does anyone know what I’m missing in the original CAD drawing that’s missing in the DXF export? It seems like I should be able to draw a circle or box and just export it but I am clearly missing something here.

1 Like

If you have a 20"x11" box around the design and it comes into the app wrong then you can scale everything there so the box is 20"x11" and your work is the correct size and location. On the other hand, if you know the correct size of your work you can just scale that.

I’m sorry that you’ve run into trouble with the scale of your design once it’s imported into the Glowforge App. It looks like you’ve already received some excellent information from our other community member. Thanks folks!

Our team only provides support for Inkscape and Adobe Illustrator. That being said, I may be able to take a look and see if I can find anything helpful regarding the other software you’re using. May I have a bit more information on which CAD package you used to create your DXF?

First off I’d like to thank everyone for their help and suggestions. The “bounding box” idea is a good one and I found that it was helpful in confirming the actual size of the part or “scale”. I was able to use that as a bit of a workaround but I was still frustrated that things would not import correctly. Well today I finally think I found the problem. You see I’m one of those people that does not turn off my computer for days or even weeks at a time. It turns out you should restart your computer sometimes. I decided to delete all my test files, turn off the computer and start from scratch. Turned it back on, edited the original file in Aspire to delete everything but one part, put a bounding box around it and sent the file to Glowforge as a SVG. Checked the scale using the bounding box and it seemed right so I printed the part. It came out perfect! So the moral of the story is when designing stuff and it doesn’t seem right try flushing the memory and buffers of your computer by restarting it. :slight_smile:


I think I finally got it.

I restarted my computer and all was right in the world again.

I thanked everyone on the forum as well.



P.S. –I usually use Aspire as I know it better than Inkscape

It’s great to hear that things are working well now! If you run into trouble again, or have any questions for our team, please reach out and we’ll be happy to help.