Scanning and calibration getting stuck - are we having an outage?


#1

I used to be an ardent defender of cloud services, but I may be starting to lose the faith.

I’ve been working on some projects this evening and everything was going ok. Then it got stuck on “Scanning”, so I tried cancelling and trying again a few times with no luck. So I turned it off and on and now it gets stuck during calibration. It goes to the center and then goes to the left and then sits there. No orange light, but no progress either.

Based on a few other reports on the forum, I’m guessing there are some intermittent server issues today. Once again, we have no status page to look at, no diagnostics, and no message from Glowforge to tell us something is awry. This really needs to change. I don’t expect 100% uptime, but the time I have when I’m not at work is quite limited and precious. The remainder of my Saturday is rapidly draining away and I don’t know if I should continue futily turning it off and on.


#2

Now it’s not even moving to the left. If I start it under the camera it just does a little nudge and then sits there forever. App says “Calibrating”, and yes I’ve tried logging out etc.


#3

Just finished two 1 hour engraves. It said calibrating between them which was unusual but that only lasted 2 minutes.


#4

I’m also trying to run a job and it has been waiting for calibration for 10 minutes or so.


#5

Unless I’m running a huge engrave I don’t wait for anything on the GF more than 5 minutes. Unless it makes noise like something might be happening. The interface too often gets stuck on the various steps like scanning, calibration or preparing. Log out, power down, power up, or wait forever.


#6

Somewhere around 10 reboots later, I’m printing again. No idea if it will last.


#7

Same issue here. Opening and closing app and restarting. Got a few prints. This shouldn’t be happening. Hope it is just a short term issue with the cloud process.


#8

I’m apparently up and running after a few reboots and reloading of the website.


#9

About ten minutes ago a <1 min cut finished and then it was stuck in calibrating. I turned it off and on again. Gave up a minute ago, but I have some design work to finish and dinner to make so I figured I would try again after that was done.


#10

Just ran two prints in the last hour, no problems.


#11

When I pay nearly $5000 dollars for a machine I expect it to work whenever I choose to use it. If it requires the cloud to work then it needs to have 100% uptime, or very close, like gmail. If they can’t do that they should give up on the cloud and run the web app locally on the machine like OctoPrint.


#12

I am also completely stuck on calibration. This happened to me once before but I was able to quickly resolve it that time by power cycling and moving the head to the center. This time I’ve performed numerous power cycles, web app logout/logins, moving the head under the camera (yes, with the power off), etc. and no dice. I appear to be permanently stuck at “Calibrating the head of your Glowforge. This can take a few minutes.” Quite frustrating as I was intending to print out part of a Halloween costume that I need for tonight.


#13

I avoid Cloud-based anything where-ever possible… but there is no other option here so needs must

image


#14

The more Glowforge owners recieve their Glowforge more data will be pushed through the Glowforge servers - I hope that they have accounted for this issue.
If it is an issue.


#15

They aren’t Glowforge’s servers. I believe they are Google’s servers.


#16

I’m sorry this happened to you.
I’m glad it started working again. I recall it happened to me once. Only once, I believe. Regardless, of course you’re absolutely right… if the cause is on the software side it cannot be allowed to happen with any frequency. I realize I’m stating the obvious but, 99.x% uptime is really required for the success of all parties.


#17

Was good all afternoon. 4:00 PM to 7:00 PM CDT inactive while I was working on something else, but it remained turned on, and had no error upon loading a new design.


#18

It got stuck on Scanning again, but when I took a screenshot to complain about it properly, my screenshot program locked up, demonstrating that ALL software is unreliable these days. I cancelled and started again, and the scanning went just fine, but now it’s hung up on preparing. This shouldn’t take long, the “design” is just a single cut line. Oh well, I guess I’ll just keep cancelling and starting over until I luck out and get connected to a working server.

I’ll just leave this here.


#19

Just to continue my evening fun report: Cut the the line successfully and afterward it started calibrating again but never finished. Power cycled and got it to calibrate.

There’s a time in development when your service hasn’t launched yet and you’re ok not having adequate monitoring and a 24/7 on-call rotation. That time has passed.

Oh, by the way, I finished making the stuff I wanted to make, so there’s that. Service interruptions aside, this machine is so friggin’ awesome.


#20

I was thinking Amazons but either way…