Select material goes to blank screen

I’ve just logged into the dashboard and set up for a cut on the machine, whenever I click on the select material button the whole screen just goes white and nothing happens. when I refresh the screen it just goes back to the view of my artwork on the material. I’ve logged out and in and switched off any ad blocksrs and things like that.

This has never happened before, any help would be greatfully appreciated, the rush job for a client is turning out be be a nightmare because of this.

1 Like

YES. It is 2:00am my time right now, I work late because I have a one year old, and I am about to snap. I have a rush of graduation this week and do not have time for this shit lol. They better fix it ASAP.

Are you having the same problem?

Yes, it literally just started a few minutes ago. I have been running the last few hours no problem. You can’t even do a manual material thickness, its all the same. I tried different browsers, restarting browsers, refreshing, turning off the machine, everything. There must be some sort of update happening or a bug.

Been an owner from day one with the crowdfunding campaign and never had a single problem with it. Really dissapointing. Hope for both our sakes and anyone else it gets dealt with quickly.

I am having the same issue here. Hope it gets fixed soon

This is middle of the day for most of Europe, so quite inconvenient…

For this, would definitely +1 a local solution instead of Cloud… (especially with all the “Premium” restrictions that have been put in place :frowning: )

1 Like

Running into the same issue, I was using mine throughout the day yesterday with zero issues.
I’ve tried everything on my end to try to get the app to work but it’s looking like the issue is on Glowforge’s end, I really hope they can resolve the issue promptly because like you all I have time constraints on the project I’m working on.
I wish there was a local version of their app we can have installed on our computers to be able to continue to use the machine while not being reliant on their cloud tech.


Am having the same problem, and a client is about to eat me up… hope its getting resolved. i have re- stated the GF several times… very frustrating, In Uganda and its the middle of the day

Same problem here and on a time crunch. Glowforge support - where are you?

The automatic reply I got from the support email says their regular hours start at 8am PST so we might be waiting for a few hours to get a response.

how frustrating!

Same thing happening here on two different accounts and lasers that I’m running hope this will be resolved quickly

Well has there been any fixes for this? I just started trying to get some work done. Frustrated

I am also having this issue in the UK. As a work around the QR scan feature is still working, so if you have a proof grade QR code of the same thickness material it will accept it, and then you can manually adjust the cut/engrave settings.
Its not a perfect solution but its got mine running again.


Was about to post the same thing. I’ve been taking the QR code stickers for proofgrade and keeping them aside for just this type of situation.

Thanks for the workaround, I’ll keep that one in the memory banks in case it happens again, ended up getting the band saw, drill and old fashioned measuring going on here to do what we needed, would have taken hours less with the laser.

Would a picture of the QR sticker work? Can anyone provide?

Once again we NEED a desktop app so badly…

1 Like

Mine is not working with the QR code, unless I am not doing it correct.

I should have done that before… its frustrating