Select material

Hi all, I am unable to select material. Whenever I click on select material the screen goes blank and stats that way. Any ideas on what’s going on? Thanks


Came here to say the same thing! Logged out and tried again. Next I’ll reboot.

1 Like

This is happening to me too across multiple devices and browsers. I’m restarting my devices now and trying to see if it will scan PG material.


Restarting won’t help. Just submit a ticket using the form on the support page.

1 Like

Mine is doing this too, even on other devices and browsers.

1 Like

same here boosting

1 Like

Looks like this issue is affecting all. Fingers crossed they’re working on it. I’ve scrolled around to look for a post from GF that they’re working on it…and haven’t seen one.

1 Like

Same here. I tried multiple computers, followed all the steps in the email sent when I submitted a tickets as well as the old, turn off, turn on of the computer :frowning: Hoping the issue gets fixed quickly.

1 Like

I’m having the same problem. I’ve restarted everything, and the problem still isn’t fixed. Any ideas?

half the day is gone and this problem still persists, I have a lot of work to get done!

I just ran a job on mine, the first of the morning and it is working fine. Hope the issue is corrected for all.

1 Like

It’s happening systemically. Try this work around: "Select Material" not working? Here's a work around

It’s already been fixed, so clear your browser cache and reload the page.

1 Like

I see a couple folks said that the problem has been solved - this in NOT the case for me. The problem still persists!

It has not been fixed for me

I’m using the app as we speak, and nobody has made a new post about this in the past 2 hours since Glowforge fixed it. It is fixed. You need to clear your browser cache then reload the page.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.