Set focus not working for me today

I too have now been hit by the set focus bug. As of today I am unable to get set focus to do anything. I won’t put the square where I place it on the screen and it won’t move the head. Have rebooted the laser, mifi, and iPad several times and tried more than one browser. I’m assuming this might be related to the other threads I’ve seen of people having this issue. Any idea when it will be fixed? I do a lot of very small stuff and having set focus inoperable is a big issue for me. I hope it’s going to fixed very soon.


No way to know how long it will take, but I know that they are working on finding it. It’s impacted a handful or two of folks over the last ten days or so.

I’ve had this issue. As soon as o get an answer or fix I’ll advise. Maybe if you get something that works for you can you advise as to what worked for you?

Thanks. I figured for now I’d concentrate on projects that I fit on an entire sheet rather than need small bits of it.


Cathe, if you are able to get it to focus on a full sheet, the problem might be that the little red laser dot is falling into cutouts in the material, instead of on the material where you want to print. Give yourself about a quarter inch space around your design when you use the Set Focus tool.

Have you run the Calibration for your machine?


If it works on full sheets, then it should work on a piece a couple of inches square - can you put such a piece on the bed alongside the smaller parts, and use that for focus?

It’s not working at all. What I meant was I can deal with placement better on a full sheet as I have a little more wiggle room.

Are you having design placement issues, or focus issues?

I don’t see any mention of placement in your previous posts.

As I said originally, set focus is not working at all. Can’t get the head to move to where it should go. It just ignores the set focus command entirely. This would affect placement because even with calipers, set focus is always more accurate. Especially on smaller projects, hence my planning to use full sheet projects where it’s not as critical.

This doesn’t sound like the same problem other people had been reporting: their machines would try to measure the material and then report an error that it was out of range.

Pretty weird though, if your machine is otherwise working. Does it do the autofocus when you start a job?

1 Like

I’m so sorry to hear about the trouble you ran into with set focus. I extracted the logs from your most recent print and it looks like set focus was working properly from our end.

Could you please let me know if you are still having trouble?

Still not working. It’s 1:50pm PDT and I just tried it. I click on set focus, put my finger on where it should go on the screen (I’m using an iPad) and it never moves the head. When I try it a second time it has moved the square elsewhere on the screen and it’s orange, but it’s not where I told it to focus.

And once I’ve done 2 tries, I can no longer highlight anything on the screen. And the square is stuck where it put it on the screen. To be able to move anything on the screen bed, I have to close the file and reopen it.

Something really odd is going on. Was there an app update that might have gone wonky for iOS devices?

Next round of test for this. At 4:07 PDT I had my laptop running Windows (not a touch screen) do a Set Focus command it did move the laser head and do the correct thing, immediately after I tried it again from my iPad and it did not work. So it is at least touch screen related to the app. Not sure if it’s just iOS but I’ve tried it on both my iPhone and iPad and it will not cause the Set Focus command to do the right thing. At least I’m assuming it’s not a machine issue or it wouldn’t work from a Windows device. If you can access the machine at a time I’m available (not hard these days) you can perhaps see what I’m taking about.

I am having the same issue with the “set focus” after this update.

The update is being rolled back this week. See if the issue continues, and if it does, start a new thread so support can address it.

Thanks for that news. I really liked the pop up with the xy coordinates do maybe it’ll come back later when the kinks are worked out. I’ll see what happens.

Different issue. The rollback is for set focus giving a height error for thin materials. Problems with the UI in Firefox on an iPad… well… I’m surprised that ever worked.

Worked fine until this week’s UI update. Many GF owners use iPads with the GFUI on a daily basis.

Thank you for letting us know that you’re only seeing this when using your iPad & phone. Does the same thing occur when you try using Google Chrome on either device? To investigate this further, could you send us your specific browser info for Firefox?

Please do the following:

  1. Go to
  2. Click the link underneath “Share my system info with tech support”
  3. Copy the highlighted link
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

For Firefox it’s this one:

For Chrome

Both were updated to the latest version before testing today. Same behavior for both as well as Safari. I can click on Set Focus and nothing happens. After that I can no longer highlight anything on the screen or move anything. I have to refresh the design to be able to move anything. And the laser head never moved when I gave it the Set Focus command.

So it’s not a specific browser bug, it’s a general touch screen UI bug is my guess. This worked fine Monday. It started on Tuesday when I got the UI update.