Software not responding

Hi is anyone having trouble with their software - I am unable to move things around or even select anything


Yes, have tried all morning. I cannot select, move anything as of 9am, 8/5/21

1 Like

Same. Whatever they did in the update last night screwed the interface up. Im dead in the water right now with two weeks until a major convention. Im not happy.

1 Like

As a work around, it seems you can hit refresh and select/move one item before it stops working… Not sure if you can move one item, refresh and move another. Worth a try to see if that will get you going until its resolved.

1 Like

Yep looks like it’s affecting almost everyone. We are ALL dead in the water. I wish someone from GF would at least post something about it here.


Same. Thought it was my browser, however, I’ve tried a few different ones with the same result. Can’t select anything.

Same. UGH.

Glad its not just me, I was refreshing but then when you select the material everything moves and you cant fix it. Hope they fix this fast. So glitchy.

The words new and improved = cost twice as much and will last half as long

1 Like

The update process here is a joke. “Lets update the software durning the week and see what happens. How bad could it be?”

1 Like

Has anyone gotten a text notification of the issue from GF yet, or have a link to the status?

1 Like

Here’s the status page:

Pretty useless, since it says everything is operational :frowning:

If it says operational, it must be true!

I found if you open your work it will let you move 1 time and then click on the hand or arrow and then move work 1 move at a time

1 Like

Same problem here… and it even shows “No Artwork” even I open previous printed file… :frowning:

Mine wont even let me do this. Some items are moveable, others are not no matter what I click on, refresh, etc…

Someone said that a work around is viewing the screen at 25%, and then widely selecting the object. Most of the time, I was able to select an object this way, and was able to move it where I wanted it to go.

doesn’t work!

me either, this is not right they need to respond to this issue ASAP

same here! Did you know they were doing a update last night? if so where did it tell you?