Start button does nothing. Its flashing blue and when I push it, nothing happens

I have used my machine and its been flawless all day and now it wont print. It centers, prepares print, all of it, shows me the time it’ll take to finish the job and the light flashes on the machine, when I push the button, nothing happens. I have a HUGE event coming up and tonight and tomorrow are my biggest days of work work work and I NEED this to work! Any tips???

Welcome to the forum. I suggest you turn off your Glowforge. Sign out of the app. Clear your computer cache. Wait a couple of minutes and then turn on the Glowforge. Let it complete the entire start up sequence. When the head is at the home position, sign back into the app. Double check that your design is placed properly and that the cut/score/engrave settings are ok. Click print. When the file has been processed, the button should flash and you should be able to press it and start the print.

1 Like

I tried all of your suggestions and it still doesn’t work. :frowning: I am in desperate need for this machine to work today!

Start the Glowforge with nothing on the bed. When it is ready, put some Proofgrade draftboard in and try printing the Gift of Good Measure. If the same problem occurs, note the time /date of the failure and any error messages you receive as Support will need that information.

If the Gift of Good Measure begins to print normally, then the problem is with the file you are trying to print.

Let us know if the Gift of Good Measure prints.

Can you confirm… It’s flashing BLUE?

If I recall (only heard of it happening once), blue can mean it’s too cold to operate. Which should result in an on-screen messages stating exactly that.

I am not getting a message confirming its too cold. It shouldn’t be but it is colder by the window.

When you load a design in the app, everything looks normal? So it’s showing your machine online?
Can you take a screenshot of the app and a picture of the blue button?

Any button color other than yellow or white (or teal during the setup) is something that support has to look into by looking at your machine logs. Wait to hear from them. (Sorry, we can’t suggest anything for you to try to fix it. You need to hear from them.)

My machine has always blinked blue when it was ready to cut. Ive had it for less than a month, but its always blinked blue and hasn’t ever not cut til now.

Probably a faulty LED then. It’s supposed to be white when it’s ready to cut.

Now, as for my other question… Can you screenshot the app? Just thought another set of eyes on it might catch something.

That didn’t work either. Dang it.

Does anyone know if Glowforge customer service is ever available for live chat? I have messaged them before with concerns and haven’t ever heard back from them. I cannot wait forever to have this resolved. My kiddos count on me to earn an income for our family. :frowning:

Can you try Chrome instead? This way we rule out Edge being the problem.


It can take a couple of days. Meanwhile we can do what we can for you. You may still have to hear from Support with the information they can see on their side.

When you press the blinking blue button, does anything at all happen? Does it still keep blinking or does it stop blinking?

It keeps blinking. Nothing happens. Nothing moves

Could be more than an faulty LED… Could be a bad button.

Just tried Chrome. Nothing changed. Oh my. I cannot believe this and to hear that it takes days for customer service to reply, not makes me wanna cry. Thanks for the continued ideas.

Your switch inside the button might be broken. Get a flashlight and look at it underneath the glass and see if you see any disconnected wires…although the signal is being received, it might just be a physical problem in the switch.

1 Like