Stray lines in engrave


#1

This has popped up several times with other users, and for me personally as well, but I haven’t seen much other than “We are looking into it” as a solution.

I keep getting stray lines in my engraves. This morning I got another one. I usually look for open paths, and I have seen the report of nodes on top of each other causing it. But like some of my others, I can’t find any of those, and it doesn’t always happen. It doesn’t even happen in the same place. Though this one is a first in that the line stays in the same place, no matter how I arrange the file. Line is ALWAYS horizontal no matter how I rotate the file.

I understand the work arounds, and have done so for this file, but it’s an annoying little bug that I’d really like to see squashed. I spend a lot of time engraving, and having to change my file every time it decides to rear it’s little head gets a bit old.


#2

Wow. This bug still exists?!

As far as I can recall it’s from rotating the image in your vector application and just needs to be rotated in your raster application.


#3

Can you share the file?


#4

doghead.zip (3.4 KB)


#5

I am pretty sure I didn’t rotate it in Illustrator, just normal edit stuff. It wasn’t until I saw the line show up the first time in the preview window of the UI that I tried rotating it, just to see what would happen. I have had luck rotating vectors and having that that get rid of lines, so I figured I’d take a shot.


#6

when i try to open this SVG in illustrator, i get a “this SVG is invalid. Validate it before opening.” error.


#7

Interesting. I did too. No issues with the .ai version. So I saved it as a svg again, and have no issues with that one. doghead2.zip (1.9 KB)


#8

I put it into outline mode and the dog’s eyes have a bunch of extra lines in them overlapping. Here they are separated. Could be something to do with it.


#9

File under “janky svg”.


#10

I wonder if that’s an Inkscape from illustrator thing. Ive got none of that in Illustrator.


#11

i opened the doghead2 file in illustrator.

i see six copies of the eyes, nose, and mouth on stacked top of each other. that will most definitely confuse the GFUI.

this is what the layers look like when i release the compound path:


#12

Might be a little easier to see here:

These are the objects that end up selected when I select just the left eye:


#13

Thanks for the help everybody.

@curt did removing the extra eyes, noses, and mouths improve the situation?


#14

Yes, though I still believe there to be a stray line issue based on other files. I haven’t had time to go back to those yet. Maybe today.


#15

There are always potential issues in an svg with node inconsistency. You might be right, there may be an issue… however there are lots of users here, and this isn’t a complaint I see come up unless there is an underlying problem with the SVG. I’d think if there was some larger issue at hand we’d see it more often.

I suspect that your other files will have either strange pathing (nodes out of order and connected across your shape or broken paths) or duplicates like this one. If you can’t get to the bottom of it, everyone is always eager to help (as you’ve seen!) :slight_smile:


#16

Well, when I originally wrote GF with the issue, the said they saw the problem and they were working on it. I saw several other posts around the same time that acknowledged the issue, but have never seen a fix posted. Granted, I haven’t tried the original file since, I’ve used my workaround file.


#17

Thanks for letting us know, and I’m so sorry your print didn’t turn out the way you expected. As you know, the team is looking into this issue, and I apologize that I don’t have any further updates at this time. In the meantime, I’d like to share some tips that may help to work around the issue.

Based on early testing we’ve done, it looks like this is occurring because of a problem with how the software interprets certain path properties in SVG files. As others in this thread have mentioned, and as we’ve heard from some customers, removing or otherwise mitigating overlapping path nodes from the file using design software should help eliminate the stray lines. Depending on the software you use and the techniques you prefer, there are a few different ways to do this. I expect you could find a helpful tutorial in the Tips and Tricks area of our community forum.

Alternatively, you can engrave the design by converting it to a bitmap, which should also eliminate the issue. In Inkscape you can do this by following these steps:

  1. Open the file in Inkscape.
  2. Go to Edit > Preferences > Bitmaps.
  3. Under Create, change the Resolution for Create Bitmap Copy to the resolution of your choice
  4. Close the Preferences window.
  5. Select your image.
  6. Choose Edit > Make a Bitmap Copy.
  7. Inkscape will make a bitmap copy on top of the original artwork.
  8. Click the top artwork to select it, drag it off of the original artwork, and delete the original artwork. You’ll be left with the bitmap copy.
  9. Select File > Save As and save the file as a Inkscape SVG file.
  10. Upload your file to the app and print.

Or, in Adobe Illustrator:

  1. Open the file in Illustrator.
  2. Select your image.
  3. Go to Object > Rasterize.
  4. Select File > Save as and save the file as an SVG.
  5. In the SVG Options dialog, under Options, select Embed for Image Location.
  6. Upload your file to the app and print.

I hope this helps! I’m going to close this thread, but if you run into any other trouble, please start a new thread or email us at support@glowforge.com. Happy printing!


#18