Stuck Cancelling and Won't Connect to Wifi

Here’s what happened:

  1. A cut job had just finished and the head moved back to the back left corner like normal - but as I was removing the material from the bed, I noticed that the countdown was still going on the website as though it wasn’t done.

  2. After removing the material, I closed the lid and clicked, “Cancel.” The site stayed in cancelling mode for quite a while.

  3. I rebooted the Glowforge and browser - no change. Still stuck cancelling.

  4. Reset the router. Rebooted the Glowforge again. No change.

  5. Turned off the GF, moved the head under the camera, and powered on. No change.

  6. Held the button down until teal and ran the setup 8-10 times. Each time failed with the “Glowforge didn’t connect” error.

  7. Tried running setup using phone hotspot. No change.

All devices in the house are connecting to the wifi and working normally. Glowforge was connected and running normally prior to “cancelling” previous job.

Checked the connections of the lid cable. Nothing loose or visibly wrong.

After all the attempts at running the setup, the teal light stays on until I push it again (after the fail). The GF fires up for a couple of seconds, but the gantry/head stays wherever it is and there’s a very slight humming sound underneath the normal GF noise that doesn’t stop. I’ve had a GF for nearly 3 years, so I am really familiar with the sounds it makes.

At a loss at this point. The default answer is usually to replace the black cable. I have always had one on hand, but I sent the last one to another user who needed it.

1 Like

Support might need to see the logs from the machine. Here is a post with the steps to retrieve them:

If the wifi connection process will not complete, I doubt it’s the cable.

I’m so sorry for the trouble. I extracted the logs from your Glowforge to investigate your report, and I can see that your Glowforge may be having trouble maintaining a stable connection to your Wi-Fi network. It looks like the last time the Glowforge was successfully connected was during your most recent print. It has not come back online since.

If you click “Cancel” from the Glowforge app while a print is running, a request will be sent to our servers to stop the print. However, if your Glowforge loses its connection to your Wi-Fi network at anytime during the print, our servers will not receive that request to Cancel the print until the unit reconnects. If a print does not cancel as soon as you’ve pushed the “Cancel” button, you can stop the print by lifting the lid on your Glowforge. However, you may still see the “Cancelling” message in the Glowforge app until your unit has reconnected to your Wi-Fi network.

Since you’ve tried Wi-Fi setup again, unsuccessfully, the next step I would suggest is a factory reset.

Please do not perform a factory reset in the future unless asked. The factory reset deletes troubleshooting information from your Glowforge that we can use to help you, so we want to make sure that we have everything we need before a customer resets.

Here’s how to reset. Please do not turn off your Glowforge until the reset process is complete.

  1. Turn on your Glowforge.
  2. Open the lid.
  3. Press and hold the Glowforge button. The button will glow teal and eventually blink teal.
  4. Release the button when it begins to blink teal.
  5. Press and hold the blinking teal button again until the button begins to blink blue.

    The button will eventually turn solid green on its own, and your Glowforge will reboot automatically. Please contact us if the button does not turn solid green.
  6. After your Glowforge reboots, the button should glow solid teal again, and your Glowforge will be in Wi-Fi setup mode. Navigate to and follow the on-screen instructions to reconnect your Glowforge to your Wi-Fi network.

Let me know how it goes!


Thanks! I did that and it did turn green, but it’s been 5 minutes and nothing else has happened after that.

It doesn’t mention closing the lid again, but I assume that I should have, so I did after it turned green. Should I have left it open?

It’s been several more minutes and the light is solid green and it hasn’t done anything else. I assume we should try again. Please advise.

Please go ahead and turn the Glowforge off, then back on, and proceed with trying Wi-Fi setup again at


It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email