Stuck focusing problem is getting worse, happens consistently & constantly

This problem that some other users have had started happening to me in the last couple of months (after working pretty well for 9 months): sometimes, and more recently most times, after the 1st job or 2nd the unit will click 3 times in 3 seconds, then pause for a bit, then repeat. It says ‘Focusing’ on the Chrome app window, and never gets to the Centering or Autofocusing part.
I’ve spent hours on multiple days now:
I tried the router/PC/GF reboot thingie.
I tried connecting the GF to a mobile hotspot and to a different router.
I tried the full cleaning of all lenses & mirrors.
I checked the lid cable & the 5 connectors, and the white ribbon cable connector, and generally looked everything over for issues.
I turned off overhead lights and blocked light from windows.

Any other ideas, anyone?

Glowforge tech support, could you check the logs and let me know what to do? This is a painful problem as I’m trying to get a project finished.


Dave in Fremont, CA

Excellent trouble reporting! Only thing I can think of is maybe a new appliance or something that’s interfering with the wifi signal, since that could have affected all three trials…microwaves, Apple TVs, and baby monitors, etc. Could even be something next door, if your neighbors are close by.

Have you tried changing the channel of your 2.4GHz network? Another thing that worked for me (before I got my Eero mesh) was setting up the Guest wifi as 2.4 GHz with a password so nothing else could use it except the GF, AND putting an extender right next to the GF.

1 Like

Could still be the black cable too. Cant focus or do anything else for the calibration if it can’t get the image from the camera to the circuit boards let along the servers.

The weird thing about this problem is that the GF will, upon first use after days or hours, usually fire up and run at least 1 job, long or short, and then almost always get stuck on ‘Focusing’.
This seems to indicate it is not a connectivity or dirty lens or loose connector issue.
Seems more like an issue that occurs when the machine warms up even a little bit.
That said, I just ran 7 2-4 minute jobs with no glitches at all, after switching the GF to my backup router & internet (and disconnecting everything else off of that). --thanks, geek2nurse, for that suggestion.
BUT, the issue could still be happening after the unit heats up from the more common longer jobs. Will test that soon. (BUT, it is a Pro, and I’m running 100%, not FULL).

1 Like

Oh no, I’m so sorry you’ve hit a snag.

Thank you so much for including those excellent notes and troubleshooting steps, as this allows us to quickly investigate.

I see two main issues when I review the logs. The first is the connection your Glowforge is receiving. In these logs we have a record of the average signal strength the Glowforge is capturing from the network it’s connected to. On average, this signal strength has been low over the last week, with average strength at around -78dBm as of today. For more context, on networks with very good signal strength, this will often run closer to -30dBm. A signal strength at -70dBm or lower would be very difficult to stay connected to.

Here’s what I’d like you to do, if you’re still having trouble: please contact your internet service provider, and ask if they’re able to run any diagnostics to measure the performance of your 2.4GHz frequency band. Please explain that you’re having trouble with the connection of one device that only uses 2.4GHz, and our technicians were able to verify successful connections and no dropped packets, but low signal strength ( around -78dBm ).

There may be an issue with the performance of the 2.4GHz band on your network. Because this band isn’t exclusively used by many devices, the issue might not be seen on other things that are connected to your network.

Next, it seems like your unit is running into trouble during the calibration step in which the lens focuses inside the printer head (you may hear this when it’s happening - there’s an audible “ticking” sound as the lens moves up and down in the head). There are a few different reasons this error may be occurring. Could you please check a few things for me to help narrow it down?

  1. Check the printer head lens by following steps 1-5 from these instructions: If you see anything unusual such as damage to the lens or debris in the printer head, please take a photo of it and attach it to your reply
  2. If you are using magnets to secure material to the crumbtray of your Glowforge, please remove or reposition them and try again. Magnets placed close to the printer head may cause trouble during calibration
  3. Check the connection of the printer head to the white ribbon cable in the printer arm. Turn off your Glowforge, unplug the head, and plug it back in. Note whether the cable plugs back in securely, and whether you feel it “click” into place

Let us know how it goes!


Thanks for the response. I have previously tried and checked everything you mentioned but will try again tonight.
But really, I have not had any other issues other than the unit getting stuck clicking and saying it is focusing, sometimes for a few minutes, sometimes forever.
So I think you are telling me the clicking might be a mechanical issue, not related to the signal strength issue? Last night at 10pm ish Pacific, I ran a series of short jobs without issue. I had switched the wifi to a separate router and isp, with no other devices connected to it.
But again, I have not had any other issues than the focusing. So I’m not sure if the weak wifi signal is of concern at the moment.

So I did step 1 and did not see any damage to any lenses or the mirror, nor any debris.
No magnets have ever been used.
White ribbon cable clicked in, and did not note any damage anywhere.
I power-cycled the unit and it went thru focusing by clicking 7 times, moving slightly but audibly in the -x direction for a tiny fraction of a inch, then centered normally, 4 times in a row. It is getting late so I stopped.
I’m leery to say the problem is solved, since I didn’t really change anything. And I wasn’t running any jobs – usually it lets me run 1, maybe 2 jobs, then gets stuck clicking & focusing.

I have not experienced problems with my black cable. I barely have run Beamer.

However, it sure seems to me that when you open close a few times then you end up with a problem.

my bet is the cable

Hi @dchen,

I’m glad to hear things seem to be going better. Looking at the logs from your unit, there were two separate issues happening. The clicking issue during calibration is separate from the connectivity trouble.

The calibration trouble you were experiencing could have been caused by a slightly loose printer head cable, and when you reseated it the connection improved. Looking at the logs from your unit, I’m not seeing the same errors as before. The last error occurred on the 9th, so I think you are good now on that front.

Your WIFI signal strength still looks not so great though. Below are a few things you can try to help improve it. If those steps don’t seem to help then you’ll definitely want to reach out to your internet provider as my colleague Jeremy suggested.

Since things look to be good now, I’m going to go ahead and close this thread. If you run into any new issues or the calibration trouble starts again please open a new thread or email us at and we’ll be happy to help.

Offline Troubleshooting

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.