Stuck on Centering after cleaning unit

I just finished a big run on my GF and it was looking really grimy, so I cleaned it yesterday, as I have done several times, including doing fan maintenance. When I turned it back on, it had trouble focusing, but I reseated the lens and it click-click-clicked to focus, which seemed normal, but then didn’t do anything once it went to “Centering” mode.
Several tries of reseating the lens and printer head, moving the arm with the power off, checking cable connections, etc. hasn’t done anything to get me past that.

  • I cleaned the unit thoroughly
  • Had initial problems with focusing, but it seems to focus OK now
  • Once it reaches the “Centering” step online, it gets stuck
  • The arm does not move
    Here’s what I’ve done:
  • Followed all the advice on this support page with no luck
  • Turned the unit off and on several times
  • Tried leaving it on for at least half an hour with lid up
  • Reset the wifi
  • Checked all cable connections, they look fine
  • Cleaned all lenses at least 3x, including camera
  • Turned off overhead lights so there’s no glare
  • Cleaned printer head connections and checked connector was secure
  • Moved the printer head to the middle of the unit
  • Note: I have had longer “centering” times when the unit was too cold, but the garage is warmed up and the unit is at room temperature.
    One other thing I tried was going into Fan Maintenance mode again and moving the arm. It properly moved the arm to the front of the unit.

Did I mess something up when cleaning? Is there a way to check the logs for that? I don’t see any mechanical issues based on the various threads I’ve read on centering issues.


Great job of explaining the steps you’ve taken…it eliminates a lot of possibilities, narrowing things down to one that might be the culprit.

It’s possible for one of the lid cables to fail after cleaning, because we tend to open the lid wide to do it, and opening the lid fully upright can break the wires inside if they are stressed or old. (Mainly on the earlier machines, the new ones have a slightly different cable.)

That is an easy fix that you can do yourself, you just need to let support see your ticket, check your logs to make sure that’s the problem, and get you set up with a replacement cable. So just wait to hear from them, and I hope that’s all it is.

Great write up of your troubleshooting steps. :slightly_smiling_face:


Thanks Jules - much appreciated. I’ll cool my jets until Support has a chance to look into it a bit. It’d be awesome if it was as simple as a cable replacement, which I could totally do myself.

1 Like

It looks like that is the case! Thanks for all the work you did in ruling out the possible causes. Thanks @Jules for the spot-on diagnosis and words of encouragement!

I’m going to close this thread and follow up in an email so we can get you a new cable and get you printing again.