Stuck on centering AGAIN!

What the heck happend to good ol fashioned customer service! Remember when you could pick up the phone and talk to an actual person?

My glowforge is stuck on centering ( again )

Im in the middle of an order that is due today and all I can do is email glowforge and hope they decide to get back to me…

Meanwhile I’m going to miss the deadline so I’ll have to hand this job off to another shop and be out all the money for that one…


The glowforge has been a great addition to the shop, but when it decides to do this mid-order… it is frustrating to say the least. Hey technology, F You!

1 Like

There are step by step instructions to test for most issues (cable or wifi seems to be the most common with centering issues). Unless it’s a broken cable, then there’s not much support will be able to do that hasn’t already been covered here on the forums so fingers crossed it’s WiFi and you won’t need to replace a cable!


Clips all looked good. Turned it back on and it goes right back to centering… nothing changed

I’m going through the same thing right now so frustrating. Wonder if it’s a software issue? It’s crazy so many people started having this issue so close together.

Ive wasted an entire day because of it… so pissed. Dont understand why they cant have a regular customer service… even if Ive got to talk to some dude in india… still beats the whole send and email then sit around waiting to see if they respond…

You’re going to want to start your own P&S thread if you want the staff to get back to you - but in the meantime, follow the same instructions posted above. First check your clips, then check your WiFi - the majority of connection problems that new users have end up being WiFi.

Have you done the WiFi checks yet?

Have done both…

Doing it again now…

Still not working…

Ok, but you haven’t posted your results - which means staff will just have to ask you to run them again when they get here so…

1 Like

Results… whay results… nothing has changed. I posted that cables (and clips) look fine ive reset wifi 3 times… none of which is working…

Man, I’m trying to help - but if you can’t even read through to the bottom of a single staffer’s post it’s gonna be really hard to help!

I’ll leave you to wait for staff to get here.


I get that you’re trying to help and I thought you were staff… I posted the results… sorry if Im being an a-hole but this is frustrating as hell! Lost an entire days work, and probably a really good customer, plus the damn thing is still not working. :rage::rage::rage::face_with_symbols_over_mouth:

FYI, Staff responses will be in yellow - plus they say “Staff” on the tag next to their name.
I get the frustration - but figuring out what’s wrong is the first step. You really don’t want it to be something that requires staff to intervene - because a) it takes longer for them to reply and b) if you have to get it repaired you’re talking at least a month or so!

So, the results I’m talking about are step 4 on the 2nd set of instructions I linked to - under:
We’re not finished! If the trouble continues, could you please run one more test? This test requires a laptop or desktop computer. If possible, try these steps from a laptop computer placed on top of your Glowforge (and on the same Wi-Fi network) for the most accurate results.

Damn… didnt even see that part…

Doesnt seem to be working

That first one was correct but you didn’t list the URL:

ping -n 50

(that’s what it means by IP address)

1 Like

Uhg… hang on, I’ll try that