Stuck on "Centering", "Scanning", and "Focusing"

Our GF was working just fine and suddenly it stopped working when I went to put in new material for the same cut/engrave that just finished. For the last 24 hours, it’s been stuck on either Centering, Scanning, or Focusing. Prior to that, my only issue was with things lining up and I was planning to try to run a calibration test, but got an error saying there was no image and to clean the camera. Things I have tried:

  • Reset computer, GF, modem, router many times
  • Tried different combinations of wi-fi networks, including hot spots, for computer and GF
  • Turned on the GF with the lid open and laser under the camera - got some movement thrice, but got an error saying it hit something and to check the bed for any obstacles, bed was emtpy
  • Checked all the clips on the lid - all in place
  • Cleaned all lenses and blew canned air over chip boards
  • Checked ribbon cable and pins

As I was writing all of this, I had the lid open and when I closed it, the laser moved around like it was going through the warm up cycle and banged into the front of GF again, like a loud bang. This is the third time it did that and this time it didn’t stop when it hit, there was another loud noise as it tired to move again.

Any help is much appreciated. Thank you.

If you’ve tried everything listed in this thread (it appears you have), it’s likely the black ribbon cable on the lid that needs to be replaced. Support will verify, and take it from there.

1 Like

@eflyguy I dont know if you mentioned trying a different browser like you suggested for my very similar situation . It definitely fixed my issue .

1 Like

That’s one I haven’t tried. Thanks you! So far, some movement, went through homing and is on centering. Did it work right away or did it take a while to go through everything?

I downloaded Chrome and haven’t had a problem since with that issue . I was using Safari .

I have been using Chrome with little issue and am trying Safari now.

It went through the centering and homing and now is ready, but the bed image isn’t updating to show material I just put in.

Other browser didn’t work - went back to getting stuck in scanning. Haven’t gotten a response from support either. This is extremely frustrating and we can’t complete projects for work.

yes it can be frustrating but at least they do eventually address everybody’s issues . They definitely have more of hand in the upkeep of software and any issues that arise which makes the available help limited but I do like that it wasn’t just haded off . did you try a different computer?

The issue you describe sounds very much like a black ribbon cable failure.

Support can take up to three business days to respond. They might ask you for clear pictures of the connectors where that cable is connected, so if you want to post those here or send via, that would streamline their response when they get to this thread. It is likely they will need to send out a replacement for that cable.

1 Like

Same issue with a different computer.

1 Like

Now we wait…


1 Like

Thanks for your help! My fingers are crossed. Should I include the clips on the lid?

I think so. Can’t hurt.

If it does end up being the black ribbon cable, I suggest ordering 2. That way, if it fails again, you have an extra. I replaced mine a while back and it’s been working great, but I have 2 extras on hand considering that it has a track record for failure.


I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.