Stuck on Preparing to Print / Now saying offline

Hi there,

Been having a few issues the last couple days.

Yesterday: after completing a successful engrave- I have removed the completed item from the bed and placed the next piece inside the glowforge. After doing so the glowforge app would say “focusing” but would never actually do so. In order to get it to focus again. I would have to shut down the glowforge (turn off and uplug the power cord for a few minutes) and then reboot. The would typically have it refocus, but I have to repeat this step every time in order for it to actually focus. (if I didnt do this it would just sit, no movement from the head no matter how long i waited).

Today: Started my first engrave this morning successfully- yay! Placed second item inside glowforge and had to repeat the same steps from yesterday to get the glowforge to focus again…

Was able to get it to focus, but then second engrave stuck on “preparing your design” for several minutes until it updated with “print cancelled”. Tried several times and it kept timing out and canceling itself.

Next, it just went offline entirely… Glowforge is still on, but app is saying offline…

So i turned it off and wrote this… a little frustrated as I spent the entire past couple days dancing around the focus issue and now its not working for me at all. Spending a ton of time troubleshooting and waiting with very few completed prints in that time. Bummer.

Appreciate any help!

A staff member will be here ASAP and they can look in your logs - but in the meantime there are things you can check.

  1. Is the material in your bed full of holes? Try a fresh sheet.
  2. Any bright lights/windows shining on your bed? Try with that off.
  3. Have you rebooted your router recently? It could be a WiFi issue - especially with the fully offline. Some routers “upgrade” to 5Hz when you’re not looking and the :glowforge: only works at 2.4Hz…

Here’s a walk-through of #3 along with some more things to try!



  1. The material is solid aluminum bar with a form of cermark applied to the surface (bright white).
  2. Glowforge is inside an enclosed room with the only widow being covered
  3. Rebooted router before restarting Glowforge to no avail. (its a att. hotspot, no updates to 5.0ghz)

I reviewed the post you included before posting my issues and tried all but removing the print head / cable so may try that later, however I just re-attempted an engrave (running as I write this) and success so far! But not feeling confident it won’t come up again, especially the lack of focusing after each job.

Yay for success! Fingers crossed it just needed a jiggle :slight_smile:

You always provide steps to hopefully resolve people’s issues. We the little people appreciate that.

1 Like


  • I’ve been printing semi-successfully for the past couple days since posting this.

  • Focusing after each job is still an issue (details below)

  • I now have Amber light showing (details below)

AMBER LIGHT: This morning (and a couple times the past couple days) the Glowforge has stopped itself right as it begins a job- fires the laser for a second and then stops and gives me the Amber Button :frowning: . Previously I have turned off the Glowforge- repositioned the head under the camera to position itself and restarted. This has worked to solve the issue in the past, however today, it repeated the amber button for a second time after trying the steps above.

Steps taken: I have followed the instructions for removing the head and checking connections:

Pins appear OK!

Warping around circuit board on laser head?! Have not seen this before- is this common? Thinking it may be the culprit.

Oh and photo of circuit board in the back left of the Glowforge (super dark sorry)

FOCUSING: I no longer am getting stuck on preparing to print, however focusing after each job is still an issue. After each job I have to turn off the Glowforge and wait a few minutes before rebooting in order for it to focus again. If not, it will stay in “focusing” forever without any movement from the head. (this is even true if I have not opened the lid after a completed job - which is confusing, because I didn’t think it required focus if you didn’t open the lid/ change out material)

For the meantime I have shut the Glowforge, and will await instructions.

Unfortunately, it looks like your unit is experiencing an issue that we can’t resolve remotely. I want you to have a reliable unit, so I’m recommending we replace this one. I’ll be in touch via email to sort out the details. I’m so sorry about the bad news.