Stuck UI - Uloading - Scaning yout material

I know there were some posts about this already and some resolve themselves.
This happends quite a lot and causes issues.
Here is how this goes.
Say I want to print something from the catalog, this means I cannot pre-position it in inkscape.
This opens in GF UI, but I am not printing on prograde but using my own material.

I run first cut but it is not cut all the way through. I want to run the same cut one more time without opening cover or changing any settings, or maybe just adjusting power or speed.

In fair amount of cases, the GF will get stuck in uploading/scanning your material dialog. With Cancel button grayed out. And there is no way to cancel out or wake it up. It will just sit there.

If I reload the page it will lose my positioning of the shapes and all the settings. There is no way to save the setings.

This happens few times a day for me.

I wish there was reset button that would reset the dialogs and try to reconnect but keep all the shapes and settings in GFUI.


I think I have heard that if you try to start a print too soon after the last one finished it locks up. Perhaps try waiting a while.


Tried it many times. Waited for hours. Waiting does not help.

Can’t say for sure if that is his issue but yes, if a person does not wait until the print button flashes once at the end of a print, usually about 14 seconds after the Ready is shown, the next print will hang on Scanning forever. The “Ready” indication just shows that it is safe to open the lid.


This may be the case some of the time but not the last time it happened.

Is this а feature or a bug ?


Open another window and start a new print without closing this window. It should fix this problem.

If they added a number of other features like numeric positioning and saved workspace states, none of this would be a problem. I hope they add this functionality soon.


Not to mention fixing the lockup bug.

1 Like

Thanks for letting me know about this. I’m taking a look.

This happens to me on a regular basis. I find that when I do a print, I wait for the fans to stop whirring, then I open the lid (I don’t wait for the software to tell me it’s done the cooldown, which I probably should). Then, I move some stuff around or swap materials or whatever, I close the lid, I go back to my PC and set up the next print. If I wait a little bit here, before clicking on “Print”, my GF will start making some little “click-click-click-click” noises. I have no idea what it’s doing. I think if I start a new print before if goes through its “click-click-click-click” routine, though, then I always run into the “Scanning your material” lockup bug. If I wait until after that, it seems to work.

Opening a second window and starting a print job does fix the first window for me.


Yep. Never start another job until after that last set of clicks in the head. The print button will flash once when that is done and the machine is truly ready. The “Ready” indication on the GFUI after the Cooldown is just an indication that it is OK to lift the lid.


I had a bad habit of opening the lid early. DIdn’t have too many problems. Most of the time when I am impatient it is to check some test cut and wouldn’t be loading another design. I generally had waited for the interface to reset before sending though because there is always a bit of post processing at the GF before I go back to the interface.

Tonight waited and realize that it is a bit of time after fans stop then the clicky/whir and then the flash. I’ll be patient from now on.


I wish they would have designed it so the button changed colors to indicate it’s time to open the lid, instead of having to wait and watch for a flash of the button. I would imagine it’s easy to miss that flash.


There is a tiny bit of animation with the “Ready” Button in the GFUI. Next time you are waiting after a print, take a look at it. When it switches from Cooling to Ready, the darker teal will surround the gray button thingy, so even if you miss that animation, you can know that if the dark teal is not surrounding the gray circle, it’s still cooling, but if it is surrounding it, it is now Ready.

I’m afraid we need a bit more information to narrow it down. Do you know the date and time (including time zone) when this last happened so we can investigate for you?

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email