Trace Feature Mess Up?


#1

Using the trace feature and this is what I have stumbled upon. As you can see the original image is all black and the trace function is gutting the little doggy. Any explanation?


Trace contrast adjustment
#2

The black may be catching the lights?
There are keyboard shortcuts to lighten or darken a trace. I’ll be damned if I can remember them though. I think it’s Ctrl + :arrow_up: and Ctrl + :arrow_down: if I remember correctly?


#3

ctrl up or down will adjust the contrast in the trace function. Then click the area you want to engrave.


#4

Thank you I was unaware of that feature! But it didn’t work well for this drawing. I’m gonna have to scan it for reals.


#5

If you have a minute, could you do it with the glass lid covered with something to kill the room light? I’m wondering if there’s an issue there (although for the love of me I can’t figure out why but I have seen some overhead light issues before).

I haven’t spent a lot of time with the trace feature because I’ve got a scanner hooked up next to it and because I don’t do much from paper source files anymore anyway. But I’m interested because I’m thinking of doing a GF MakerFaire cut/engrave thing like they did at NYC last year only at our local MF and I’m wondering how successful it will be.


#6

Yeah I actually had to do that at a Makerfaire I was just at. Especially on more thinner line drawings. I used a sheet of black gator board to block the light coming in. UPDATE: Just tried that method and same thing happened. I ran into another drawing with a lot of black space, same thing. It’s gotta be the bed lights reflecting off the pool of black sharpie. Glad I didn’t run into that issue at the faire. I had enough issues with connecting as it was (I’ll be posting about my experience later today or tomorrow morning)


#7

Yep. Another factor is whether the black fill was done with different levels of intensity. i.e. - if they pressed down a bit harder with the sharpie in some areas more than others, or if they did multiple layers of ink in one section, but not in others. IME, the camera seems to be sensitive enough to pick up on these subtle differences in shading.

I experienced this with one of my first projects on the PRU, and one or twice since then. It’s easy enough to work around, but yeah - it’s a thing.


#8

How are you “working” around it?


#9

Like if I’m at a Makerfaire (like I was on Saturday) I don’t have enough time to breath with the lines of people I had… KInd of like the sensitivity but can work against you too.


#10

I had a little on this image but not anything major in difference. I retraced the image with a fresh sharpie and the same thing happened. Beside, the bed camera isn’t that sensitive I wouldn’t think. Now if it was the future fine line head camera (BTW is that working yet?) I could see it being picky.


#11

Basically with the tactics mentioned thus far in this thread - being mindful of light sources in the room, adjusting contrast in UI, and also just by being aware of this factor when I choose my images. If I’m tracing (which I don’t do all that often) I try to ensure that the image has consistent saturation.

If it doesn’t have consistent saturation, the image is probably a better candidate for processing via software than via trace. <~ And I do realize that this last comment is not terribly helpful in the context of demonstrating at an exhibit, where you need to be able to print on the fly and don’t have time to fiddle around with software. Perhaps in that scenario, just encourage people to do simple line work without a whole lot of shaded fills?


#12

I used the blocking method a few times during the exhibit because of finer lines washing out with ambient lighting. I am suspecting it’s a software issue and not a camera one on the fills. The contrast feature didn’t work on these images. Thanks for your insight guys and gals!


#13

Just as an example of how “sensitive” it is, here’s a couple of empty bed images through the trace function. Most of your phone cameras now are going to probably be a fixed f/1.8 aperture. But, even if a cheaper camera, probably no slower than f/2.8. That, with a fairly slow shutter speed (if that’s the case), and it picks up quite a bit more light than what you might think.

Empty bed preview before trace:

Empty bed, what the trace is picking up (no contrast changes):


#14

WOw, you’re right, it’s pretty neato


#15

I wonder if laying a polarizing film over top of the drawing would improve the scan. Or perhaps in front of the case’s LEDs themselves. Too bad we can’t readily stick lens attachments to the Glowforge. :slight_smile:

https://www.amazon.com/Polarizing-Film-Sheet-Gadget-Electronics/dp/B004X3XFHU/


#16

I have had a degree of success putting a piece of masking tape over the two lights in the lid that flank the camera to dim them.


#17

That’s not the advertised use case though. Hand drawn images (especially off the cuff or amateur artists) are definitely not going to have consistent saturation. The “throw it in the bed and have the GF trace it” use case is a non-pro feature. The use of a scanner to import and clean up is more of a dedicated or “professional” user solution.


#18

@jonny_firebrand. I had this problem too. Dan’s tip to me is in the last paragraph of this quote from my June 11th post:

https://community.glowforge.com/t/wjls-production-machine-projects/8550/54?u=bill_laba.

Try ctrl-shift-arrow to control fill in of shapes. It worked back in June, hopefully will still do so. I don’t have time to try it right now.

For the batman scan, did you try changing the contrast? I think you hold ctrl and hit up or down to change the contrast of the image after you scan it.
Thanks @joe. I thought I remembered that there was a way to adjust contrast. Looked at all the commands on screen and couldn’t find it. The control-arrow shortcut does change the contrast, but unfortunately the contrast difference was way too much on this scan. If I adjusted enough to start to fill the interior void, the rest of the graphic started to fill also. I have written this down for future use. It already could have come handy for the Batman linocut in this post. We adjusted contrast outside of the :glowforge: 's interface to compensate for it being a black and beige image. As you’ll see in one of the posts above, Geordi did come up with an alternative fix and the Batman/Joker coaster is complete. The Romulan/Enterprise coaster is about 6 minutes from completion.

There’s another even secret-er shortcut - I believe it’s ctrl-shift-arrow. It’s in the manual. It controls the amount of “fill in” of shapes. It’s hard to explain but very useful to experiment with.


#19

THanks for the reference to this solution!


#20

Thanks for posting this. I’m so sorry you ran into trouble there. Using both of the shortcut commands that @Tom_A and @bill_laba suggested in tandem should help you resolve the “gutting.” If you don’t see improvement, let us know and we’ll investigate!