Please, please. The “trial” is a trial. How do I “opt out?” I’m spending hours trying to work in an app window that is half-empty, unhelpful, in the way and has made my Glowforge nearly unusable as far as I’m concerned, I want the former interface restored.


I’m so sorry for the trouble.

Can you share a screen shot of what you’re seeing?

To take a screenshot:

  • Mac: Press Shift-Command-4 and click and drag a box around your image. You’ll find the screenshot file saved on your desktop.

  • Windows: Click on the Start Menu and type “snipping tool”. Open the Snipping Tool > New then click and drag a box around your image. Click the Save icon and name and save your file.

You can post the screenshot here, or email it to us at support@glowforge.com


Soooo… what’s the answer? How do we opt out of the trial? Sounds like I’m having much of the same issue. I don’t have the time right now to re-learn the interface!!

I’m so sorry to ask for the screenshot again, but it looks like something may have gone wrong when it was uploaded to your forum post. Will you please reattempt, or send it to us via email at support@glowforge.com?

@paul.chabala - I’m sorry to hear that you’ve run into trouble also. We try to keep to one topic per post in the Problems and Support section. Can you create a new post with this question or email ust at support@glowforge.com? We’ll be happy to help you troubleshoot.

Thank you for the screenshot. I’ve shared notes about this with our team so we can investigate. Will you please let me know if adjusting the screen resolution settings in your operating system improves the issue? Also, may I have your browser information? Please do the following:

  1. Go to https://www.whatismybrowser.com/
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

As you can see, changing my browser default font size from 16 to 12 didn’t change the problem with the white box overlaying the workspace, to the extent that I can’t see the workspace. Please answer my original question: Can I "opt out?’ I’m not happy that the Glowforge “Beta test” is making the use of my machine such a poor experience.

Is it possible for you to update your browser? You are using a version of Firefox from 2016 – a year before Glowforge even started shipping – that doesn’t support a lot of modern web standards. I suspect that’s why you’re seeing all of those interface glitches.


I have the same problem - I posted screen shot here but haven’t gotten any feedback

All right. Firefox doesn’t have a newer version of the browser for my Apple computer. I have installed the most up-to-date version of Google’s Chrome browser that is compatible with my machine. Here is the screenshot. Now, I think this is getting beyond your scope of support, so I will ask one last time. Can I OPT OUT OF THE BETA or not. That is my request, and Glowforge support has either IGNORED me, or they are unable to respond to my request.

You posted a screenshot that didn’t show any problems and all you asked was whether you should be seeing Trial. Are you actually having the same issue where the screen is all messed up? If so, you might want to explain that in your support question, otherwise they won’t know what to help you with.


Sorry, I saw the announcement talking about the Trial. No problems for me. Thanks.

I was replying to lindyg11. I tried to help you earlier with my best guess about a browser version issue, but if you’re going to be nasty about it I’ll just leave you alone. Sorry to have tried.


Opting out of the trial features won’t fix your problem, because the position / scale box is not part of them, it’s part of the UI update. But yours doesn’t look right, and Support is trying to figure out why, so it will help if you can cooperate with them.

What version of Chrome did you install? If it’s not too old, you might be able to use @chris1’s “fix” that’s posted here: Unsupported hacks to mess with the Precision Placement box

And no, @chris1 and I are not Glowforge employees, just other users with experience who are trying to help you help Support figure out what’s going on with your interface. Support people’s messages will be in yellow, and it will say “Staff” next to their names.


Thank you geek2nurse. Hard for me to believe, in over a week of dialogue, you’re the first answer to the first question! Apparently, I’ve not received a single response from Glowforge support: there are no yellow messages. Dragging and dropping the hack icons into my interface toolbar had no effect. I very likely would never search Internet for something called an “unsupported toolbar hack” to resolve my issue. Your willingness to answer my question and offer a solution is very appreciated. Since I spent a substantial amount of money for this machine, I will work around this “new normal.” Without throwing it in the recycle bin! Thank you again!

The message up above from Ivan1 is from staff and is yellow.


Actually @Ivan1 is staff, and has replied to you several times. He replied to you three days ago asking you to re-upload your screenshot since it didn’t post correctly, and two days ago with additional steps to take.


Thanks for your patience while we investigated. We’ve been able to reproduce this behavior, and found that this is an issue in versions of MacOS 10.9 and older, which are unable to upgrade to the latest version of Google Chrome. Unfortunately, the solution will require updating your OS and browser. I’m so sorry for the trouble.